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Lab 8   RGB-IHS-RGB Transform and Image Sharpening 
Utilizes Textbook’s Remote Sensing Digital Database: Chapter  4 data. 

The objectives of this lab include learning about RGB and IHS (or HSV) color systems, 
the RGB to IHS to RGB transform, and different techniques for image sharpening.  The 
transform exercise is long & tedious, but it will teach you about different image file types 
and shortcomings/complicated work-arounds with ENVI software.  The tasks are done 
with tools in the ENVI Toolbox. 

Six questions are to be answered on the last page of this handout and one digital file is 
to be uploaded to the instructor. 

1) RGB-IHS-RGB transform 
Chapter 2 discusses the additive and subtractive systems of primary colors Red, Green, 
and Blue.  Chapter 9 discusses an alternative approach to color - the Intensity (Value), 
Hue, and Saturation system.  Figure 9-19 shows the scaling used for the IHS system.  
IHS is equivalent to HSV (ENVI uses HSV) 

Color images often have a pastel appearance because the images are undersaturated. 
RGB images have their saturation (purity of color) increased by transforming the RGB 
colors into IHS color space, and contrast-stretching the Saturation grayscale image.  
After the Saturation image is contrast-stretched, the IHS images are transformed back 
to RGB colors.  See Figure 9-20 and Digital Image 9-1.  Edge enhancement and the 
replacement of the intensity image with the panchromatic band can also be done prior 
to transforming the IHS images back to a RGB color composite. 

We will create an ASTER color IR image from a 9-band ASTER multispectral dataset 
and contrast-stretch the color IR with a “Linear 1%” stretch.   

1a) The 9-band ASTER data set is in the “Remote Sensing Digital Database \ 
Ch_4_Other MSS_Satellites” folder within the “ASTER_VNIR-SWIR” subfolder. 

 

 Start-up ENVI > File > Open > drive to the “ASTER_Geo” subfolder > select > 
 “ASTER_2002_Reflectance_30m_9-band_ENVI_.img” > Open 

 Zoom to Full Extent > Choose “Linear 1%” stretch.  You should see a color IR 
 image displayed in the View.  Click-on the 9-band file in the Layer Manager to 
 ensure that the Bands 3N-2-1 are loaded into R-G-B.  ASTER does not collect a 
 blue band, so Band 3N = NIR, 2 = Red, and 1 = Green. 
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 Highlight the 9-band file in the Layer Manager.  We will export this enhanced 
 color IR image using   File > Export Selected Layer to TIFF… > Name the color 
 IR image “ASTER_CIR_Original” and check “Display result”  >  OK 

 The exported color IR image should look exactly like the 3N-2-1 as R-G-B color 
 composite made from the 9-band data set.   

 The Chugwater Redbeds in the Red Rose Anticline appear as yellow rocks in a 
 Color IR image (see Figure 3-11H for location if you forgot) 
  
 Uncheck the 9-band dataset in the Layer Manager.   

 Let’s open 4 Views.     Views > 2 x 2 Views 
 The 3-band color IR image is in View 1.  Zoom to Full Extent 

 Highlight View 2 (empty View in the upper right).  This will ensure the IHS (HSV) 
 color composite is displayed in View 2. 

     1b) First we’ll use ENVI’s programmed “Saturation Stretch” Tool.   
 ENVI Toolbox > Transform > Saturation Stretch 
  The “Saturation Stretch Input Bands” window pops up. 
  Select the 3-bands in our CIR original image as R-G-B > OK 
  Name the output “ENVI_Sat_Str_”  > Open > OK 
  The ENVI saturation stretched CIR image appears in View 2 
 
  Views > Link Views > Link All > OK   (empty Views don’t link) 

  Pan and zoom around, comparing the original CIR image to the ENVI  
  saturated stretch image.   

Question 1:  Discuss the differences in the colors between the original ASTER CIR  
  image and the ENVI saturated stretched CIR image.  Do you prefer the  
  “instant” ENVI saturation stretch or your 2% saturation stretch that you  
  created at the end of this exercise?  (see page 7 below)  WHY? 

How was the Saturation enhancement done???  What steps are involved?  Next we’ll 
do our own saturation stretch.  First we transform our RGB image to IHS (or HSV) color 
space. 

 In the Layer Manager, drag & drop the “ENVI_Sat_Str” CIR image into View 1  
  (so we don’t get confused later).  You can uncheck this image in View 1. 
 Right-click “ENVI_Sat_Str” image in View 2 in the Layer Manager > Remove 

 Highlight the empty View 2 so our IHS image is loaded here. 
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 ENVI Toolbox > Transform > Color Transforms > RGB to HSV Color Transform  
 The “RBG to HSV Input Bands” window pops-up. 
 Sequentially click-on Band 1 to Red, Band 2 to Green, Band 3 to Blue > OK 

 The “RGB to HSV Parameters” window pops-up. 
 Select the Original CIR bands 1, 2, 3 as R, G, B  > OK 
 Name the file “ASTER_IHS”  > OK 
 
 The HSV color composite displays in View 3.  We want to see the individual Hue, 
 Saturation, and Value (Intensity) grayscale images in Views 2, 3, and 4. 

 Open the “Data Manager” 
  The “ASTER_HS” I, H, S grayscale images are at the top of the list. 
  Highlight View 2 
  Click-on Hue > Load Grayscale >  Zoom to Full Extent > Linear 1% 
 
  Highlight View 3 
  Click-on Saturation > Load Grayscale >  Zoom to Full Extent > Linear 1% 

  Highlight View 4 
  Click-on Value (Intensity) > Load Grayscale  >  Zoom to Full Extent >  
               Linear 1% 
 The four views should look like the screen capture below.  
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 Open the Histogram Stretch icon to the right of the Contrast Stretch drop-down 
 menu. 
 Click on each View and look at the histogram.  Look at the horizontal   
 scale on the histograms.  The scale used on the horizontal axis     
 (brightness) is different for the RGB image (View 1) and the Hue image   
 (View 2).  Saturation and Intensity (Value) use the same scale, which is   
 different than the scale used by RGB images and Hue images. 
 
Question 2:   A. Which HSV grayscale image has a significant skew to the left (meaning 
   most pixels are dark)? 

  B) What is the range of brightness for Hue pixels? 

  C) What is the range of brightness for Intensity (Value) and Saturation  
  pixels? 

  D) What is the brightness value on the horizontal axis of the Saturation  
  (View 3) histogram when you slide the vertical line to the left  so that 95%  
  of the pixels are below that brightness value  (Hint:  look above the vertical 
  line for the data brightness value and percentage of pixels to the left of the 
  vertical line). 
 
1c)  We want to pan and zoom to the same pixels in the four views. 
 Views > Link Views > Link All > OK 

 Select the Cursor Value tool and click-on the “Link Views” and the “Display 
 information for all Views” icons located along the top of the tool. 

Question 3: With the Cursor Value tool, Click-on a light brown – light orange agricultural 
field (fallow – no vigorous crops growing) in the color IR in View 1.  The data values for 
each type of image are listed in the “Data:”  entry space of the Cursor Value window.  
Write the data values you find for the same feature in the table below  

          
    

 

 

 

 

View Type of Image Data Value (brightness) 

View #1 Color IR  

View #2 Hue  

View #3 Saturation  

View #4 Intensity (Value)  
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1d) We want to brighten the Saturation grayscale image, but we cannot use the “Linear 
1%” because that would take the darkest 1% of the pixels and turn them black.  

 Highlight View 3 (Saturation)  >  Zoom to Full Extent  > Change the contrast-
 stretch from “Linear 1%” to “No stretch” 
 Open the “Histogram Stretch” 
 Move the Histogram away from View so you can see how the brightness 
 changes in the Saturation image as you send bright pixels to pure white (1.0) 

 Drag the maximum vertical slider (right side of the histogram) to the left so 
 that 2% of the pixels are brightened to 1.0.  (98% of the pixels are to the left 
 of the vertical slider).  The brightness value should be 0.8. 
 
NOTE:  The bright red, color IR pixels in the irrigated fields may be oversaturated and 
blend together with this saturation stretch (a visual loss of information).   

 Now we want to save the brightened Saturation grayscale image. 
 File > Export View > Image File  >  Ensure “Full” is active  >  
   Accept the other Defaults  >  
 
 Name the file “Sat_5pct_brighter_ENVI”  >  Display Results > OK 

 Press on the “+” sign next to the brighter Saturation image (.dat format) in the 
 Layer Manager View 3 list 
  Unfortunately, ENVI created a 3-band grayscale image when we only  
  want 1 band in the grayscale image!!  This is a bad software shortcoming. 
  
 “We must save our brightened grayscale Saturation image as a NEW, 1-band 
 grayscale image! 

 File > Save As  >  Save As (ENVI, NITF….)” 
 The “Data Selection” window pops-up.  Ensure our brightened Saturation 
 image is selected. 

 Click on “Spectral subset” button  >  The Spectral Subset window pops-up. 
 Select “Band 2” > OK  > OK    (all 3 bands are identical – so pick any one) 
 
 The “Save File as Parameters” window pops-up. 
  Name file “Sat_2pct_brighter_1band”    >  Check “Display results” > OK 

 Uncheck the older files in View #3 so only our “Sat_2pct_brighter_1band”    
  is checked.  >  
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1e)  Right-click on the “Sat_1pct_brighter_1band”   file in the Layer Manager. 
 > View Metadata > Raster tab 
 Our brightened, 1-band saturation image is a Byte data type.  8-bit.  DN 
 brightness ranges from 0 to 255.   
 
 Look at the histogram brightness values with the Histogram Stretch tool. 
  Brightness ranges from 0 to 255.  (see all the pixels at 255 on the right  
  vertical axis – we sent 5% of the pixels to pure white) 
BUT our Saturation image in IHS color space was a float (decimal) grayscale image 
with brightness DNs that ranged from 0 to 1. 

1f) So we have to convert our 8-bit image to a float image with DN range from 0 to 1. 
 ENVI Toolbox > Raster Management > Stretch Data 
 The “Data Stretch Input File” window pops-up. 
 Ensure our new 1-band Saturation .dat file is selected. > OK 

 The “Data Stretching” window pops up   
 Accept defaults. 

  Fill in the “Output Data Range” as Min = 0 and Max = 1 
  Data Type should be “Floating Point”   
   name the new grayscale image “Sat_2pct_brighter_1band_float0-1” 

    (see filled-in menu below) 

  > OK 
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1g)  Uncheck other files in View #3.   Only our new float grayscale Saturation image 
should be displayed and checked in the Layer Manager  
  
 View metadata for our new float image.  >  Close 
 Look at the histogram with the Histogram Stretch tool –  
  we can see 0 to 1 on brightness axis!! 

 We have increased the mean brightness and the standard deviation of the 
 saturated grayscale image by our 2% clip of the brightest pixels.   
 The original Saturation image had a mean of 0.21 and a StdDev of 0.19 
 
Question 4:  What is the mean and StdDev of the stretched saturation grayscale image? 
  (Hint:  Quick Stats has the answer).   This confirms numerically what we  
  see visually between the original and stretched saturation image. 
 
1h) Now we will combine our Hue, Intensity, and our brightened float 0-1 Saturation 
image and transform this new IHS combination into a hopefully much more vibrant color 
IR image!   
       ENVI Toolbox > Transform  > Color Transforms > HSV to RGB Color Transform 
 The HSV to RGB Input Bands window pops-up 

 The “H” is filled with our “ASTER IHS” Hue Band 1 
 The “S” is filled with our new brighter, float, 0-1 Saturation image at the top of  
  the list   (“Sat_5pct_brighter_1band_float0-1”) 
 The “V” is filled with our ASTER IHS” Val Band 3   > OK 

 Name the transformed RGB color IR image “ASTER_my_sat_str_ENVI” 

1i) The new color IR image in View #3 is much brighter and vibrant compared with our 
original color IR image in View #1!!  Success!!  
 To make a useful GIS geoTIFF of the brighter Color IR image in View #3 
  File > Export Selected Layer to TIFF >    
  name “ASTER_CIR_my_sat_str_GIS”    click “Display result” 

1j) After all that work, let’s save a chip view of the brighter Color IR image for the 
instructor.   
 Zoom to Full Extent > File > Chip View To… >  File >  Select JPEG 
 Name your output “YourName_ASTER_CIR_my_sat_str” 

  No need to display result   >OK 
 
 Upload the jpg to the instructor. 
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2) Image Sharpening 
This will be a short, simple exercise using DigitalGlobe’s high resolution satellite 
imagery over Tokyo.  In almost all cases a panchromatic (grayscale) image is acquired 
with higher spatial resolution compared with the multispectral color bands that collect a 
narrower wavelength range within a larger pixel.   The pan and multispectral bands are 
collected at the same time, so alignment/registration issues are minimized. 

Start up a new ENVI display.  The data are in “Ch_4_Other_MSS_Satellites” folder, 
inside the “High_resolution_Satellites” subfolder and its “Worldview-3-pan-MSS_Tokyo” 
folder. 
 
 Read the pdf description of the awesome Worldview-3 satellite is in the Tokyo 
 folder. 

 File > Open   drive to the Tokyo folder described above 
 Select  “Tokyo_WV-3_30cm_panchromatic_GIS” and  
   “Tokyo_WV-3_4-bnd_120cm_11-bit_MSS_GeoTIFF” 

 Views > Two Vertical Views 
 Drag the pan image into View #2  > Remove the pan image in View #1. 
  
 Views > Link Views > Link All > OK 
 Zoom to Full Extent   >  Contrast stretch 
 Pan around and zoom in and out –  
 Zoom in to the baseball field in the lower portion of the image. 
  Do you see a difference in the level of detail between  
              the 120 cm color and 30 cm pan images? 
 
NOTE:  30 cm is the highest spatial resolution allowed by the U.S. government for 
civilian applications at this time (April 2019) Brighten both Views with “Linear 2%” 
 Open the “Data Manager”    
  DigitalGlobe’s multispectral band sequence is:  
   Band 1, 2, 3, 4 = Blue, Green, Red, NearIR 

 Click on the “+” sign next to the multispectral data set.   
  Bands 3-2-1 are loaded as R-G-B 

Question 5:  Is the 3-band image displayed in View #1 natural color or color IR? 

 Highlight View #2 with the pan image 

 ENVI Toolbox > Image Sharpening > Gram-Schmidt Pan Sharpening 
 The “Data Selection” window pops-up 
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 Select “Low Spatial Resolution Multi Band Input File:” 
   Select the 120 cm data set  >  OK 
  
 The “Data Selection” window pops-up again 
 Select “High Spatial Resolution Pan Band Input File:” 
   Select the 30 cm pan image  >  OK 

 The “Pan Sharpening Parameters” window pops-up 
  Sensor choose WorldView-3 
  Accept Resampling Bilinear  
  Output Format TIFF (we are going to load this into GIS) 
  Name  “Your Name_pan-sharp_WV3_GIS” 
  check Display result    > OK (The filled in menu is shown below) 

 

 The fusion or pan-sharpening process can take a long time.  There is an 
 activity indicator in the lower right of the ENVI Display window. 

NOTE:  Use ENVI Help and type in “sharpening” in the Index search box.   Learn about 
the differences with the many tools ENVI offers.  

2a) move the 120 cm multispectral data into one view and in the other view display our 
30 cm pan-sharpened image.   
 Both files should default to 3-2-1 as R-G-B.  The two Views should still be 
 linked.  Contrast stretch both files with “Linear 2%” 

 Zoom to Full Extent  Evaluate the imagery and answer question 6A below. 
 Zoom-in to the in-field at the baseball stadium in the lower left corner of the  
   scene and answer question 6B below. 
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Question 6:  A. Do you see much difference in spatial detail when both the 120 cm and  
  30 cm images are Zoomed to Full Extent? 
 
  B. Describe the difference in spatial detail when zoomed-in to the baseball 
  in-field at baseball stadium. 
 
  C.  Each 120 cm pixel covers how much more area compared to each 30  
  cm pixel?  (Can answer with cm-based measurement or a magnitude  
  difference (for example, 5 x more area)  

2b) Let’s see what a color IR image looks like at the baseball field. 
 Right-click the pan-sharpened 4-band dataset in Layer Manager > 
  Change RGB Bands > select Band 4 as R, Band 3 as G, Band 2 as B > OK 

 Right-click the 120 cm,  4-band dataset in Layer Manager > 
  Change RGB Bands > select Band 4 as R, Band 3 as G, Band 2 as B > OK 

 A color IR image should be more detailed compared to a color image 
 because the long wavelength Near IR band is not scattered as much as the 
 short wavelength Blue band by the atmosphere. 

 Zoom out and then zoom in to the tennis courts in the lower right portion of 
 the scene.  The WorldView-3 imagery is discussed and the tennis court 
 features are interpreted in the textbook’s Figure 4-9.   
 
 Do you see a remarkable difference in clarity between the 30 cm Color  IR 
 image and the 120 cm color IR image? 

If you have time, try out the other image-sharpening algorithms.  The difference in 
colors and sharpness with different algorithms can be significant.   
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Lab 8  RGB-IHS-RGB and Image Sharpening     Name: 

Upload the following files to the instructor: 
 
 (1j) “YourName_ASTER_CIR_my_sat_str”  .jpg 
 
 

Question 1:  A. Discuss the differences in the colors between the original ASTER CIR  
   image and the ENVI saturated stretched CIR image.    

   B. Do you prefer the “instant” ENVI saturation stretch or your 2%   
   saturation stretch that you  created at the end of this exercise?  (page 7)   
   WHY? 

 
Question 2:   A. Which HSV grayscale image has a significant skew to the left (meaning 
   most pixels are dark)? 

   B) What is the range of brightness for Hue pixels? 

  C) What is the range of brightness for Intensity (Value) and Saturation 
   pixels? 
  
  D) What is the brightness value on the horizontal axis of the Saturation 
  (View 3) histogram when you slide the vertical line to the left  so that 95% 
  of the pixels are below that brightness value  (Hint:  look above the vertical 
  line for the data brightness value and percentage of pixels to the left of the
  vertical line).   
 
  
Question 3: With the Cursor Value tool, Click-on a light brown agricultural field (fallow – 
no vigorous crops growing) in the color IR in View 1.  The data values for each type of 
image are listed in the “Data:”  entry space of the Cursor Value window.  Write the data 
values you find for the same feature in the table below  

          
    

 

 

 

 

View Type of Image Data Value (brightness) 

View #1 Color IR  

View #2 Hue  

View #3 Saturation  

View #4 Intensity (Value)  
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Question 4:  What is the mean and StdDev of the stretched saturation grayscale image? 
  (Hint:  Quick Stats has the answer). 
   

Question 5:  Is the 3-band image displayed in View #1 natural color or color IR? 
 

Question 6:  A. Do you see much difference in spatial detail when both the 120 cm and  
  30 cm images are Zoomed to Full Extent? 
 
  B. Describe the difference in spatial detail when zoomed-in to the baseball 
  in-field at baseball stadium. 
 
  C.  Each 120 cm pixel covers how much more area compared to each 30  
  cm pixel?  (Can answer with cm-based measurement or a magnitude  
  difference (for example, 5 x more area) 
 

  


