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Lab 7   DEMs and Lidar 
Utilizes Textbook’s Remote Sensing Digital Database: Chapter 7 data. 

The objectives of this lab include enhancement of DEMs generated with radar and lidar 
using image-processing tools and visualization to improve understanding of the models.  
ENVI Toolbox contains the tasks that we will use for this lab.  A short video for the lidar 
section that reviews the tools in the new ENVI LiDAR display is in the Lab_7_Data 
folder  

Two digital files are to be uploaded to the instructor and ten questions are to be 
answered on the final pages of this handout. 

Radar DEMs 

1) Airborne L-band and P-band radar were flown over the Fairbanks, Alaska area to 
generate a Digital Surface Model (DSM) and a Digital Terrain Model (DTM).  See 
discussion in the textbook Chapter 7.  The data are located in the Remote Sensing 
Digital Database \ Ch_7_DEMs in the Chapter 7 folder. The path is: 

 Plate 23 P-and X-band GeoSAR_AK \ 
          GeoSAR_DSM-DTM_ \  DSM, DTM, and Ortho_Radar_Image folders 

  
Subfolders in “GeoSAR_DSM-DTM_” folder 

2) Review the “READ ME…” pdf in the “Plate 23 P-and X-band…” folder.  The READ 
ME file provides an overview of the technology applied and examples from the textbook 
of final products that can be generated with remote sensing and GIS software. 

3) Open the newer ENVI “GIS-look” program  > File > Open >   

 drive to the “Ortho_Radar_Image folder and select “ORI_N6445W14800.tif” 
 > Open 
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 > Zoom to Full Extent Fairbanks is on the East side of the image, North 
     of the Chena River. 
      
Question 1: A. In which direction is the radar beam pointing  (N, S, E, or W)?  

  B. Why does the river south of Fairbanks have a very dark? 

4) DSM:  Open the DSM folder and  load  “DSM_N6445W14800.tif” into the View. 
 Right-click on this DSM layer in the Layer Manager > Quick Stats 
 The “Statistics View:….” window pops-up. 
  In the upper left, Select Plot > Histogram Plot 1 
 
Question 2: What is the minimum elevation of this DSM? 
 
 
 4a) ENVI Toolbox > Classification > Raster Color Slices    
 Select the DSM in the “Data Selection” window    >  
 Accept Defaults: 16-slices, rainbow color scheme > OK  

 4b) ENVI Toolbox > Terrain > Create Hill Shade Image 
 Select the DSM in the 
 “Select Hill shade Input DEM File” window    > OK 
 The “Hill shade Image Parameters” window pops-up 
  Enter “25” for Sun Elevation Angle 
  Enter “270” for Sun Azimuth Angle 
  Select “B-W LINEAR” for Color Table to Apply 
  Change “Stretch” to “0.0”  (no stretch applied) 
  FileName:  “YourName_DSM_hs_ENVI”  > OK 

 
 The hill shade DSM displays in the View.  Zoom to Full Extent 
 Zoom-in and pan around  

Question 3: What natural and man-made features are generating the surface on the 
DSM?   (Hint: Turn off all layers in the Layer Manager except the hillshade DSM and the 
ORI radar image.  Turn the top layer on & off to identify features.  ) 

Turn on the Raster Color Slice layer in the Layer Manager.  If your hillshade DSM is 
above this layer in the Layer Manager, use the Transparency Tool to fade the hillshade 
DSM so the color on the DSM can be seen. 
 Zoom-in to an area of interest.   
 Type in the scale 1:25,000 (near the top-center of the ENVI display window) 
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 Let’s save a jpg of the enlarged area (this display) for the instructor 

 File > Chip View To > Image     
 The “Chip to File Parameters” window pops-up.   
 Choose Output Format “JPEG” 
 Name the file “YourName_color-coded_25K_DSM” 
 Don’t “display result”    We will look at the jpg outside of ENVI. 

 Open up your jpg.  Is the quality acceptable?  What’s missing?  Where’s the 
 scale bar, legend, coordinate grid – essential cartography elements for GIS and 
 map-making?  This is just a picture – it has very little value in the real world. 
  
 The new ENVI GIS-look front end seemingly cannot attach cartographic 
 elements to exported images – unless you start ENVI in 32-bit mode and have an 
 ArcGIS license…?  That is not good – if this is true and there is no work-around. 
 You can create and export images with scale, coordinate grid, N-arrow, logos, 
 text boxes, and other cartographic elements using the older ENVI Classic and 
 the “QuickMap” tool. 
 
 Going forward, if you use this new ENVI front end, Export your enhanced 
 imagery and DEMs in the geoTIFF format  so you can use GIS software to add 
 symbology and critical cartographic elements.  

 4d) Let’s create a 3D Surface View with  
 our color-coded hill shade DSM (displayed here).   

 BUT first, the two files are separate in the color-coded,  
 hillshade DSM – 1) the faded grayscale hillshade  
 and 2) the 16-slice color DSM.   
  
 We need to combine these two images into one so 
 we can use the 3D Surface View (and other  
 visualization software).   The combined color-coded  
 hill shade image will be draped over the DEM to enable 
 perspective 3D viewing. 

 To combine the full scenes of the two files that we see on the screen into one 
 raster  image file we should “Zoom to Full Extent” to see what is going to be 
 saved. 
 File > Export View To > Image File   
 The “Export View to Image File” window pops-up. 
  We want the Full scene, so click the button next to “Full”  
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  Note the pixel size is the original data size, the Zoom Factor is 1.0000 
  We can output in ENVI format for this exercise. 
  Name the Output file:  “hs_with_color-coded_DSM_ENVI”   > OK 

 The “hs_with_color-coded_DSM_ENVI”  image is displayed in our View. 

 4e) Now we can use the ENVI visualization tool! 

 ENVI Toolbox > Terrain > 3D Surface View 
 The “Select 3D SurfaceView Image Bands…” window pops up 
 
 Sequentially select Band 1, Band 2, Band 3 that make up the  
 “hs_with_color-coded_DSM_ENVI”  color image so that the R, G, B buttons are 
 filled in the correct sequence in the” Available Bands List” menu.  > OK 
 
 Next we select the “Associated DEM Input File”.   
 Select > “DSM_N6445W14800.tif”  > OK 

 The “3D SurfaceView Input Parameters” window pops-up. 
  Click on “512” and accept the other defaults  > OK 

 The 3D SurfaceView display pops-up with your color-coded, hill-shade DSM 
 with 5X vertical exaggeration draped on the DSM.  Many options are available in 
 this display, including saving the surface view as a VRML file. 

 

 

Let’s show this to the instructor.  In the “3D SurfaceView” display, 
 File > Save Surface As > Image File     
 The “Output Plot to Image File” window pops up (see next page).   

 We want a color jpg of this perspective view so we set Resolution as “24-bit 
 Color (BSQ)”, Output File Type as “JPEG”, and Compression Factor as “0.95” 
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 Name the jpg “YourName_DSM_Perspective_View”  > OK 

 Upload to the instructor. 

 Close the “3D_SurfaceView” window. 

5) DTM   Let’s compare the DTM to the DSM.  Views > Two Vertical Views 

Activate View 2 by clicking on the empty View 2.   

 File > Open drive to the “DTM” folder.   Select “DTM_N6445W14800.tif”  > Open 
Zoom to Full Extent. 

 5a) ENVI Toolbox > Terrain > Create Hill Shade Image 
 Select the DTM in the “Select Hill shade Input DEM File” window    > OK 
 The “Hill shade Image Parameters” window pops-up 
  Enter “25” for Sun Elevation Angle 
  Enter “270” for Sun Azimuth Angle 
  Select “B-W LINEAR” for Color Table to Apply 
  Change “Stretch” to “0.0”  (no stretch applied) 
  FileName:  “YourName_DTM_hs_ENVI”  > OK 

 5b) Views > Link Views   “Link Views” window pops-up > Link All > OK 

 We want to use the “Cursor Value” tool to see the elevation at the same pixel on 
 the DSM and DTM.   
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 The DTM and hillshade DTM and the DSM and hillshade DSM should be turned 
 on in the Layer Manager.  Un-check all other files. 

 5c) In the Cursor Value menu,  
  press “Link Views” button and  
  press “Display Information for all Views” button. 

  Now you should see the elevation in the DTM and DSM appear in the  
  Cursor Value window. 

 

 

 

  

 

     DTM elevation is here (226.6 m) 

 

 

 

     DSM elevation is here (235.6 m) 

 
 
Question 4: A. what is the DTM and DSM elevation at the airport runway? 
 
  B.  What is the elevation of the DTM and DSM about 3.5 km NW of the  
  airport runway, along the crest of the ridge? 

  C.  What causes the DSM and DTM to have different elevations along the  
  crest of the ridge about 4 km NW of the airport runway? 

  D.  Why was one radar wavelength used primarily for the DSM and the  
  other radar wavelength used to generate the DTM?   

Lidar 
6) Let’s start over with a new ENVI Display.  File > Exit   to close the Radar DEMs 
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Using your computer’s file management system,   
 Open the Remote Sensing Digital Database and then open the subfolder 
 “Ch_7_DEMs”.  There are five DEM examples in this folder.  We are going to use 
 the lidar data in the subfolder “Plates_21-22_ LiDAR_DVC-CA”.   
          (See file structure below) 

 

The lidar data is in standard .las format and is located in the “DSM_First-Return-LiDAR” 
and “DTM_Last-return-LiDAR” folders.  This .las data was processed and converted to 
geoTIFFs to simplify use in a GIS, CAD, or other geospatial software.  These geoTIFFs 
are located in the “DSM_First-Return_Answer” and DTM_Last-Return_Answer” 

A color orthoimage is in the “Aerial_Orthophoto” folder.  Open these folders to 
familiarize yourself with the many files that you will be working with in this lab.  Many of 
the files are intermediate forms that were generated by ENVI, ERDAS, and ArcGIS 
software as the original lidar data was processed. 
 

6a) We will be working with lidar data of a suburban area west of Pleasant Hill, 
California. 

The source of the lidar data is the Contra Costa County 2008 Orthophotographs & Lidar 
project.  Available at: https://gis.cccounty.us/Downloads/Lidar/2008/   the zip is 70 GB! 
 
The lidar and orthorectified image are in the State Plane CA III FIPS 0403 Feet (US) 
NAD-83 Coordinate System. 
 
6b) Start up a new ENVI Display.    File > Open    the orthorectified aerial color image 
      “g09d2_3_color_mar-apr2008_1meter”  > Open 
 >  Zoom to Full Extent 

https://gis.cccounty.us/Downloads/Lidar/2008/
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 Review what and where the land cover/land use features are in this area, 
 including single family dwellings, golf course, non-irrigated grass-covered terrain, 
 a road network with many curves, etc. 

6c) Now we will review the metadata associated with the .las lidar files 
 ENVI Toolbox > LiDAR > View LAS Header 
 Drive to the “Data” folder and open the “DSM_First-Return-LiDAR” 
 Select “G09D2_3(2).las”  > Open 
 Examine the metadata in the header. 
 
Question 5:  A. What is the minimum and maximum elevation (Z) in the DSM? 

 ASPRS helped establish standards for lidar data.  The points are classified into 9 
categories as shown below.  However, the metadata for our dataset lacks this 
classification as it notes with “0” that the lidar points were  “Created, never classified” 

 

Portion of the metadata for our lidar data 

 

 

 

 

 

 Now we will look at the metadata for the DTM. 
 ENVI Toolbox > LiDAR > View LAS Header 
 Drive to the “Data” folder and open the “DTM_First-Return-LiDAR” 
 Select “G09D2_3.las”  > Open 
 Examine the metadata in the header. 
 
Question 6:  A. What is the minimum and maximum elevation (Z) in the DTM? 

  B. How many lidar points are in this DTM data set?     
   (NUM_POINT_RECORDS) 
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6d) Now we will switch to a new display ENVI has created to view and interact with lidar 
data.  A 9-minute video is included in the Lab_7_Data_Video folder that provides an 
overview of the ENVI LiDAR tools and display options to help you be more efficient 
working your way through the lidar portion of this lab.  
 
 ENVI Toolbox > LiDAR > Launch ENVI LiDAR 
 We will first load the DSM into this view.   File > Open  Select “G09D2_3(2).las” 
 > Open   You should see this display.  The DSM is displayed as a “Solid” surface. 

 In the layer manager, right-click on “DSM” > change to “Wireframe” 
 Zoom-in until you see clearly see the the 1 meter grid. 
 In the layer manager, right-click on “DSM” > change to “Solid”  Zoom-out 

 
 

 The window at the lower left shows the extent of the entire DSM.  It has a 
 rectangular outline that shows what portion of the DSM is shown in the main 
 display.  Use your cursor to draw an outline around the entire thumbnail image 
 (approximately 918 x 616).  The entire DSM is shown in the main display.  

6e) Interrogate the drop-down menus and the ribbon of icons across the top of the ENVI 
LiDAR window.  We’ll activate a few of them. 
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 View > Height Legend  (note the units are in meters!) 
 Help > Help Contents  (very useful to read before proceeding too far) 
 Reset Perspective View  icon > Move your mouse around to rotate and tilt the  
      model  
  Zoom-in on the grove of trees along the top margin of the DSM.  Change  
  the rendition of the model between Wire Frame to Solid (see below) 

     

Question 7:  A. Why do the trees have elongated, near-vertical sides around the extent  
  of the tree canopy? 

  B. What do the red dots at the top of the canopy represent? 

 Reset Isometric View icon > Click on the model in the display  and roll your  
      mouse wheel to zoom in and out.  
     > Click on the left and right buttons on your mouse 
      and pan around the model.   

 Reset Isometric View icon > Click-on the Select Cross Section icon. 
 Move your cursor to the bottom margin of the model, click once and move your 
 cursor to the top of the model and click once to generate a N-S cross section. 

7) A “Cross Section” window pops-up at the bottom of the ENVI LiDAR window.  
  We’ll interact with a few of the tools at the top of the display. 
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 Often the width of the window automatically becomes too large.  At the upper 
 right of the “Cross Section” display is “Thickness (cm):”    Change to “500”. 

 The “Movement” tool has up-down arrows.  The default value seems to be “100”.  
 Clicking on the arrows moves the cross section in a direction perpendicular to the 
 cross section.  Increase number to “500” and the cross section moves in larger 
 increments. 

 The “Angle” rotates the cross-section.  Increasing the number from the default of 
 “1.000” moves the cross section in larger increments. 

 “Reset Position” places the cross section back to its original position (maybe? To 
 the bottom margin of the DSM...).  Click the “Movement” Arrow to move the cross 
 section across the model at intervals of “500”. 
  
 You can zoom into a feature of interest in the cross section with your mouse 
 wheel. 

Question 8:  What features do you see on the DSM cross section as you traverse the  
  model? (refer to the orthophotograph in the ENVI window that we opened  
  first)  

8) Click on the “Measurement Tool” icon (a ruler) in the ENVI LiDAR window.  Measure 
the height of some of the trees in the “Cross Section”.   

Question 9:  What is the height (in feet) of the tallest tree that you measure? 

 To remove the white banners with the XY and Z elevation at the measurement 
 sites > Right-click on the white banner > Delete Annotation  
 To remove the Cross Section vector lines on your ENVI LiDAR display, close (X) 
 the Cross section display.  

9) The last DSM exercise will use the “Color by Viewshed Analysis” icon in the upper 
ribbon of the ENVI LiDAR menu.   
 
Viewshed analysis is widely used to evaluate the visual impact to a person standing at a 
specific location of existing land cover/land use features, new construction, proposed 
logging, new hedgerows or barriers to “hide” infrastructure, etc.    

 

 Ensure you are zoomed-out so the entire DSM is displayed (use thumbnail tool in 
 lower left corner) 
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 Click-on the “Color by Viewshed Analysis” icon.  Instructions pop-up. 

 > OK 

 The DSM turns into a grayscale image. 
 Move your cursor to the southern slope near the top of the hill in the north margin 
 of DSM.  (imagine you are hiking up the slope toward the crest and turn around – 
 what do you see?) 
  Ctrl-Click at the site for the Viewshed Analysis  
 
  Those features that you can see from this site are displayed in green  
  (maybe).  The Add Observer Point menu pops-up.  Change Radius to  
  “500” and Visible Color to “Red” > OK 

    

  The pop-up instructions above tell us how to export this analysis. 
     File > Export > Viewshed Analysis Raster 
  This Export option did not allow me to name the file, or to direct it to a  
  specified folder…maybe you can figure out how to make the export work  
  for you…  
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  I’m just going to do a simple screen capture of my Viewshed perspective  
  view using the ENVI LiDAR  File > Screenshot to Powerpoint > Save As 
   
  “LastName_DSM Viewshed” 

  (If you don’t have Microsoft Powerpoint software on your computer, just  
  take a screen capture of your viewshed DSM and save it as a jpg) 

  Upload this graphic to the instructor. 
 

10) We’ll next look at the DTM.   File > Open > “G09D2_3.las”  > Open 
 The DSM disappears.  The DTM is loaded into the display.   
 In the Thumbnail display of the DTM (lower left corner), draw a large rectangle 
 over the East half of the DTM  so you capture the red hill and dark blue terrain. 

 The ENVI LiDAR can only display a 2000 x 2000 area on the main display.  
 Accept the program’s redrawn area. 

 The ENVI LiDAR program displays the DTM, but in the Layer Manager it is 
 labelled as “DSM”.  The software cannot identify the type of DEM being loaded. 

 Right-click  on “DSM” in the Layer Manager and alternate between Solid and 
 Wire Frame.  Zoom in to see the level of detail in the DTM. 

 If you see a grayscale DTM in the display, click on the Height Palette Editor” icon 
 and load the “Rainbow” palette (lower left corner of the menu) 

  Note the flat pads that have been constructed for the suburban homes  
  with cut and fill on the sloping terrain. 

  Notice how the trees in the DSM have been removed from the hill in the  
  north portion  of the DTM model. 

 Display the “Solid” model.  Click-on the “Reset Perspective View” icon. 

 Click on the “Filter Points By Height” icon.  (see below) 
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 Move the “Minimum (Min.) Project Height” slider to the right. 
 Set your minimum height at “100.00”   > OK 
 
Question 10.  What are you simulating by raising the minimum height on the DTM? 
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Lab 7   DEMs and Lidar                          Name: 

Upload the following files to the instructor: 
 
 (4) “YourName_color-coded_25K_DSM”    jpg 
 
 (4)  “YourName_DSM_Perspective_View”      
  
 (9) “LastName_Viewshed”   Powerpoint, jpg, or other format. 
  

 
Question 1: A. In which direction is the radar beam pointing  (N, S, E, or W)?  

  B. Why does the river south of Fairbanks have a very dark? 

Question 2: What is the minimum elevation of this DSM? 

Question 3: What natural and man-made features are generating the surface on the 
DSM?   (Hint: Turn off all layers in the Layer Manager except the hillshade DSM and the 
ORI radar image.  Turn the top layer on & off to identify features. ) 

Question 4: A. what is the DTM and DSM elevation at the airport runway? 
 
  B.  What is the elevation of the DTM and DSM about 3.5 km NW of the  
  airport runway, along the crest of the ridge? 

  C.  What causes the DSM and DTM to have different elevations along the  
  crest of the ridge about 3.5 km NW of the airport runway? 

  D.  Why was one radar wavelength used primarily for the DSM and the  
  other radar wavelength used to generate the DTM?   

Question 5:  A. What is the minimum and maximum elevation (Z) in the DSM? 

Question 6:  A. What is the minimum and maximum elevation (Z) in the DTM? 

  B. How many lidar points are in this DTM data set?     
   (NUM_POINT_RECORDS) 

Question 7:  A. Why do the trees have elongated, near-vertical sides around the extent  
  of the tree canopy? 

  B. What do the red dots at the top of the canopy represent? 
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Question 8:  What features do you see on the DSM cross section as you traverse the  
  model? (refer to the orthophotograph in the ENVI window that we opened  
  first)  

Question 9:  What is the height (in feet) of the tallest tree that you measure? 

Question 10.  What are you simulating by raising the minimum height on the DTM? 

 


