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Lab 4    Image Processing 2 
Utilizes Textbook’s Remote Sensing Digital Database: Chapters 3, 5, and 8 data. 

The objectives of this lab are to use image enhancement tools (see Chapter 9 Digital 
Image Processing for discussion of enhancements) to process thermal IR, UAS (drone), 
and multispectral data and to introduce band math.  The tasks we will complete with this 
lab are done with tools in the ENVI Toolbox: 

 Band Math 
 Density slice  
 Mosaicking 
 Masking 

Four digital files are to be uploaded to the instructor and four questions are to be 
answered on the last page of this handout. 

IMPORTANT NOTE: The “new” ENVI with the GIS-look does not retain display 
enhancements for images when you use Save As. These include rotating, zooming, 
contrast, brightness, sharpening, stretching, Portals, or viewing multiple layers. Use the 
Export View To > Image File to retain displayed enhancements.  Unfortunately, it 
appears that when exporting an enhanced 1-band grayscale image, ENVI generates a 
grayscale file that contains 3 identical grayscale bands.  This is bad.  Can you find a fix? 

1) Band Math  
In this exercise we will convert raw DNs displayed on an ASTER thermal IR surface 
temperature image of the Ghanzi area, Afghanistan to degrees Celsius (°C).  See 
textbook Chapter 5 and Figure 5-6 for more background information. 

 Open the ENVI software.   File > Open  

 Locate the nighttime, Level 2 ASTER TIR surface temperature image  
 (AST- 08 product) from the Remote Sensing Digital Database following this path:   
 
 \ Ch_5_Thermal_IR \ Fig_5-6 Afghanistan_ASTER_Surface_Temp \ 
 Nightime 

 Choose the TIF image in the “Nightime” subfolder:
 “Ghazni_AST_08_TIR_Surface_Kinetic_Temp_Nighttime_31aug2013_integer” 

 Zoom to Extent          Click-on the Cursor Value icon 
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Use the Select Arrow to move the crosshairs around the ASTER TIR image. 
  Move from bright pixels to dark pixels. 
  View Metadata 
  Quick Stats        
   Select Plot (drop-down menu in upper left) > Histogram Band 1 

NOTE:  The Terra platform that hosts the ASTER system is moving from south to north 
during the nighttime orbit.  The rotation of the earth is demonstrated by the wedge-
shaped black margins of NO DATA on the East and West margins.   The system 
records a null DN of 2000 in this NO DATA area.  Ignore the wedge-shaped margins. 

Question 1:  A. What is the range in DN values (min – max)? 

  B. What is the DN range for the bin with the highest Count (located at the  
  peak of the histogram)? 

1a) Brilliant people at the Jet Propulsion Lab (JPL) and NASA deliver calibrated ASTER 
thermal IR products for a variety of applications at no cost.  The original DNs of the 
pixels in a Level 2, AST-08 product (calibrated surface temperature) can be converted 
to degrees Celsius (°C) using the following formula (Gillespie and Rokugawa, 2001): 

  XXXX = DN of pixel on calibrated AST-08 Level 2 image 
  2730 = constant 
  YYY = Value when 2730 subtracted from DN on image (XXXX) 

  XXXX – 2730 = YYY * 0.1 = ZZ.Z°C 

You can do this calculation on paper or with a calculator for each pixel you measured 
with the Cursor Value tool earlier.  That is very inefficient.  Fortunately, many image 
processing and GIS software packages include tools for you to write your own 
mathematical operations that can be applied to the entire image.   

ENVI supplies the Band Math tool.  Band Math is a powerful tool for remote sensing.   
Let’s use it! 
 Toolbox > Band Algebra > Band Math 



3 
 

3 Introduction to Remote Sensing  Principles, Interpretation, and Applications 
F. F. Sabins and J.M. Ellis, 2020, Waveland Press.    Contact:  jellis@ellis-geospatial.com 

 

 

Push Help to see examples and better understand how band math works!! 

   Our formula XXXX – 2730 = YYY * 0.1 becomes (float(b1) - 2730) * 0.1 

  “float” is used before each pixel’s original DN value to ensure our degree  
  Celsius result supports a decimal point. 

 Enter the Band Math formula into the “Enter an expression” box  
    > Add to List  

  Save the Band Math formula as “ASTER TIR DN to Celsius” so you can  
  use it again in the future. 
   > OK       The “Variables to Bands Pairings” window pops up. 
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  Click-on the “Band 1” in the “Available Bands List”  
   The thermal IR band will automatically fill in the “Variables used in  
   expression:”    Name the output file “ASTER TIR Celsius_ENVI”. 
   This new image will be in ENVI format (.img with .hdr). 

 The ASTER TIR °C image automatically loads into the View.  The new image will 
 be very dark if “No stretch” is set.  Contrast stretch with” Linear 1%” 

 Roam around the image with your “Cursor Value” tool.   Very dark blobs of pixels 
 along the East margin have negative °C values.  These may be clouds or errors.  
 Best to ignore. 

 If you are more comfortable with Fahrenheit degrees (°F), use this formula for 
 converting °C to °F 
  (32°C × 9/5) + 32 = 89.6°F 
 
Question 2:   A. What is the highest temperature in °C recorded by the ASTER TIR  
  system?  (Hint: Refer to the Quick Stats Histogram table) 

  B. Do you think you should use this highest temperature if only one pixel  
  recorded it?   YES  or   NO 
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 1b) Our “ASTER TIR Celsius_ENVI” grayscale image is not useful for GIS.  Let’s 
 quickly convert it to a geoTIFF format. 

 Right-click on “ASTER TIR Celsius_ENVI” in the Layer Manager  
  > Export Layer to TIFF 

  Name your geotiff output file “Your Name_ASTER Temp GIS.tif” 

  Upload to the instructor. 
  If you have access to a GIS, open your geoTIFF image in the GIS. 

 
2) Density Slice.   Use the “Raster Color Slices” tool in the ENVI Toolbox. 
Temperature patterns on our ASTER TIR °C grayscale image can be understood more 
easily if we perform a density slice on the image. 

 Highlight the  “ASTER TIR Celsius_ENVI” image in the Layer Manager. 

 ENVI Toolbox > Classification > Raster Color Slices 
  A “Data Selection” window pops up – ensure the “Band Math (…)” entry 
  under our “ASTER TIR Celsius_ENVI” image is highlighted. >  OK 

 Automatically ENVI generates a “Raster Color Slice” image with 16 slices! 

  NOTE Problem!  ENVI created 12 density slices where there is no data 
  because our ASTER TIR DN histogram is not “normal” – it is skewed to  
  the right.    Image processing algorithms often assume a “normal”   
  distribution of data.  But often the data DNs are skewed!!  Always look at  
  your results to see if they are reasonable.  See below 
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 We MUST correct this very bad and misleading density slice image!! 
  Click-on the 2nd to the upper left icon “New Default Color Slices…” 

  The “Default Raster Color Slices” window pops up. (see below) 

 

  Change the Num Slices to “’6” and the Data Min to “5” > OK 

 You now see the color density slices more accurately reflect the distribution of 
 surface temperatures on the ASTER TIR image.   

 In the “Edit Raster Color Slices: Raster Color Slice” window now on your screen, 
 save the color density slices as a shapefile.  Drop-down menu on diskette (6th 
 icon from left) > Export as Shapefile… 

  Name your shapefile “YourName_ASTER_Temp_Density_Slice” 
  If you have access to a GIS, load this shapefile and color-code. 

  Upload your shapefile to the instructor. 

NOTE:  Converting a raster color density slice image to a vector polygon shapefile 
enables you to improve the symbology and legend, and fuse with other layers in your 
GIS.  The nighttime surface temperature shapefile is awesome when faded and draped 
on the 30-meter SRTM DEM (available in the Remote Sensing Digital Database, 
Chapter 5 Thermal IR folder) 

3) Mosaicking. 
This exercise is quick and simple with ENVI.  We will load two overlapping color images 
acquired by a USGS drone and digitally mosaic them into one image.  

 Remove all files from the Data Manager and Layer Manager. 

 The two georeferenced images are in the Remote Sensing Digital Database. 
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  File > Open   Open the folder “Ch_8_sUAS_Manned-Aircraft” and its subfolder 
 “UAS_USGS_West Fork Mine”.  The two images to load are 

   “dji__0260_georef_GIS.tif” and “dji__0770_georef_GIS.tif” 

 Zoom to Extents 
  With the Cursor Value, roam over the black edges around the images. 

Question 3:  What is the DN at the black edges of the two images? 

 ENVI Toolbox > Mosaicking > Seamless Mosaic  > green + sign (Add Scenes) 

 In the “Data Selection” menu, select both images (ctrl key) or Select All > OK 

 Click-on the “Color Correction” tab > do not check Histogram matching 
  (the mosaicked image is overly bright if you check this function) 

 Click-on the “Seamlines/Feathering” tab > check None 

 Click-on the “Export” tab > “Output Format” dropdown menu TIFF 
  “Output Filename” > “Drone mosaic” 
  “Data Ignore Value” . “0”   (zero – so the black margins that overlap are  
                                              transparent) 
 Click “Show Preview”     (see tool and tabs below)  

 

 Check the preview.  If OK, Click Finish 

  The processing could take a minute or two.  The mosaic is over 160 MB. 
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 Zoom in along the seam between the two images.  (Scale 1:250). 

 Let’s save a thumbnail jpg and upload it to the instructor. 

 File > Chip View To > File   Choose “Output Format” as JPEG. 

  Name the file “YourName_drone_mosaic_thumbnail” 

  No need to display.  Look at it when it is saved to your folder for this lab. 
   My thumbnail was tiny – 60 KB and it looked OK! 

 Upload thumbnail jpg to the instructor. 

4) Masking. 
Exit the GIS-look ENVI that we have been using, and open ENVI Classic.  
I find that older ENVI Classic is much more efficient at generating a Mask  
from a multispectral data set compared with the new ENVI front end.   
I have included the Masking exercise with the new ENVI front end as an   
alternative supplement at the end of the Lab Manual.   

We are going to use a Landsat TM SWIR1 band (TM band 5) to mask water around 
islands in the Bahamas so we only process the features on the islands without 
interference or noise from the water. 

 The textbook Chapter 3 discusses how Landsat was used for generating a 
 bathymetry map of the seafloor in this area. Plate 9 and Figure 3-16 show the
 enhanced satellite image with masks that you will be using in this exercise.  

The Landsat data is in the Remote Sensing Digital Database \ Ch_3_Landsat folder. 

In ENVI Classic   File > Open Image File 

 Follow this path:   \ Plate_9_Bathymetry \ Original_Landsat_Data 

 to the “Exumas_Bathy_1984_Landsat_6-band_clip_GeoTIFF” data  > Open 

An “Available Band List” window pops up with the six bands.  (see below). 
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 Click the “RGB Color” button  >  Click on Band 3 first, Band 2 second, and Band 
 1 last to create a natural color image (reflected red-green-blue light as R-G-B). 
  
 Click-on “Load RGB”.   A 3-window display pops up.  The color image is 
 automatically loaded  in “Display #1” with its 3 windows.The full scene is in the 
 lower left “Scoll”, a 1:1 zoom factor image is in the large (“Image”) window 
 (outlined in red on the “Scroll” window), and an enlargement is in the “Zoom” 
 window (outlined in red on the “Image” window.    The “Available Band List” is to 
 the right.   See below. 
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NOTE:  Remember that Landsat TM 30 m bands are numbered 1-5 and then 7 
(SWIR2).  See textbook Table 3-1.  TM band 6 is a 60 m thermal IR band.  We did not 
include the thermal IR band in our layer stack, so TM band 7 is listed as “band 6” by 
ENVI (and other image processing software).   
 
4a) You are looking at a natural color image of the clear water, underwater sand bars in 
shades of blue, and white carbonate sands around the islands.   
  
 Access one “Contrast Stretch” tool in the “Image Window” by clicking-on  
  Enhance >     In the Drop-down menu  Select   “ [Scoll] Linear 0-255” 
   this will reset the displayed image to the original DNs. 
    
 In the “Image” window      Tools > Cursor Location/Value…      

  A “+” shows up in the “Image” window and a small  
  “Cursor Location/Value” window pops up.   If you are looking at the   
  original data (not contrast-stretched) the “Scrn:” and “Data:” R-G-B DN  
  values are identical.     

   Move the Cursor Value tool around the image to understand the  
   range of DNs in the water and on land.   

  To brighten the color image  Enhance > “[Scroll]” Linear 2%  
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   Move the Cursor Value tool around the image.  Note how the  
   enhanced pixels on the screen (“Scrn:”) have DNs that are different 
   compared with the original “Data:” 

 Now we will compare the individual grayscale bands to the natural color image by 
 opening up a second Display (“Display #2). 

  In the “Available Bands List” menu,   click-on “Band 1” >  
   click-on “Gray Scale”  >   click-on “Display #2”  > New Display   >   
   click-on “Load Band” 
  Band 1 pops up in Display #2 to the right of Display #1. 

 4b) Let’s link the two views so we can compare the color image to the bands.  
  In Display #2    Tools > Link > Link Displays    

   The “Link Displays” window pops up.    > OK 

 

   Choosing to start the link in Display #2 makes Display #2 the  
   master when moving around the scene  

 Now you can move the Image rectangle outline in the “Scroll” window of Display 
 #2 around to  see different parts of the scene in color and as grayscale bands. 

  Sequentially display Bands 1 through 6 in Display #2.  Contrast-stretch  
  as needed with the Enhance tool.   Press the Image or Scroll   
  window with the cursor and the linked Display image is shown. 

  In the Cursor Location/Value tool, look at the original DN value for the  
  grayscale bands as you roam around from shallow to deeper water.  
  The original DN values are on the “Disp  #2 Data:” line. 
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Question 4:  A.  What happens to the visibility of the underwater sand bars and ripples  
  on the sea floor as you display the blue, then green, and then red bands? 
  (Hint: read the textbook Chapter 3 and look at Plate 9)  
  B.  Why?   

  C. What happens to the brightness of water as you display the reflected  
  infrared bands (Bands 4, 5, 6)?  (Contrast-stretch each band to make the  
  change more clear).  
  D. Why? 

4c) Landsat TM band 5 (SWIR1) does a good job of differentiating water from land.  
Using the “Available Band List”   Load Band > Band 5 as a “Gray Scale” into Display 
#2..  Now we will make a binary (black and white) image of Band 5 in Display #2. 

Tools > Color Mapping > ENVI Color Tables    (see below) 

 

The B-W Linear grayscale from black to White should be displayed.  (See above). 
Move the stretch buttons toward the center of the sliders.   You are doing a linear 
stretch, with the top slider moving pixels toward the left side to pure black (DN =  0) and 
the bottom slider moving pixels toward the right side to pure white (DN =  255).  Align 
the slider buttons so the black-white pattern has a sharp boundary  (see below).  This 
could be termed a “Linear 50%” contrast stretch.   

 



13 
 

13 Introduction to Remote Sensing  Principles, Interpretation, and Applications 
F. F. Sabins and J.M. Ellis, 2020, Waveland Press.    Contact:  jellis@ellis-geospatial.com 

 

 Look at the Band 5 image in Display #2.  The pixels are only black or white.   
 (See “Cursor Location / Value”   “Disp #2…Scrn:” DN values). 
  
 Our goal is to display islands as white and water as black.  The Linear 50% 
 stretch is excessive - a significant portion of the land on the islands is black 
 which should represent water. 

 Redo the sliders on the “#2 ENVI Color Tables” window.  Move the vertical Black-
 white boundary left so that the land on the islands is displayed as white.  

 Press the Image or Scroll window with the cursor and the linked Display image 
 is shown.  This will help you determine when you have an appropriate land – 
 water boundary.  I decided on the following black – white boundary. 

 

 Note that there are lakes on the islands and the white sands may be saturated – 
 so the SWIR TM band 5 records these as dark pixels.  These pixels are in the 
 black water class.   

To save our TM Band 5 Black-White image we use Display #2 Image drop-down menus 
File > Save Image As > Image File   The Output Display to Image File window pops up. 
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 Choose the defaults.  The “Resolution “ is “8-bit (gray scale)” Save the image as 
 “TM_Band5_BW_8-bit_ENVI” 

 The saved image automatically shows up in the “Available Band List” and is 
 highlighted so it easily displays next. 

  “Available Band List” > push “Display #1” button > New Display >  
  push “Load Band”     Our TM Band 5 8-bit image is loaded into Display #3. 

4d)  Build the Mask.  Now we will convert our 8-bit grayscale image (with 255 levels of 
gray even though only 0 and 255 are used) to a Mask with DNs of 0 and 1. 

 We use the drop-down menus on the ENVI Classic Toolbar (see below). 

 

 Basic Tools > Masking > Build Mask    Select Display #3  

 The “#3 Mask Definition” window pops up.   Our TM Band 5 8-bit image is 
 highlighted by ENVI.    Options > Import Data Range  (shown below on left) 

                  

 The “Import for Data Range Mask” menu pops up.  Enter 0 and 1. 
 This sets the mask for “water”    > OK 
  
 In the Options drop-down menu ensure “Selected Areas “Off” 
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 Name the Mask “Water_Mask_0-1_Off” so that you remember you used 0-1 and 
 “off” in the Mask Definition.   > Apply 

NOTE:  The combination of 0-1 and “off” in the Mask Definition ensures that the mask 
will be opaque over water pixels and transparent over land pixels so water will not 
interfere with processing analysis of the land cover on the islands.   This is always 
confusing and trial & error with these parameters seems to be the typical way to get the 
Mask you want… 

 The mask automatically loads into the “Available Band List” and is highlighted. 
  Push “Display #...” drop-down menu and choose “New Display” 
  Push “Load Band? 

 Move your Cursor Location/Value tool over the water and land.  They should 
 have DNs of 0 and 1, respectively. 

4e)  Apply the Mask 

 ENVI Toolbar > Basic Tools > Masking > Apply Mask   
  The “Apply Mask Input File” window pops up.  This is the data we want to  
  mask – the 6-band Landsat dataset. 

 “Select Input File:”   Select the 6-band Landsat dataset  > OK 
 Buttons pop in on the “Apply Mask Input File” window  (see below) 

     

 Click-on the “Select Mask Band” button.  Our water mask shows up at the top of 
the “Select Mask Input Band” window  (see above)   > OK   > OK 
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 An “Apply Mask Parameters” window pops up.  (see below) 

 

 Name the file “Landsat_6-band_Water_Masked_ENVI”  > OK 

 The masked Landsat displays in the “Available Bands List” 

 Display a color IR image (TM bands 4-3-2 as R-G-B) 
  Click the “RGB Color” >  Push the “Load RGB” button   
  Your masked color image will display in your last Display. 
 
 Move the Zoom window over a large island > Enhance > [Zoom] Equalization 
  You are contrast-stretching using only the pixels in the Zoom window. 
  This stretch reveals significant differences in the vigor of vegetation  
   on different islands and within larger islands. 

4f) Our masked ENVI color IR Landsat is more useful in GIS so others can view it – and 
we could import our color IR image into Google Earth if it was a geoTIFF. 
 
 We want to save the 3- band color composite so we use the ENVI Image menus 
  File > Save Image  As > Image File… 
   Choose “Resolution” drop-down menu   “24-bit Color (BSQ) 
   Choose “Output File Type” drop-down menu   “TIFF/GeoTIFF 

  Name the GIS-ready dataset:  
   “YourName_Landsat_ColorIR_Masked_Water_GIS”  > OK 
 

 Upload the 24-bit GIS-ready color IR image to the instructor. 

 If you have access to a GIS, load the 6-band multispectral dataset. 
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Lab 4   Image Processing 2              Name: 

Upload the following files to the instructor: 
 
 (1) “Your Name_ASTER Temp GIS.tif”  geotiff 

 (2) “YourName_ASTER_Temp_Density_Slice” shapefile 

 (3) “YourName_drone_mosaic_thumbnail” jpg 

 (4D) “YourName_Landsat_ColorIR_Masked_Water_GIS”  geotiff 

Question 1:  A. What is the range in DN values (min – max)? 

  B. What is the DN range for the bin with the highest Count (located at the  
  peak of the histogram)? 

Question 2:   A. What is the highest temperature in °C recorded by the ASTER TIR  
  system?  (Hint: Refer to the Quick Stats Histogram table) 

  B. Do you think you should use this highest temperature if only one pixel  
  recorded it?   YES  or   NO 

Question 3:  What is the DN at the black edges of the two images? 

 

Question 4:  A.  What happens to the visibility of the underwater sand bars and ripples  
  on the sea floor as you display the blue, then green, and then red bands? 
  (Hint: read the textbook Chapter 3 and look at Plate 9). 

 

  B.  Why?   

 

  C. What happens to the brightness of water as you display the reflected  
  infrared bands (Bands 4, 5, 6)?  (Contrast-stretch each band to make the  
  change more clear).  

 

  D. Why? 

 


