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Lab 3   Image Processing 1 
Utilizes Textbook’s Remote Sensing Digital Database: Chapters 3 and 4 data. 

The objectives of this lab are to learn the processing tools that are used for 
Preprocessing and Image Enhancement (see Chapter 9 Digital Image Processing for 
discussion).  The tools used in this lab are in in the ENVI Toolbox: 

 Statistics (complete, including correlation matrix) 
 Resize Data 
 Rotate/Flip Data 
 Layer stacking 
 Edge enhancement  

Some files are in the Lab_3_Data folder.  Five questions are asked during this lab – you 
are to write your answer on the sheet that is at the end of this handout.   Three digital 
files are to be uploaded to the instructor. 

IMPORTANT NOTE: ENVI does not retain display enhancements for images when you 
use Save As. These include rotating, zooming, contrast, brightness, sharpening, 
stretching, Portals, or viewing multiple layers. Use the Export View To > Image File to 
retain display enhancements and original scale (choose Zoom Factor 1.0000). 

1) Statistics 

 We will use a Landsat 8 data set located in the “Remote Sensing Digital 
 Database \ Ch_3_Landsat” folder.  Open the subfolder named 
 “Plate_6_1979-2016_Saudi_Change”.   
 Open the subfolder “Landsat-8_2016_OLI-TIRS”. 

 Open ENVI.  File > Open  

  “Saudi_Landsat8_2016_Bnds1-7_10-11_Stack_Clip_ENVI_” 

  This Landsat data has 7 VNIR-SWIR bands and two TIR bands.  We will  
  evaluate the statistics for OLI bands 2-7. 

 Zoom to Full Extent,    File > Data Manager    So you can see all the bands. 

 Right-click  on file in Layer Manager > Change RGB Bands..       

  Load 7-5-2 as R-G-B.   (these are SWIR2 – NIR – Green bands) 

  Your display should appear as below – note the Toolbox on the right. 
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Toolbox > Statistics > Compute Statistics 

 A “Compute Statistics Input File” menu pops up.  Highlight the Saudi Landsat 8 
 input file.   We want to show statistics on the six VNIR-SWIR bands that record 
 reflected blue, green, red, NIR, SWIR1 and SWIR2 light (Landsat OLI bands 2 – 
 7). To do this, click on the “Spectral Subset” button that has “9/9  bands”  
 displayed.   

   A smaller menu “File Spectral Subset” pops up.  We will select bands 2 – 7 with 
 the Shift or Ctrl key, and then press    Add Range  > OK     

 Note the “Spectral Subset” number changes to “6/9 Bands” on the “Compute 
 Statistics Input File” menu.   

 > OK on the “Compute Statistics Input File” window (lower left) 

 See menu below for selecting 6 of the 9 bands. 
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A “Compute Statistics Parameters” menu pops up.  (see below)  Check all the boxes.   

 Accept the default names for the ENVI statistics .sta file and the .txt Report 
 FileName.  If the default name is blank, use “VNIR-SWIR_stats…” 

  Click OK when done. 
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 A Statistics View window pops open because the “Output to the Screen” option 
 was checked.  This Toolbox report is more complete than the Quick Stats report. 

  Push the triangle in the white strip on the right vertical bar next to the chart 
  to reveal details and edit colors and data values. 

  At the bottom of the window are tables.  Scroll down to the “Correlation”  
  table.  

 1.000 is perfect correlation.  The more highly correlated the bands, the higher 
 the correlation value.  Band have perfect 1.00 correlation to themselves in this 
 table (also called a Correlation Matrix).  Negative correlation values (-) indicate 
 that when pixels are light in one band they are dark in the other band. 

Question 1:  (Provide correlation values to the nearest two decimal places). 

  A.  What is the correlation between OLI bands 3 (green) and 2 (blue)? 

  B.  What is the correlation between OLI bands 4 (red) and 2 (blue)? 

  C. What two bands have the least correlation (most difference spectrally)?  

  D.  What two bands have the highest correlation (most similar spectrally)? 

 Open the text document that lists the statistics. 

2) Let’s look at the image in two ENVI views that are linked.  The Saudi Landsat scene 
has active sand dunes, some pivot irrigation plots, and stabilized barren ground without 
vegetation. 

 File > View > Two Horizontal Views      
 Right-click  on file in Layer Manager > Change RGB Bands..       

  View 1:  Load 4-3-2 as R-G-B.   (these are the visible bands).  
   Drag and drop the color image from View 1 to View 2 
   (you can also load View 2 using the Data Manager) 

  View 2:  Right-click  on file in Layer Manager > Change RGB Bands..       
   Load 5-4-3 as R-G-B    (this is a color IR image). 

  File > View > Link Views > Link All 

 Use the Pan to roam around both images.  Zoom in and out.  Interpret what  
  is displayed in the scene 
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 Right-click on the Landsat dataset in one of the Views in the Layer Manager  

    > Band Animation.  Slow down flicker.  You can pan around while flickering. 

Question 2:   Compare the visual gray tone of the sand dunes in the northeast and  
  east of the band 2 (blue) and the three reflected infrared bands (5-7).   
  Does this match the values in the correlation table?  Explain.  

3) Let’s look at a Scatter plot of the 9-band Saudi Landsat data.  Return to one view.  
 Views > One View           
 Only the 9-band Landsat file should be checked in the Layer Manager. 
 Display  > 2D Scatter Plot    
  Compare different combinations of bands. 
   Save an image of the band 2 versus band 5 scatter plot.   

  File > Save Plot As > Image…  “Your name_bands_2-5_Scatterplot” 
   save as a jpg or png. 

   Upload your image of the Scatterplot to the instructor. 

Question 3:   How does the scatter plot of bands 2 and 3 and the plot of bands 2 and 5  
  compare to the correlation table values? 

4) Resize Data        We will clip out a subscene of Band 5 (NIR) from the 9-band Saudi  
   dataset. 

 ENVI Toolbox > Raster Management > Resize Data 
  ‘Resize Data Input File” window pops up.  Highlight the Saudi Landsat 9- 
  band dataset if needed. 

  Click on “”Spectral Subset” button.  “9/9 Bands” is shown next to this  
  button.  A “File Spectral Subset” window pops up.  Highlight Band 5 > Add  
  Range  and “1/9” shows up in the text next to the Spectral Subset button  
  on the Resize menu.  > OK 

  Click on “Spatial Subset” button > “Select Spatial Subset” window pops  
  up.   (see screen capture below) 

   > Click on “Image”  >  “Subset by Image” window pops up.  
  > change Samples and Lines to 300 x 300  
  > move subset box to center of image >  OK > OK > OK.   

 The menus are displayed below with the 3 OK buttons. 
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  A “Resize Data Parameters” window pops up showing the 300 x 300  
  dimensions of the subset area.  (see below).    

  Name the subset image “Your name_subset_band5_ENVI”.   The image  
  will be in ENVI format (.img with .hdr file)   > OK 

  Resize menu 

 The resized ENVI image will display in the center of the larger image in the ENVI 
 view and will be listed in the Layer Manager.   
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 We want to make the clipped band 5 NIR grayscale image more useful for GIS, 
 so we will next convert the ENVI image to the universal geotiff format. 

  Highlight the resized file in the Layer Manager  
  File  > Export Selected Layer to TIFF 

   NOTE:  The same export tool is available with Right-click on the  
   resized file in the Layer Manager > Export Layer to TIFF 

  Rename the file “Your name_subset_band5_geotiff” 

  Check the “Display result” box > OK 
  Upload your geotiff of the resized image to the instructor. 

5) Rotate/Flip Data    We will use an image that does not have any coordinates.  This 
tool is useful when georeferencing scanned images and maps to place them in a 
position where N is approximately up. 

 Right-click View > Remove All Layers  

 In the Lab_3_Data folder is a grayscale image without coordinates from Lab  
 1 named “E 8-bit.tif” 

 File > Open > “E 8bit.tif”   > Zoom to Full Extent 

 Right-click “E 8bit.tif” in the Layer Manager > View Metadata.  Does this image  
   have any coordinate information? 

 Toolbox > Raster Management > Rotate/Flip Data 
  Select “E 8-bit.tif” in the Rotation Input File menu.  > OK 
  In the “Rotation Parameters” menu, Choose the “Standard 90” 
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  Rename the rotated ENVI file “Your name_rotate 90_ENVI” 

  The rotated file automatically displays in ENVI.   
  Upload the rotated image and the same-name .hdr file to the instructor 

6) Layer stacking    Landsat and other multispectral data are delivered as individual 
bands.  In order to generate spectral profiles, complete spectral classification, and do 
other image enhancement tasks, the bands have to be stacked into one database.   

We will use the Landsat 8 bands of Thermopolis that are located in the “Remote 
Sensing Digital Database \ Ch_3_Landsat” folder.  Open the subfolder 
“Plates_7and27_Thermopolis”.  Open the subfolder “Bands”.  

You will see bands OLI bands 2 – 7 and TIR band 10 as .tifs with .tfw files (the .tfw 
contains georeferencing information). 

 In ENVI, Right-click View > Remove All Layers  

 File > Open  highlight the seven  .TIFF  files > Open    (see below) 

 

 The seven bands should be displayed in ENVI.  Zoom to Full Extent 

 Toolbox > raster Management > Layer Stacking 
 The “Layer Stacking Parameters” window pops up > Import File… 
 The “Layer Stacking Input File” window pops up.   
 Highlight the seven bands  > OK    
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 In the “Layer Stacking Parameters” window the georeferenced bands 
 automatically fill in the map projection parameters.   > Reorder Files…   

 See below.  Reorder if band number are not sequential (2 to 7 and then 10) > OK 

 

 Name the output stack “Landsat8_Thermopolis_Stack_7 bands_ENVI” 

  The Data Manager will list the 7 bands. 

 Display different color combinations of your new stacked Landsat bands. 

7) Edge Enhancement 

Let’s remove all the layers in the view and load a commercial, high spatial resolution 
image discussed in the textbook Chapter 4 (see Figure 4-9).  The data is provided by 
DigitalGlobe.  The scene covers a portion of Tokyo with their Worldview-3 satellite (WV-
3). 
 Right-click on View > Remove all the other images in the View. 

 File > Open >   “Remote Sensing Digital Database \      
   Chapter_4_Other_MSS_Satellites” \ High_resolution_Satellites \ 
                      Worldview-3_pan-MSS_Tokyo”    folder  

      Select “Tokyo_WV-3_4-bnd_30cm_pan-sharpened_MSS_11-bit_GeoTIFF” 
      > Open 
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 We’ll create a natural color image with 30 cm spatial resolution.  DigitalGlobe 
 delivers data with bands 1, 2, 3, 4 as reflected blue, green, red, near IR light.  

 Select Band 3 – Band 2 – Band 1 as Red – Green – Blue 

 Zoom-in to the lower left corner so the two red & white construction cranes, the 
 street below, and the southwest corner of the baseball stadium is in your view.  

  Set scale to 1:300 

 Let’s use the Sharpen Slider in the 2nd from top row of icons to see what happens 
 with high pass and low pass filters. 

Question 4:  A. Describe the change in visual appearance of the red & white 
construction cranes when the Sharpen slider is set to 100 and to the far left of the slider 
(beyond the no change vertical line on the slider). 

  B. What level of sharpening provides an image that you find most 
informative (answer with the number to the right of the slider) 

To improve our understanding of edge enhancement, we will now use the Toolbox for 
high pass and low pass filtering of our Tokyo 4-band dataset. 

Chapter 9 Digital Image Processing has an extensive discussion on edge enhancement 
(see Figures 9-14 to 9-18).  We will be using a High Pass filter that  is similar to the 
Laplacian filter shown in Figure 9-14, but the center and corner pixel values are 
different. See ENVI Tool below that is opened via the Toolbox. 

 Filter > Convolutions and Morphology     
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 Press the buttons across the top to see the many possible variations. 
  Click on the Help button to obtain a better understanding of the tools.  

 The high-pass filter that we will use is shown above.  This filter “….Removes the 
 low frequency components of an image while retaining the high frequency (local 
 variations).”  ENVI Help. 

 As a recap of what is discussed in Chapter 9, let us assume that the 3 x 3 filter 
 cell is on a pixel with a DN value of 52. The algorithm does the calculation shown 
 below for the center cell to every pixel in the image…except along the margin of 
 the image!  The center pixel is changed from 52 to 64 in the example below. 

           [-65 + -55 + -65 + -60  +416 + -60  +-60 + -55 + -60]  = [416 + -480] = = +64 

 

 First we will do the high pass filter with 0% image add back. 

 Filter > Convolutions and Morphology  >  0% Add Back  >  Apply to File 

 A “Convolution Input File” window pops up – select the Tokyo 4-bnd dataset. 
  Apply this high pass filter to all four bands – so just say OK 
  The Convolution Parameters window pops up – name your file 
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 You should see something like the image below – a high pass filter applied with 
0% add back on the Tokyo satellite image – edges are emphasized….maybe good for 
input to AI and fracture/fault/linear feature detection…  but not a visually pleasing 
image.  You usually have to do some contrast stretch to make the image appear without 
being oversaturated (blown out). 

 

 Repeat the Convolutions and Morphology high pass filtering, but change the Add back 
to 95%.  Addback means the percentage of the original image added back to the edge-
enhanced image.  95% Add back is often used to create a sharper image for 
interpretation. 

 In the ENVI Layer manager compare the original color image with the image 
 that has been edge-enhanced with a high pass filter but with 95 % image add 
 back.  Is the 95% add back more informative compared to the original? 

 
Let’s do a Low-Pass Filter.  Low pass filters “…Preserves the low frequency 
components of an image, which smoothes it.”  ENVI Help.  Low pass filters are useful 
for noisy data and used extensively in geophysics. 

 Toolbox > Filter > Convolutions and Morphology > Convolutions > Low Pass 

  Kernal size = 3      0% Image Add Back  

  Repeat but with Kernal size = 13     0% Image Add Back 

Question 5:  What is the difference in image appearance when a low pass filter with a 3 
x 3 kernal is applied compared with a low pass filter with a 13 x 13 kernel? 
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Lab 3 Image Processing               Name: 

Upload the following files to the instructor: 
     (3) “Your name_bands_2-5_Scatterplot” 
 
  (4) “Your name_subset_band5_geotiff” 
 
  (5) “Your name_rotate 90_ENVI.img”  with ENVI .hdr file (two files) 

 
Question 1:  (Provide correlation values to the nearest two decimal places). 

  A.  What is the correlation between OLI bands 3 (green) and 2 (blue)? 

  B.  What is the correlation between OLI bands 4 (red) and 2 (blue)? 

  C. What two bands have the least correlation (most difference spectrally)?  

  D.  What two bands have the highest correlation (most similar spectrally)? 

Question 2:   A. Compare the visual gray tone of the sand dunes in the band 2 (blue)  
  and the three reflected infrared bands (5-7).  Does this match the values in 
  the correlation table?  Explain.  

 

Question 3:   How does the scatter plot of bands 2 and 3 and the plot of bands 2 and 5  
  compare to the correlation table values? 

 

Question 4:  Describe the change in visual appearance of the red & white construction  
  cranes when the Sharpen slider is set to 100 and to the far left of the slider 
  (beyond the no change vertical line on the slider). 

  B. What level of sharpening provides an image that you find most   
  informative (answer with the number to the right of the slider). 

 

Question 5:  What is the difference in image appearance when a low pass filter with a 3  
  x 3 kernel is applied compared with a low pass filter with a 13 x 13 kernel? 

 


