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Lab 1  Introduction to ENVI Software 
Utilizes Textbook’s Remote Sensing Digital Database: Chapters 1 and 2 data. 

The objectives of this lab are to learn where many key, image processing tools are 
located on ENVI’s main display window and what these tools do.  Topics that will be 
covered include: 

 Review drop-down menus and tools located along top margin. 
 Metadata 
 Radiometric and spatial resolution 
 Contrast stretching 
 Spectral and Arbitrary profile (transect) 

You will upload one (1) digital file to the instructor.  Thirteen (13) questions are asked 
during this lab – you are to write your answer on the sheet that is at the end of this 
handout.  

ENVI has two formats for the Graphical User Interface (GUI).   

 A)  “Classic” is a 3-window arrangement (Image, zoom, and scroll) for power 
users.   

 B) unnamed is the latest arrangement that as has a GIS look.  We’ll start with the 
unnamed GUI (see Figure below).  Start the ENVI software. 

Layers that are loaded into the program are displayed in the left column, many tools are 
in the Toolbox to the right, and the image and maps are displayed in the center view. 
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1) Let’s first load the 3 spatial resolution grayscale images that have copied from the 
“Remote Sensing Digital Database \ Ch_1_Resolution” collection.   Open the 
“Lab_1_Data” folder that was in the same folder as this Lab 1 handout and load the 3 
images.   These 3 images are shown in the textbook’s Figure 1-5. 

 File > Open > Lab_1_Data\ 10m resampled_tif, 5m resampled_tif, and 60 cm 
 image_tif.     (You should see windows identical to what is below). 

 

 Zoom to Full Extent icon.  Unclick the 60 cm and the 5 m images in the Layer 
 Manager so only the 10 m image is displayed.  (See below). 

 



3 
 

3 Introduction to Remote Sensing  Principles, Interpretation, and Applications 
F. F. Sabins and J.M. Ellis, 2020, Waveland Press.    Contact:  jellis@ellis-geospatial.com 

 

2) With the instructor, you will open the tasks located across the top of the ENVI window 
(File, Edit, Display, etc.)  We will start with the dropdown menu under “File > Open As.   
Examine the “Open As” options for different types of data – discuss the advantages of 
this extensive capability  (Optical Sensors shown below). 

 

File > Open World Data   Global data – you need to zoom out.  You may be asked to 
approve reprojecting the images in your view so that the ENVI global vector and DEM 
data can be displayed. 

File >   Open Remote Dataset   or    Remote Connection Manager   Streams in GIS 
layers from a server on the Internet. 

File > Views and Layers > Save     Enables you to save the images and maps loaded 
into ENVI Views so you can restore them later (data has to remain on the same path). 

File > Export Selected Layer to TIFF   Most useful for images being sent to a GIS. 

File > Data Manager   Displays all the data you have opened.  Shows all the bands in a 
multispectral data set (Layer Manager only shows the 3 bands being displayed in color). 

File > Preferences   Important if you want to change the default display stretches  

Display >       You will use many of these tools, especially Cursor Value and Profiles. 

Views >      You can drag and drop images and maps from one view to other views.  
Multiple views are excellent for comparing different enhancements of the same dataset. 
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Help > Contents     Essential for understanding the tools that you will be using.  
Click on the “Index” tab and type in a term you want to understand in the “Search 
Index”. 

3) Top row of icons and buttons 

 

Test out the different tools.  The “Pixel Scale” dropdown menu is less useful than the 
“Map Scale” dropdown menu. 

Other icons are duplicates of what is in the Display dropdown menu. 

4) Second row of icons and sliders 

 

The “Contrast” slider only works when the contrast stretch is set to “Linear” (see below). 

The “Stretch on View Extend” is very useful for enhancing only what you see in the View 
– it ignores the rest of the dataset outside the view. 

  The “contrast stretch options in the drop-down menu are very useful. 

Histogram Stretch      Enables you to broaden or narrow the digital numbers (DNs) used 
in the enhanced grayscale band (or image) by moving darker pixels to pure black and 
lighter pixels to pure white. 

Sharpen is an edge enhancement tool.  Zoom-in to a scale of 1:1000. Move the slider to 
the right to see the visible increase in edges and sharpness (this is a “high pass filter”).  
The vertical line in the slider represents No Sharpening.  Move the slider to the left of 
the vertical line to soften the image (this is a “low pass filter”). 
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5) File > Preferences> Display General   Set the Default Stretches for 8-bit imagery  
       to “No Stretch” >  OK 

     This will load new 8-bit images without any enhancement. 

6) Right-click on the 10m resample_tif image in the Layer Manager  > View Metadata. 

View the metadata for the 5m resampled_tif and the 60 cm image_tif 

Question 1:   A. What is the map projection and datum for the 3 images? 

      B. How big is each image in KB, and the number of pixels in the columns  
  and rows? 
 

7) Turn-on (check) the 5 m and 60 cm images in the Layer Manager 

      Right-click on the “60 cm image_tif.tif”    View Metadata.    

    Export > Selected node to a file > Close 

Question 2:  What is the format is the exported metadata?  Why is this a useful format? 

8) Display > Cursor Value     Move the cross-hairs around with the “Select” arrow. 

Question 3:  What is the range of digital numbers (DNs) for the 60 cm image? 

Question 4: can you identify the tanks on the 10 m image? 

Question 5: Can you identify roads on the 5 m image?  What is their characteristic? 

9) Views > Two Vertical View     Activate the blank view so it has a color boundary 
 around it and the “View” text in the Layer Manager is highlighted. 

 File > Open > A 3-bit.tif, C 5-bit.tif, and E 8-bit.tif    
  These 3 images are shown in Figure 1-9 (see also Figure 1-10). 

 Zoom to Full Extent icon.    Unclick the 5-bit and the 8-bit images. 

 Use the Zoom tool and enlarge the 4 tanks and ground in the southeast central 
 portion of the image.  Turn on & off the 3 images. 

Question 6:   A. 3-bit images have how many levels of gray? 

  B. 5-bit images have how many levels of gray”? 

  C. Do you see much difference between the 5-bit and 8-bit images?   
  Why? 
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10)  Zoom into the same tank on the left and right view.  Use the Pan tool to center the 
tank in the view. 

 Use the measuring tool “Mensuration” to measure the dimension of the tank. 

Question 7:   A. What are the two measurements of the same tank in the two views? 

  B. Why the difference? 

11) Views > One View  (don’t save any annotation).    We are going back to one view. 

 Right-click on “View” in the Layer Manager and “Remove all Layers”  (don’t save 
 any annotation).   The Layer Manager should be blank. 

12) File > Open >        Locate the folders in the Remote Sensing Digital Database 
named “Ch_2_Aerial_Images\Plate_3_NAIP_Aerial_Multispectral” 

 Open the “NAIP_CIR_432…”, “NAIP_Color_321…”, and “NAIP-4band…” TIFs 

  Highlight each tif file (the largest 3 files in the subfolder) > Open. 

 The 3 data sets are in the one view.  Move the “NAIP_Color…”  image to the 
 bottom of the Layer Manager list (highlight and drag to bottom of the list).   

NOTE: The 4 NAIP bands, along with a map are shown in the textbook’s 
Figure 2-27.  The natural color and color IR images are shown in the 
textbook’s Plate 3. 

 File > Data Manager      If not already opened, open the Data Manager so you  
     can see how many bands are in each dataset. 

 Zoom to Full Extent icon.  Unclick the “NAIP_CIR…” and the “NAIP_4band…” 
 layers in the Layer Manager.     

 The “NAIP_Color…” image should appear with natural colors.  This image was 
 acquired in June when non-irrigated grasses that cover the hills are very dry and 
 should appear with shades of yellow.  What color is the grass on the hills in your 
 view?  If the non-irrigated grass is not yellow, the order of the bands in the color 
 display is incorrect (See Plate 3A). 

NOTE:  A typical problem to solve when loading data is the order that bands 
are sequenced in a dataset.  The USDA delivers 4-band NAIP data in the 
following order:  reflected blue light = band 1, reflected green light = band 2, 
reflected red light = band 3, and reflected Near IR light = band 4.  A natural 
color image should display in ENVI as bands 3, 2, 1 in red-green-blue.   
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But you may see that ENVI loaded the color image with bands 1, 2, 3 as red-
green-blue.  That is incorrect!    

The metadata that accompanies a remote sensing dataset should document 
the sequence of bands to help minimize the confusion. 

13) We’ll change the color images band order next to correct the problem. 

 Right-click on “NAIP_Color…”  in the Layer Manager > Change RGB Bands… 

  In the Change Bands window (see below) Click Band 3 first (displayed  
  with red light), Band 2 next (displayed with green light) and Band 1 last  
  (displayed with blue light)  >  OK 

 

 Now the dry grass should appear yellow. 

 Right-click on the “NAIP_Color…” image and View Metadata. 

14) Enhancing the image.  Start with “No stretch”.  Use the Brightness slider – when 
 done, return to 50. 

 Contrast stretching is discussed in the textbook’s Chapter 9 Digital Image 
 Processing.  Also see textbook Figures 9-12 and 9-13. 

 Click on the Histogram Stretch icon.  You will see the 3 histograms for the color 
 image.  The NAIP image is collected as 4 bands (reflected blue, green, red, and 
 near IR as bands 1, 2, 3, and 4).  The color image is bands 1-2-3 displayed in 
 blue-green-red. The CIR (color infrared image is bands 2-3-4 displayed in blue-
 green-red.  The 4-band multispectral data enables you to change the band 
 combinations and color composite using the 4 bands.   

 The Histogram Stretch display is shown below for the 3 bands in the  
 “NAIP_Color…” image.   There is no contrast stretch applied. 
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Question 8:  How many bits is this data?  How many levels of gray?  

Question 9:   Between approximately what low and high DN (brightness) values   
  (numbers along the  horizontal axis) are most of the pixels in this dataset? 

We can use the contrast-stretching tools to improve the range of brightness and 
improve the information content in the color image.  First let’s do the enhancement with 
the options provided in the contrast stretch drop-down menu. 

 Choose “Linear 1%”     Is the image more informative? Zoom in and pan around 
 to make your determination. 

 For this contrast stretch, 1 % of the pixels are moved to pure black (DN = 0) on 
 the left side of the histogram and 1% of the pixels are moved to pure white (DN = 
 255) on the right side of histogram).  You see the 1% vertical lines on the 
 Histogram Stretch plots. 
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Question 10:  Why did moving 1% of the dark and bright pixels to 0 and 255, 
respectively, improve the range of colors displayed in the color composite? 

 

 Choose “Linear 5%”   What happened to the information content displayed in the  
     industrial and developed areas? 

15) Now let’s manually change the % of pixels changed to pure black or pure white.  

 Use the Drop-down menu and choose “No Stretch” 

  Place your cursor on the left and right side of the red histogram and move the 
 bars inward so that approximately 2% of the pixels are moved to pure black or 
 DN = 0 (left side) and pure white or DN = 255 (right side).   

 What happens to the natural color image when you do contrast stretching only 
 only one band – in this case the band illuminated with red light?  

 Repeat the 2% linear stretch on the green and blue bands.  Is the image more 
 informative?  Zoom in and pan around to make your determination if a Linear 2% 
 stretch was better than a Linear 1% stretch that we did earlier. 

16) Let’s save our enhanced Linear 2% contrast-stretched color image for a GIS.   

 Highlight the “NAIP_Color… file name in the Layer Manager.  

 File > Export Selected File to TIFF…   Name the file “Enhanced_NAIP_Color.tif” 

Question 11:  A. How large is this tif file in MB?          

  B. How large was the original NAIP_Color_321…tif” image? 

  C. Is your enhanced image better looking than the original?  

 File > Chip File To >  Geospatial PDF…     

  Fill in with your name, course ID, and a few keywords (metadata!!). 

  Output file name:  “Your Name_Enhanced_NAIP_Color pdf” 

  Do you like the thumbnail image? 

  Upload this pdf to the instructor. 

 File > Chip File To > Google Earth    you don’t get to name the kmz… 
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  Look at your image in Google Earth.  Do you like it? 

  The name may be “ENVI View”… not very useful… 

    

17)  Let’s reset the stretch to “No stretch”.  Click through the different stretches in the 
drop-down menu.  Which one do you like the best? 

 Zoom into the golf course in the lower right. 

 Turn on the “NAIP_Color_321…” and the “NAIP_CIR_432…” image in the Layer 
 Manager.  Unclick the “NAIP-4band…” data. 

 Turn on the Portal and move it  around with the Select arrow. 

  Display > Portal 

  Hopefully you will see the color image in the portal – and the color IR  
  image as the background – or vice versa. 

 Zoom in with the Portal active.  Very cool(!) – it stays the same size while you 
 zoom in & out.  Use the Select arrow to pan the Portal around. 

 You are looking at 1 meter digital airborne imagery. 

18)  Above the Layer Manager are 3 icons – Blend, Flicker, and Swipe  

 Touch the Swipe tool icon.  You should see the “NAIP_Color_321…” being 
 swiped over the “NAIP_CIR_432…”  

 Unclick the [p] file (Portal) in the Layer Manager so the Portal does not display 
 while the Swipe tool is active. 

 Right-click on Flicker and Portal [p] files in the Layer Manager and Remove. 

19)  Views > Two Horizontal Views 

 Drag and drop the color IR image from the 1st view into the 2nd view. 

 Turn-off the color IR image in the 1st view.  Have the color image turned on in the 
 first view. 

 Views > Link Views > Geo Link >Link All > OK 

 Zoom in and pan around. 
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20)  Views > One View  > Click on “NAIP-4band…” multispectral data set. 

 The data will be in the Data Manager if it doesn’t appear in your view.  Select 
 bands 4-3-2 as red-green-blue so a Color IR image is displayed. 

 Use the Equalization contrast stretch in the drop-down menu.  Click on the 
 adjacent (to the left) icon to apply the stretch to only the view. 

  Stretch on View Extent  

 This “harsh” contrast stretch should reveal subtle irrigation patterns and dry 
 portions of the golf course, along with strange linear patterns paralleling the 
 fairways (due to uneven fertilizer application or mowing issues?  (See below) 

 

 Zoom to a scale of  1:4000 in the drop-down menu near the top center of the 
 ENVI window.  Ensure in the view that you have a pond in the upper left and 
 and lower right with golf fairways in between. 

 Display > Profiles > Spectral    or   click-on the Spectral Profile icon along the top 
 row of tools.  This tool shows the reflectance at individual pixels for the 4 bands. 

 Use the Select arrow to move the crosshairs around the golf course targeting 
 water, irrigated grass in the golf course, non irrigated (dry grass) outside the golf 
 course, concrete, building tops, asphalt, etc.  (See below) 
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Spectral signature for healthy irrigated 
golf course grass. 
 
Horizontal Axis shows bands 1 – 4: 
1 = reflected blue light 
2 = reflected green light 
3 = reflected red light 
4 = reflected Near IR light  

  

Question 12: A. What happens to the Data Value (brightness) of Band 3 (red) and Band  
  4 (near IR) when you measure reflectance on irrigated grass at the golf  
  course? 

  B. What happens to Band 4 when you measure the reflectance over  
  water? 

  C. What are the two brightest bands when you measure reflectance over  
  dry grass outside of the golf course? 

21)  Now we’ll do a spectral profile (a transect or a line) of reflected near IR, red, and 
green light across the golf course. 

 Zoom to a scale of  1:4000 in the drop-down menu near the top center of the 
 ENVI window.  Ensure in the view that you have a pond in the upper left and 
 and lower right with golf fairways in between. 

 Display > Profiles > Arbitrary  

  Start on the lake in the upper left and move the cursor to the lake at the  
  lower right and click to stop line – and a graph pops up.  Maybe you have  
  to click the end of the line a couple times. 

  In the Arbitrary Profile transect window, click on the black triangle in the  
  white area of the right margin to reveal what bands are associated with  
  what color line. 

  Options (drop-down menu) > Curve Smoothing      (see below) 
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Question 13:  A. What happens to the Near IR reflectance (brightness or Data Value) 
  value (red line) in water? 

  B. What happens to Near IR brightness in the golf course fairways?  

  C. Reflected green light is brighter than reflected red light over the   
  irrigated grass on the fairways?  Why do you already know this fact? 

  D. Do you have any idea why green light is reflected more strongly from  
  healthy vegetation compared with red light? 
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Lab 1 Introduction to ENVI Answer Sheet             Name: 

Upload the following file to the instructor: 

 (16) Your Name_Enhanced_NAIP_Color pdf”  pdf  

 
Question 1:   A. What is the map projection and datum for these 3 images? 

  B. How big is each image in KB, and the number of pixels in the columns  
  and rows? 

     KB            columns          rows 
 
   60 cm: 

   5 m: 

   10 m: 

Question 2:  What is the format is the exported metadata?  Why is this a useful format? 

Question 3:  What is the range of digital numbers (DNs) for the 60 cm image? 

Question 4: Can you identify oil storage tanks on the 10 m image?  Why? 

Question 5: Can you identify roads on the 5 m image?  What is their characteristic? 

Question 6:   A. 3-bit images have how many levels of gray? 

  B. 5-bit images have how many levels of gray”? 

  D. Do you see much difference between the 5-bit and 8-bit images?   
  Why? 

Question 7:   A. What are your two measurements of the same tank in the two views? 

  B. Why the difference? 

Question 8:  How many bits is this data?  How many levels of gray?  

Question 9:   Between approximately what low and high DN (brightness) values   
  (numbers along the  horizontal axis) are most of the pixels in this dataset? 

Question 10:  Why did moving 1% of the dark and bright pixels to 0 and 255, 
respectively, improve the range of colors displayed in the color composite? 
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Question 11:  A. How large is this tif file in MB?          

  B. How large was the original NAIP_Color_321…tif” image? 

  C. Is your enhanced image better looking than the original?  

Question 12: A. What happens to the Data Value (brightness) of Band 3 (red) and Band  
  4 (near IR) when you measure reflectance on irrigated grass at the golf  
  course? 

  B. What happens to Band 4 when you measure the reflectance over  
  water? 

  C. What are the two brightest bands when you measure reflectance over  
  dry grass outside of the golf course? 

Question 13:  A. What happens to the Near IR reflectance (brightness or Data Value) 
  value (red line) in water? 

  B. What happens to Near IR brightness in the golf course fairways?  

  C. Reflected green light is brighter than reflected red light over the   
  irrigated grass on the fairways?  Why do you already know this fact? 

  D. Do you have any idea why green light is reflected more strongly from  
  healthy vegetation compared with red light? 

 

 

 

  

 

  


