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Lab 1  Introduction to ENVI Software 
Utilizes Textbook’s Remote Sensing Digital Database: Chapters 1 and 2 data. 

The objectives of this lab are to learn where many key, image processing tools are 
located on ENVI’s main display window and what these tools do.  Topics that will be 
covered include: 

 Review drop-down menus and tools located along top margin. 
 Metadata 
 Radiometric and spatial resolution 
 Contrast stretching 
 Spectral and Arbitrary profile (transect) 

You will upload one (1) digital file to the instructor.  Thirteen (13) questions are asked 
during this lab – you are to write your answer on the sheet that is at the end of this 
handout.  

ENVI has two formats for the Graphical User Interface (GUI).   

 A)  “Classic” is a 3-window arrangement (Image, zoom, and scroll) for power 
users.   

 B) unnamed is the latest arrangement that as has a GIS look.  We’ll start with the 
unnamed GUI (see Figure below).  Start the ENVI software. 

Layers that are loaded into the program are displayed in the left column, many tools are 
in the Toolbox to the right, and the image and maps are displayed in the center view. 
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1) Let’s first load the 3 spatial resolution grayscale images that have copied from the 
“Remote Sensing Digital Database \ Ch_1_Resolution” collection.   Open the 
“Lab_1_Data” folder that was in the same folder as this Lab 1 handout and load the 3 
images.   These 3 images are shown in the textbook’s Figure 1-5. 

 File > Open > Lab_1_Data\ 10m resampled_tif, 5m resampled_tif, and 60 cm 
 image_tif.     (You should see windows identical to what is below). 

 

 Zoom to Full Extent icon.  Unclick the 60 cm and the 5 m images in the Layer 
 Manager so only the 10 m image is displayed.  (See below). 
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2) With the instructor, you will open the tasks located across the top of the ENVI window 
(File, Edit, Display, etc.)  We will start with the dropdown menu under “File > Open As.   
Examine the “Open As” options for different types of data – discuss the advantages of 
this extensive capability  (Optical Sensors shown below). 

 

File > Open World Data   Global data – you need to zoom out.  You may be asked to 
approve reprojecting the images in your view so that the ENVI global vector and DEM 
data can be displayed. 

File >   Open Remote Dataset   or    Remote Connection Manager   Streams in GIS 
layers from a server on the Internet. 

File > Views and Layers > Save     Enables you to save the images and maps loaded 
into ENVI Views so you can restore them later (data has to remain on the same path). 

File > Export Selected Layer to TIFF   Most useful for images being sent to a GIS. 

File > Data Manager   Displays all the data you have opened.  Shows all the bands in a 
multispectral data set (Layer Manager only shows the 3 bands being displayed in color). 

File > Preferences   Important if you want to change the default display stretches  

Display >       You will use many of these tools, especially Cursor Value and Profiles. 

Views >      You can drag and drop images and maps from one view to other views.  
Multiple views are excellent for comparing different enhancements of the same dataset. 
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Help > Contents     Essential for understanding the tools that you will be using.  
Click on the “Index” tab and type in a term you want to understand in the “Search 
Index”. 

3) Top row of icons and buttons 

 

Test out the different tools.  The “Pixel Scale” dropdown menu is less useful than the 
“Map Scale” dropdown menu. 

Other icons are duplicates of what is in the Display dropdown menu. 

4) Second row of icons and sliders 

 

The “Contrast” slider only works when the contrast stretch is set to “Linear” (see below). 

The “Stretch on View Extend” is very useful for enhancing only what you see in the View 
– it ignores the rest of the dataset outside the view. 

  The “contrast stretch options in the drop-down menu are very useful. 

Histogram Stretch      Enables you to broaden or narrow the digital numbers (DNs) used 
in the enhanced grayscale band (or image) by moving darker pixels to pure black and 
lighter pixels to pure white. 

Sharpen is an edge enhancement tool.  Zoom-in to a scale of 1:1000. Move the slider to 
the right to see the visible increase in edges and sharpness (this is a “high pass filter”).  
The vertical line in the slider represents No Sharpening.  Move the slider to the left of 
the vertical line to soften the image (this is a “low pass filter”). 
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5) File > Preferences> Display General   Set the Default Stretches for 8-bit imagery  
       to “No Stretch” >  OK 

     This will load new 8-bit images without any enhancement. 

6) Right-click on the 10m resample_tif image in the Layer Manager  > View Metadata. 

View the metadata for the 5m resampled_tif and the 60 cm image_tif 

Question 1:   A. What is the map projection and datum for the 3 images? 

      B. How big is each image in KB, and the number of pixels in the columns  
  and rows? 
 

7) Turn-on (check) the 5 m and 60 cm images in the Layer Manager 

      Right-click on the “60 cm image_tif.tif”    View Metadata.    

    Export > Selected node to a file > Close 

Question 2:  What is the format is the exported metadata?  Why is this a useful format? 

8) Display > Cursor Value     Move the cross-hairs around with the “Select” arrow. 

Question 3:  What is the range of digital numbers (DNs) for the 60 cm image? 

Question 4: can you identify the tanks on the 10 m image? 

Question 5: Can you identify roads on the 5 m image?  What is their characteristic? 

9) Views > Two Vertical View     Activate the blank view so it has a color boundary 
 around it and the “View” text in the Layer Manager is highlighted. 

 File > Open > A 3-bit.tif, C 5-bit.tif, and E 8-bit.tif    
  These 3 images are shown in Figure 1-9 (see also Figure 1-10). 

 Zoom to Full Extent icon.    Unclick the 5-bit and the 8-bit images. 

 Use the Zoom tool and enlarge the 4 tanks and ground in the southeast central 
 portion of the image.  Turn on & off the 3 images. 

Question 6:   A. 3-bit images have how many levels of gray? 

  B. 5-bit images have how many levels of gray”? 

  C. Do you see much difference between the 5-bit and 8-bit images?   
  Why? 
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10)  Zoom into the same tank on the left and right view.  Use the Pan tool to center the 
tank in the view. 

 Use the measuring tool “Mensuration” to measure the dimension of the tank. 

Question 7:   A. What are the two measurements of the same tank in the two views? 

  B. Why the difference? 

11) Views > One View  (don’t save any annotation).    We are going back to one view. 

 Right-click on “View” in the Layer Manager and “Remove all Layers”  (don’t save 
 any annotation).   The Layer Manager should be blank. 

12) File > Open >        Locate the folders in the Remote Sensing Digital Database 
named “Ch_2_Aerial_Images\Plate_3_NAIP_Aerial_Multispectral” 

 Open the “NAIP_CIR_432…”, “NAIP_Color_321…”, and “NAIP-4band…” TIFs 

  Highlight each tif file (the largest 3 files in the subfolder) > Open. 

 The 3 data sets are in the one view.  Move the “NAIP_Color…”  image to the 
 bottom of the Layer Manager list (highlight and drag to bottom of the list).   

NOTE: The 4 NAIP bands, along with a map are shown in the textbook’s 
Figure 2-27.  The natural color and color IR images are shown in the 
textbook’s Plate 3. 

 File > Data Manager      If not already opened, open the Data Manager so you  
     can see how many bands are in each dataset. 

 Zoom to Full Extent icon.  Unclick the “NAIP_CIR…” and the “NAIP_4band…” 
 layers in the Layer Manager.     

 The “NAIP_Color…” image should appear with natural colors.  This image was 
 acquired in June when non-irrigated grasses that cover the hills are very dry and 
 should appear with shades of yellow.  What color is the grass on the hills in your 
 view?  If the non-irrigated grass is not yellow, the order of the bands in the color 
 display is incorrect (See Plate 3A). 

NOTE:  A typical problem to solve when loading data is the order that bands 
are sequenced in a dataset.  The USDA delivers 4-band NAIP data in the 
following order:  reflected blue light = band 1, reflected green light = band 2, 
reflected red light = band 3, and reflected Near IR light = band 4.  A natural 
color image should display in ENVI as bands 3, 2, 1 in red-green-blue.   
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But you may see that ENVI loaded the color image with bands 1, 2, 3 as red-
green-blue.  That is incorrect!    

The metadata that accompanies a remote sensing dataset should document 
the sequence of bands to help minimize the confusion. 

13) We’ll change the color images band order next to correct the problem. 

 Right-click on “NAIP_Color…”  in the Layer Manager > Change RGB Bands… 

  In the Change Bands window (see below) Click Band 3 first (displayed  
  with red light), Band 2 next (displayed with green light) and Band 1 last  
  (displayed with blue light)  >  OK 

 

 Now the dry grass should appear yellow. 

 Right-click on the “NAIP_Color…” image and View Metadata. 

14) Enhancing the image.  Start with “No stretch”.  Use the Brightness slider – when 
 done, return to 50. 

 Contrast stretching is discussed in the textbook’s Chapter 9 Digital Image 
 Processing.  Also see textbook Figures 9-12 and 9-13. 

 Click on the Histogram Stretch icon.  You will see the 3 histograms for the color 
 image.  The NAIP image is collected as 4 bands (reflected blue, green, red, and 
 near IR as bands 1, 2, 3, and 4).  The color image is bands 1-2-3 displayed in 
 blue-green-red. The CIR (color infrared image is bands 2-3-4 displayed in blue-
 green-red.  The 4-band multispectral data enables you to change the band 
 combinations and color composite using the 4 bands.   

 The Histogram Stretch display is shown below for the 3 bands in the  
 “NAIP_Color…” image.   There is no contrast stretch applied. 
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Question 8:  How many bits is this data?  How many levels of gray?  

Question 9:   Between approximately what low and high DN (brightness) values   
  (numbers along the  horizontal axis) are most of the pixels in this dataset? 

We can use the contrast-stretching tools to improve the range of brightness and 
improve the information content in the color image.  First let’s do the enhancement with 
the options provided in the contrast stretch drop-down menu. 

 Choose “Linear 1%”     Is the image more informative? Zoom in and pan around 
 to make your determination. 

 For this contrast stretch, 1 % of the pixels are moved to pure black (DN = 0) on 
 the left side of the histogram and 1% of the pixels are moved to pure white (DN = 
 255) on the right side of histogram).  You see the 1% vertical lines on the 
 Histogram Stretch plots. 
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Question 10:  Why did moving 1% of the dark and bright pixels to 0 and 255, 
respectively, improve the range of colors displayed in the color composite? 

 

 Choose “Linear 5%”   What happened to the information content displayed in the  
     industrial and developed areas? 

15) Now let’s manually change the % of pixels changed to pure black or pure white.  

 Use the Drop-down menu and choose “No Stretch” 

  Place your cursor on the left and right side of the red histogram and move the 
 bars inward so that approximately 2% of the pixels are moved to pure black or 
 DN = 0 (left side) and pure white or DN = 255 (right side).   

 What happens to the natural color image when you do contrast stretching only 
 only one band – in this case the band illuminated with red light?  

 Repeat the 2% linear stretch on the green and blue bands.  Is the image more 
 informative?  Zoom in and pan around to make your determination if a Linear 2% 
 stretch was better than a Linear 1% stretch that we did earlier. 

16) Let’s save our enhanced Linear 2% contrast-stretched color image for a GIS.   

 Highlight the “NAIP_Color… file name in the Layer Manager.  

 File > Export Selected File to TIFF…   Name the file “Enhanced_NAIP_Color.tif” 

Question 11:  A. How large is this tif file in MB?          

  B. How large was the original NAIP_Color_321…tif” image? 

  C. Is your enhanced image better looking than the original?  

 File > Chip File To >  Geospatial PDF…     

  Fill in with your name, course ID, and a few keywords (metadata!!). 

  Output file name:  “Your Name_Enhanced_NAIP_Color pdf” 

  Do you like the thumbnail image? 

  Upload this pdf to the instructor. 

 File > Chip File To > Google Earth    you don’t get to name the kmz… 
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  Look at your image in Google Earth.  Do you like it? 

  The name may be “ENVI View”… not very useful… 

    

17)  Let’s reset the stretch to “No stretch”.  Click through the different stretches in the 
drop-down menu.  Which one do you like the best? 

 Zoom into the golf course in the lower right. 

 Turn on the “NAIP_Color_321…” and the “NAIP_CIR_432…” image in the Layer 
 Manager.  Unclick the “NAIP-4band…” data. 

 Turn on the Portal and move it  around with the Select arrow. 

  Display > Portal 

  Hopefully you will see the color image in the portal – and the color IR  
  image as the background – or vice versa. 

 Zoom in with the Portal active.  Very cool(!) – it stays the same size while you 
 zoom in & out.  Use the Select arrow to pan the Portal around. 

 You are looking at 1 meter digital airborne imagery. 

18)  Above the Layer Manager are 3 icons – Blend, Flicker, and Swipe  

 Touch the Swipe tool icon.  You should see the “NAIP_Color_321…” being 
 swiped over the “NAIP_CIR_432…”  

 Unclick the [p] file (Portal) in the Layer Manager so the Portal does not display 
 while the Swipe tool is active. 

 Right-click on Flicker and Portal [p] files in the Layer Manager and Remove. 

19)  Views > Two Horizontal Views 

 Drag and drop the color IR image from the 1st view into the 2nd view. 

 Turn-off the color IR image in the 1st view.  Have the color image turned on in the 
 first view. 

 Views > Link Views > Geo Link >Link All > OK 

 Zoom in and pan around. 
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20)  Views > One View  > Click on “NAIP-4band…” multispectral data set. 

 The data will be in the Data Manager if it doesn’t appear in your view.  Select 
 bands 4-3-2 as red-green-blue so a Color IR image is displayed. 

 Use the Equalization contrast stretch in the drop-down menu.  Click on the 
 adjacent (to the left) icon to apply the stretch to only the view. 

  Stretch on View Extent  

 This “harsh” contrast stretch should reveal subtle irrigation patterns and dry 
 portions of the golf course, along with strange linear patterns paralleling the 
 fairways (due to uneven fertilizer application or mowing issues?  (See below) 

 

 Zoom to a scale of  1:4000 in the drop-down menu near the top center of the 
 ENVI window.  Ensure in the view that you have a pond in the upper left and 
 and lower right with golf fairways in between. 

 Display > Profiles > Spectral    or   click-on the Spectral Profile icon along the top 
 row of tools.  This tool shows the reflectance at individual pixels for the 4 bands. 

 Use the Select arrow to move the crosshairs around the golf course targeting 
 water, irrigated grass in the golf course, non irrigated (dry grass) outside the golf 
 course, concrete, building tops, asphalt, etc.  (See below) 
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Spectral signature for healthy irrigated 
golf course grass. 
 
Horizontal Axis shows bands 1 – 4: 
1 = reflected blue light 
2 = reflected green light 
3 = reflected red light 
4 = reflected Near IR light  

  

Question 12: A. What happens to the Data Value (brightness) of Band 3 (red) and Band  
  4 (near IR) when you measure reflectance on irrigated grass at the golf  
  course? 

  B. What happens to Band 4 when you measure the reflectance over  
  water? 

  C. What are the two brightest bands when you measure reflectance over  
  dry grass outside of the golf course? 

21)  Now we’ll do a spectral profile (a transect or a line) of reflected near IR, red, and 
green light across the golf course. 

 Zoom to a scale of  1:4000 in the drop-down menu near the top center of the 
 ENVI window.  Ensure in the view that you have a pond in the upper left and 
 and lower right with golf fairways in between. 

 Display > Profiles > Arbitrary  

  Start on the lake in the upper left and move the cursor to the lake at the  
  lower right and click to stop line – and a graph pops up.  Maybe you have  
  to click the end of the line a couple times. 

  In the Arbitrary Profile transect window, click on the black triangle in the  
  white area of the right margin to reveal what bands are associated with  
  what color line. 

  Options (drop-down menu) > Curve Smoothing      (see below) 
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Question 13:  A. What happens to the Near IR reflectance (brightness or Data Value) 
  value (red line) in water? 

  B. What happens to Near IR brightness in the golf course fairways?  

  C. Reflected green light is brighter than reflected red light over the   
  irrigated grass on the fairways?  Why do you already know this fact? 

  D. Do you have any idea why green light is reflected more strongly from  
  healthy vegetation compared with red light? 
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Lab 1 Introduction to ENVI Answer Sheet             Name: 

Upload the following file to the instructor: 

 (16) Your Name_Enhanced_NAIP_Color pdf”  pdf  

 
Question 1:   A. What is the map projection and datum for these 3 images? 

  B. How big is each image in KB, and the number of pixels in the columns  
  and rows? 

     KB            columns          rows 
 
   60 cm: 

   5 m: 

   10 m: 

Question 2:  What is the format is the exported metadata?  Why is this a useful format? 

Question 3:  What is the range of digital numbers (DNs) for the 60 cm image? 

Question 4: Can you identify oil storage tanks on the 10 m image?  Why? 

Question 5: Can you identify roads on the 5 m image?  What is their characteristic? 

Question 6:   A. 3-bit images have how many levels of gray? 

  B. 5-bit images have how many levels of gray”? 

  D. Do you see much difference between the 5-bit and 8-bit images?   
  Why? 

Question 7:   A. What are your two measurements of the same tank in the two views? 

  B. Why the difference? 

Question 8:  How many bits is this data?  How many levels of gray?  

Question 9:   Between approximately what low and high DN (brightness) values   
  (numbers along the  horizontal axis) are most of the pixels in this dataset? 

Question 10:  Why did moving 1% of the dark and bright pixels to 0 and 255, 
respectively, improve the range of colors displayed in the color composite? 
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Question 11:  A. How large is this tif file in MB?          

  B. How large was the original NAIP_Color_321…tif” image? 

  C. Is your enhanced image better looking than the original?  

Question 12: A. What happens to the Data Value (brightness) of Band 3 (red) and Band  
  4 (near IR) when you measure reflectance on irrigated grass at the golf  
  course? 

  B. What happens to Band 4 when you measure the reflectance over  
  water? 

  C. What are the two brightest bands when you measure reflectance over  
  dry grass outside of the golf course? 

Question 13:  A. What happens to the Near IR reflectance (brightness or Data Value) 
  value (red line) in water? 

  B. What happens to Near IR brightness in the golf course fairways?  

  C. Reflected green light is brighter than reflected red light over the   
  irrigated grass on the fairways?  Why do you already know this fact? 

  D. Do you have any idea why green light is reflected more strongly from  
  healthy vegetation compared with red light? 
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Lab 2  Landsat Multispectral Processing 
Utilizes Textbook’s Remote Sensing Digital Database: Chapter 3 data. 

The objectives of this lab are to learn the processing tools on ENVI’s main display 
window that are used to interrogate, display, and display multispectral data.   

 Evaluate individual bands 
 Quick stats (overview of dataset statistics) 
 Compare an enhanced image with original USGS data 
 Spectral profile 
 Evaluate different color composites in four display Views 
 Regions of Interest (ROIs)  
 Scatter plots (feature space) 

Eight questions are asked during this lab – you are to write your answer on the sheet 
that is at the end of this handout.  Two files are to be uploaded to the instructor. 

1) Open the Remote Sensing Digital Database chapter 3 folder named “Plates_7 and 
27_Thermopolis”.  You can see that all the Landsat 8 bands and derived images that 
are explained in the textbook are contained within this folder.  Also there is a folder 
named Lab_2_Data that has other data used in this lab. 

 Open ENVI (the GIS-look option) and load the 9-band Landsat data in ENVI 
 format named:  “Thermopolis_Landsat8_bnds1-7_10-11_30m_ENVI_”.  

NOTE:  The ENVI file has more information compared with the GeoTIFF because the 
wavelength (blue, NIR, Thermal IR, etc.) can added to the band number and displayed 
in the Layer Manager and Data Manager. 

 Zoom to full extent.  Note that the first 3 bands are automatically displayed by the 
 ENVI software based on the default Preferences.  To see what bands are 
 displayed you have to click on the “+” sign to the left of the file name (see below). 
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  File > Data Manager     Lists all 9 bands in this Landsat dataset 

 Look at Figure 3-11 A-G in the textbook.  The geologic map is Figure 3-11H.  
 Also look at Plate 7.  We’ll examine the spectral characteristics of the Red  Rose 
 Anticline and the agricultural fields in the upper right along the Wind River. 

2) Let’s examine each of the 9 bands.  Right-click on the file name in the Layer Manager 
> Band Animation.  ENVI flickers through the 9 bands rapidly(!) by default. 

 

 Slow down ENVI….Use the dropdown menu in the lower left of the Band 
 Animation tool to choose 2 seconds or 5 seconds. 

Question 1: Which band is most unlike the other 8 bands? 

3) Let’s load 7 of the individual bands.  Open the “Bands” subfolder that is in the 
Remote Sensing Digital Data chapter 3 folder named  “Plates_7and27_Thermopolis”.   

 Landsat OLI bands 2-7 and 10 are available for loading into ENVI. 

 Highlight the seven TIFF images with the Control (Ctrl) Key down and click Open 

 Turn-off all the bands in the View except “Band 10 Thermal_tif.tif” in the Layer 
 Manager View 

  Right-click on Band 10 in the Layer Manager and View Metadata.   

   What is the pixel size of this thermal IR band? _____ 

  Right-click on Band 6 in the Layer Manager and View Metadata.   

   What is the pixel size of this SWIR1 band? _____ 
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 The Landsat 8  TIR sensor acquires thermal IR bands 10 and 11 with 100 x 100 
 m pixels.   The Landsat 8 OLI sensor acquires VNIR-SWIR bands 1 to 7 with 30 
 x 30 m pixels.  The USGS resamples the thermal IR bands to 30 x 30 m pixels 
 for delivery to users. 

Question 2: Why are the Landsat 8 thermal IR bands collected with pixels that cover an 
area more than 100 times larger than the VNIR-SWIR 30 x 30 m pixels?  

  (see Equation 1-2 and Table 3-1 in the textbook) 

4) Turn on Landsat OLI band 5 NIR.  Right click > Quick Stats 

 Select Plot > Histogram Band 1 (Drop-down menu in upper left of Quick Stats) 

 This Landsat band was resampled to 8-bit from the original data delivered by  
 the USGS and contrast-stretched for the textbook figure.  You are viewing a 
 contrast-stretched grayscale image (you would not know this unless the remote 
 sensing analyst documented the radiometric change in the metadata). 

Question 3:  A. What is the Mean and Standard Deviation of all the pixels in the   
  grayscale Band 5 NIR? 

  B. What percentage of pixels have values within one standard deviation of 
  the mean?  (see textbook Figure 9-3 for explanation) 

  C. What digital number (DN) is displayed by the most pixels (Data Value  
  on the horizontal axis of the histogram)?  How many pixels have that DN  
  (“Count” value)?  What percentage of the 256 DNs is contained by this  
  largest DN? 

5)  Let’s zoom into the area shown in the textbook’s Figure 9-2.  Turn on Landsat band 
5 NIR.  Load the UTM Zone 13 vector polygon shapefile named “Textbook Fig 9-2 
Thermopolis.shp” that is in the Lab_2_Data folder.   

 File > Open > “Textbook Fig 9-2 Thermopolis.shp”   (the type of file to load is 
 designated “SHP”.  Many files are required to support a shapefile(!) 

 Right click on the shapefile in the Layer Manager > Properties > change “Line 
 Thickness” to 3  >   Change “Line Color” to black so that the rectangular polygon 
 is displayed more clearly. 

 We want to replicate some of Figure 9-2.  Turn-off all images and bands except 
 Band 5 NIR.  Display the band 5 with “No Stretch”.   You have to keep 
 highlighting “Band 5 NIR” in the Layer Manager while the vector shapefile is 
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 turned-on to use tools and to see information about the raster band 5. 
  Zoom-in so the polygon fills your View 

 Display > Cursor Value    Move the crosshairs around the image with the Select  
     tool (arrow) 

 What is the brightest DN value for band 5?  What is the darkest DN value for 
 band 5? 

 Turn-off the shapefile.  Highlight Band 5 NIR in the Layer Manager 

  Display > Profiles > Arbitrary 

  Draw a profile that mimics a – a’ on Figure 9-2A  (keep clicking until the  
  profile pops up in a window). What do you see as the high and low DNs  
  (see figure below).   

 

a- a’ profile of Band 5 NIR 

6) Let’s look at band 5 in the 9-band dataset (Thermopolis_Landsat8_bands1-7_10-
11_30m_ENVI_).  Highlight this color composite in the Layer Manager.  Change the 
band combination to a 7-5-2 as red-green-blue. 

 Right-click the 9-band Landsat dataset in the Layer Manager > Change RGB  
 Bands…     The bands in this dataset have the original DNs delivered by the 
 USGS.  

 Right click on the 9—band Landsat dataset > Quick Stats        

  Select Plot >  Histogram Band 5  



5 
 

5 Introduction to Remote Sensing  Principles, Interpretation, and Applications 
F. F. Sabins and J.M. Ellis, 2020, Waveland Press.    Contact:  jellis@ellis-geospatial.com 

 

Question 4:  A. What is the Mean and Standard Deviation of all the pixels in the  
  9-band Landsat dataset’s Band 5 NIR? 

  B.  Scroll down (or use the “Locate Stat” dropdown menu) and select Band 
  5.   Computer screens can typically only display 256 levels (DNs) of  
  brightness. So each DN on the histogram and your computer screen  
  contains many DNs from the original USGS data.  How many original DNs 
  are contained within each DN displayed in the histogram and on the  
  computer screen (look for “binsize =….”)   

  C. What range of original USGS digital numbers (DN) have the highest  
  count in band 5?   

  D. How many pixels (the “Count” value) in band 5 have the highest DN? 

  E. The USGS delivers Landsat 8 OLI and TIR bands with 16-bit   
  radiometric resolution!  How many levels of brightness is available with 16- 
  bit data?    
 
   NOTE:  The Landsat 8 system collects the data with 12-bit   
   radiometric resolution (see Textbook Table 3-3). 

7) Let’s examine a color IR image generated from the  “Thermopolis_Landsat8_bands1-
7_10-11_30m_ENVI_” dataset.  The area we are evaluating continues to be within the 
shapefile and the textbook Figure 9-2. 

 Right-click on the file name in the Layer Manager and Change RGB bands… 

  Generate a color IR image (Bands 5-4-3 or NIR-red-green in R-G-B).  To  
  see what bands are displayed you have to click on the “+” sign to the left  
  of the file name. 
  Zoom to Full Extent 

  Contrast-stretch the color IR image – use the “Linear 2%” stretch 

 Display > Cursor Value    Move the crosshairs around the image with the Select  
 tool (arrow).  The DNs for the 3 bands are displayed in the “Data:” field. 

 What is the approximate brightest DN value for band 5 NIR?  What is the 
 approximate darkest DN value for band 5 NIR? 

 Turn-on the shapefile.  Zoom-in to the shapefile polygon.   Highlight the 9-band 
 Landsat dataset in the Layer Manager 
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  Display > Profiles > Arbitrary 

  Draw a profile that mimics a – a’ on Figure 9-2A.  Where do you see the  
  high and low DNs for Band 5? 

Question 5:  A. How is the DN profile from the enhanced grayscale Band 5 NIR (shown  
  above) compare with the DN profile from the original USGS data for Band  
  5 NIR (seen as a red line in the profile (not shown))?   

  B. What is different about the profiles?  (Do not include the difference in  
  the “Data Value” on the vertical axis) 

  C. Why the difference in the profiles?  (Hint: what is different in the image  
  processing?) 

Question 6:  Reflected near IR light is very bright (high Data Value) over irrigated 
agricultural fields on your Arbitrary Profile across the original USGS Landsat data.  On 
this same plot, what happens to the reflected red light (band 4) over irrigated agricultural 
fields in comparison to reflected green light (band 3)?  Any idea why this occurs? 

8) Let’s look at the brightness values of the 9 bands in the 
“Thermopolis_Landsat8_bands1-7_10-11_30m_ENVI_” dataset.  Highlight the color IR 
image in the Layer Manager.  The bands in this dataset have the original DNs delivered 
by the USGS.  

 Right click on the 9—band Landsat dataset > Quick Stats        

 The horizontal axis labelled “Unknown” represents the band number.  The visible 
bands are 1-4, the NIR band is 5, the SWIR bands are 6 and 7, and the thermal IR 
bands are 8 and 9 on the horizontal axis.  The “Data Value” vertical axis represents the 
16-bit DNs (brightness value ) that are delivered with Landsat 8 radiance data.  See 
below. 
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Question 7:   A. Explain the statistical plot above.  (also look at the metadata table) 

  B. What band has the highest mean DN? 

  C. What band has the highest DN range? 

  D. What band has the largest standard deviation? 

9) Zoom out on the color IR image so that you see the Red Rose Anticline and the 
agricultural fields (perhaps with a map scale of 1:100,000).  Let’s look at a spectral 
profile at individual pixels. 

 Display > Profiles > Spectral 

 Move the crosshairs around with the select arrow and click on different pixels.   

  Examine the profile at the following features: 

   Irrigated agricultural field 
   Wind River 
   Airport  
   Different color geologic outcrops 

  What band varies the most?  What bands vary the least?   
    

10) Let’s change the Color IR image in our View to a natural color image. 

 Right-click on 9-band Landsat data set in Layer Manager > Change RGB Bands 
 > Select Band 4 - Band 3 - Band2 as R-G-B > OK  > Zoom to Full Extent > 
 Contrast Stretch to “Linear 2%” 

Now let’s generate 4 Views and load three other band combinations in each one, then 
link the four views so we can pan and zoom in and out and easily compare the different 
colors composites. 

Views > 2 X 2 Views      We’ll load the empty Views using the Data Manager. 
 
Highlight View 2 (upper right) with your cursor.  Data Manager > Select Band 5 – Band 
4 – Band 3 as R-G-B in the 9-band Landsat data set  > Load Data  > Zoom to Full 
Extent > Contrast Stretch to “Linear 2%” 

Highlight View 3 (lower left) with your cursor.  Data Manager > Select Band 7 – Band 5 
– Band 2 as R-G-B in the 9-band Landsat data set  > Load Data  > Zoom to Full Extent  
> Contrast Stretch to “Linear 2%” 
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Highlight View 4 (lower right) with your cursor.  Data Manager > Select Band 7 – Band 6 
– Band 5 as R-G-B in the 9-band Landsat data set  > Load Data  > Zoom to Full Extent 
> Contrast Stretch to “Linear 2%” 

 To see what bands are displayed you have to click on the “+” sign to the left of 
 the file name. 

 Turn-off all other images and shapefile in the Layer Manager .  Each View should 
 only have the color composite checked in the Layer Manager and displayed. 
 
Now we will link the four Views.   
 Views > Link Views  >   GeoLink active >   Link All    > OK 
  Pan around     Zoom in & out 
 
Question 8: List the colors displayed with the different color composites in the 
agricultural fields along the Wind River.  Zoom in on a field with much irrigation and 
vigorous crops and a field with limited irrigation and less vigorous crops to fill in the 
blanks on the table. 

  a) natural color (red-green-blue in R-G-B),  

  b) color IR (NIR-red-green in R-G-B) 

  c) enhanced color (SWIR2-NIR-blue in R-G-B) 

  d) total IR (SWIR2-SWIR1-NIR in R-G-B) 

11)  Close 3 of the 4 Views.   
 Right-click on “View” in the Layer Manager >  Remove View  
 In the remaining View > Zoom to Full Extent 

We will now examine the correlation between the different bands using the Scatter Plot 
Tool.  We will be working with the same  
  “Thermopolis_Landsat8_bands1-7_10-11_30m_ENVI_” dataset.  
 Change RGB Bands > 5-4-3 as red-green-blue (color IR) 
 Turn off other layers in your Layer Manager.   
 You will be doing statistical analysis using all the pixels in each band. 

 Display > 2D Scatter Plot     (Picture below)  
  Press the “Toggle Density Slice” tool (upper center) to see the pixel  
  density scaled to color.   
  Click the “Full Band” box.   
  Change the Class 1 color from default red to yellow. 
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 White areas in the scatterplot show where the highest number of pixels
 overlap between the two bands while black areas have the least number of 
 overlapping  pixels. 

 Start with bands 1 versus 2, and work your way through band combinations.  
 Ignore the thermal bands (# 8 and 9 in the Scatter plot) 

 Note how band 5 NIR is significantly different from the other VNIR-SWIR bands 

 Display Band 5 NIR versus Band 4 Red in the color Scatter plot  
 (see picture below).  On the image in the ENVI View, as you  
 move your mouse around you should see a small square. 
 If you don’t, close the scatter plot tool, highlight the 9-band 
 Landsat dataset in the Layer Manager and reopen the 2D scatterplot display 
  Display > 2D Scatterplot 

  As you move your mouse over irrigated agricultural fields – you will see the color 
 IR red pixels display where the Band 5 NIR have high DN values and the Band 4 
 Red have low DN values in the scatterplot.  The image is connected to the 
 Scatter plot! 

 On the scatter plot, draw a polygon around the pixels with high Band 5 NIR DNs 
 and low Band 4 Red DNs.  This is “Class 1”.  (see below).  You will see those 
 pixels that have band 5 and band 4 pixels within your polygon light up on the 
 color IR image!  You have identified vigorous vegetation in the agricultural fields. 

 



10 
 

10 Introduction to Remote Sensing  Principles, Interpretation, and Applications 
F. F. Sabins and J.M. Ellis, 2020, Waveland Press.    Contact:  jellis@ellis-geospatial.com 

 

 Let’s upload the Landsat color image with the Class 1 pixels highlighted to the 
 instructor as a “geospatial pdf”. 

 File > Export View To > GeoSpatial pdf    (the pdf has coordinates!) 

  Briefly fill in the blanks on the form (this is metadata!) 

  Name the pdf “Your Name_Landsat_vig_veg” 

12) Now we will use the scatter plot tool to display the spectral characteristics of   select 
features that you will map with ENVI’s ROI (region of interest) tool. 
 Clear the yellow Class 1 on the scatterplot.  Options > Clear Class 

   Use the Toggle Density Tool (upper center) to change 
      to a Black pattern for the pixel distribution. 

 Go to the main ENVI display to access the ROI tool. 
 File > New > Region of Interest    The Region of Interest (ROI) Tool pops up  
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We will create 4 ROIs using the default Geometry > polygon tool in the menu above.  
The ROIs will represent: 
  Irrigated vigorous vegetation  
  Water in the Wind River 
  Outcrop of the Chainman Shale 
  Airport tarmac (asphalt?) 

 
We will display the Landsat as a 7-5-2 as R-G-B color image.  Use a Linear 2% stretch. 

We will use a GIS vector shapefile that has each of the four features above mapped as 
points.  Draw your ROI polygon around those pixels near the shapefile point that are 
“pure” pixels for the feature of interest. Don’t mix other pixels as that will degrade the 
spectral signature of our four features of interest. 

 File > Open   open the “Lab_2_Data” folder and select the 
    “ROI_sites on Thermopolis Landsat.shp” file.  (the SHP File). 

The four points will display on the ENVI view.  The points are located across the center 
of the image.  They are difficult to see!  Right-click on the ROI sites shapefile in the 
Layer Manager and change the Properties – enlarge the “Point Size” to “20”.  Maybe 
change the color to “Black”. 

 Location of shapefile points 
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If you can’t see the shapefile points clearly, the longitude and latitude coordinates are 
provided below.  Drive your Zoom tool (enables zooming in with a rectangle area of 
interest) to each point, zoom-in, and create a polygon ROI. 

  

 

 

  

 

 a) Zoom into the vigorous agricultural field and draw a ROI polygon within the 
 bright green pixels.  Double-click at the end of your polygon line to close the  
 polygon and create the ROI 
  Rename the ROI #1 to “Irrigated vegetation”.    
  Click-on the upper left icon “New ROI” to create a new ROI. 

 b) Zoom into the Chainman Shale outcrop and draw a ROI polygon within the 
 yellow-orange to orange pixels. 
  Rename the ROI #.. to “Chainman Shale”.   
  Click-on the upper left icon “New ROI”. 

NOTE:  the polygons and ROIs can get mixed up.  You may have to       
delete an ROI, edit the name (right-click on the ROI in the Layer Manager), 
and redo an ROI.  Look at the Layer Manager and Data Manager       
to see if you are correctly making four ROIs over four areas on the          
Landsat image.  If you get two polygons in your ROI, just use the Record 
Count at the bottom of the ROI Tool and delete the incorrect polygon.  
PATIENCE!! 

 c) Zoom into the Airport tarmac and draw a ROI polygon within the darkest 
 pixels.  (change the shapefile color from black to yellow so you can see it…) 
  Rename the ROI #.. to “Airport tarmac”.   
  Click-on the upper left icon “New ROI”. 

 d) Zoom into the Wind River water and draw a ROI polygon within the  
 darkest pixels.   
  Rename the ROI #.. to “Water”.   
 
You should see the four ROIs under a folder named “Regions of Interest” in the Layer 
Manager.  Let’s rename this folder  

Feature of Interest Longitude Latitude 

Irrigated Vegetation -108.1263 43.7313 

Chainman Shale -108.2886 43.6956 

Airport tarmac asphalt -108.3788 43.7161 

Water -108.1574 43.7012 
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 Right-click “Regions of Interest” folder  > Save As    
     “Your Name_ROIs_for_ScatterPlot” 

NOTE: You can also save the four ROIs using the Regions of Interest (ROI) 
Tool.  File > Save As     Click-on the “Select All Items” button.  

13) Now let’s see where these four ROIs are located on our scatter plot. 
 First you have to highlight the 9-band Landsat data in the Layer Manager! 
 Display > 2D Scatter Plot  (if not already opened) 
        Choose band 4 on the vertical axis and band 5 on the horizontal axis. 
 
 Use the Toggle Density Slice to make the scatter plot black. 

 On the Scatter Plot Tool   File > Import ROIs 
  You should see the 4 ROIs you just created(!)    
  Push the “Select All Items” button. 
 You will the pixels that match your ROI spectral signatures show up on the  
 black scatter plot with default colors.  Let’s change the colors to brighter shades. 

  

Chainman Shale 

Water 

Airport  
tarmac 

Irrigated Vegetation 
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 The ROIs reveal that each of the classes has a unique spectral signature that is 
 differentiated on the band 4 (red) versus band 5 (NIR) scatter plot!  You also see 
 the same-color pixels on the image in the ENVI view.  There are few asphalt 
 pixels and no (?) water pixels outside the Wind River with the same spectral  
 characteristics as our ROIs. 

 Save the scatter plot as an image      File > Save Plot As > Image. 

  Name the plot “Your Name_Scatterplot_with_ROIs” 

  Upload the .jpg or .png image to the instructor 
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Lab 2 Multispectral Landsat Processing   Name: 

Upload the following files to the instructor: 
 
 (11) “Your Name_Scatterplot_map.pdf”   
 
 (13) “Your Name_Scatterplot_with_ROIs.png” 

Question 1: Which band is most unlike the other 9 bands? 

Question 2: Why are the Landsat 8 thermal IR bands collected with pixels that cover an 
area more than 100 times larger than the VNIR-SWIR 30 x 30 m pixels?  
  (see Equation 1-2 and Table 3-1 in the textbook) 

Question 3:  A. What is the Mean and Standard Deviation of all the pixels in the   
  grayscale Band 5 NIR? 

  B. What percentage of pixels have values within one standard deviation of 
  the mean?  (see textbook Figure 9-3 for explanation) 

  C. What digital number (DN) is displayed by the most pixels (Data Value  
  on the horizontal axis of the histogram)?  How many pixels have that DN  
  (“Count” value)?  What percentage of the 256 DNs is contained by this  
  largest DN? 

Question 4:  A. What is the Mean and Standard Deviation of all the pixels in the  
  9-band Landsat dataset’s Band 5 NIR? 

  B.  Scroll down (or use the “Locate Stat” dropdown menu) and select Band 
  5.   Computer screens can typically only display 256 levels (DNs) of  
  brightness. So each DN on the histogram and your computer screen  
  contains many DNs from the original USGS data.  How many original DNs 
  are contained within each DN displayed in the histogram and on the  
  computer screen (look for “binsize =….”)   

  C. What range of original USGS digital numbers (DN) have the highest  
  count in band 5?   

  D. How many pixels (the “Count” value) in band 5 have the highest DN? 

  E. The USGS delivers Landsat 8 OLI and TIR bands with 16-bit   
  radiometric resolution!  How many levels of brightness is available with 16- 
  bit data?    
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Question 5:  A. How is the DN profile from the enhanced grayscale Band 5 NIR (shown  
  above) compare with the DN profile from the original USGS data for Band  
  5 NIR (seen as a red line in the profile (not shown))?   

  B. What is different about the profiles?  (Do not include the difference in  
  the “Data Value” on the vertical axis) 

  C. Why the difference in the profiles?  (Hint: what is different in the image  
  processing?) 

 

 

Question 6:  Reflected near IR light is very bright (high Data Value) over irrigated 
agricultural fields on your Arbitrary Profile across the original USGS Landsat data.  On 
this same plot, what happens to the reflected red light (band 4) over irrigated agricultural 
fields  in comparison to reflected green light (band 3)?  Any idea why this occurs? 

 

 

Question 7:   A. Explain the statistical plot.  (also look at the metadata  table) 

  B. What band has the highest mean DN? 

  C. What band has the highest DN range? 

  D. What band has the largest standard deviation? 
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Question 8: List the colors displayed with the different color composites in the 
agricultural fields along the Wind River.  Zoom in on a field with much irrigation and 
vigorous crops and a field with limited irrigation and less vigorous crops to fill in the 
blanks on the table. 

 

     Features of               
Interest 

 
 
 

OLI Bands__      

Agriculture 
fields with 

much 
irrigation and 

vigorous 
crops 

Agriculture 
fields with 

limited 
irrigation and 
less vigorous 

crops 

Natural Color 
OLI 4-3-2 

as 
R-G-B 

  

Color IR 
OLI 5-4-3 

as 
R-G-B 

  

Enhanced 
Color 

OLI 7-5-2 
as 

R-G-B 

  

Total IR 
OLI 7-6-2 

as 
R-G-B 
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Lab 3   Image Processing 1 
Utilizes Textbook’s Remote Sensing Digital Database: Chapters 3 and 4 data. 

The objectives of this lab are to learn the processing tools that are used for 
Preprocessing and Image Enhancement (see Chapter 9 Digital Image Processing for 
discussion).  The tools used in this lab are in in the ENVI Toolbox: 

 Statistics (complete, including correlation matrix) 
 Resize Data 
 Rotate/Flip Data 
 Layer stacking 
 Edge enhancement  

Some files are in the Lab_3_Data folder.  Five questions are asked during this lab – you 
are to write your answer on the sheet that is at the end of this handout.   Three digital 
files are to be uploaded to the instructor. 

IMPORTANT NOTE: ENVI does not retain display enhancements for images when you 
use Save As. These include rotating, zooming, contrast, brightness, sharpening, 
stretching, Portals, or viewing multiple layers. Use the Export View To > Image File to 
retain display enhancements and original scale (choose Zoom Factor 1.0000). 

1) Statistics 

 We will use a Landsat 8 data set located in the “Remote Sensing Digital 
 Database \ Ch_3_Landsat” folder.  Open the subfolder named 
 “Plate_6_1979-2016_Saudi_Change”.   
 Open the subfolder “Landsat-8_2016_OLI-TIRS”. 

 Open ENVI.  File > Open  

  “Saudi_Landsat8_2016_Bnds1-7_10-11_Stack_Clip_ENVI_” 

  This Landsat data has 7 VNIR-SWIR bands and two TIR bands.  We will  
  evaluate the statistics for OLI bands 2-7. 

 Zoom to Full Extent,    File > Data Manager    So you can see all the bands. 

 Right-click  on file in Layer Manager > Change RGB Bands..       

  Load 7-5-2 as R-G-B.   (these are SWIR2 – NIR – Green bands) 

  Your display should appear as below – note the Toolbox on the right. 
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Toolbox > Statistics > Compute Statistics 

 A “Compute Statistics Input File” menu pops up.  Highlight the Saudi Landsat 8 
 input file.   We want to show statistics on the six VNIR-SWIR bands that record 
 reflected blue, green, red, NIR, SWIR1 and SWIR2 light (Landsat OLI bands 2 – 
 7). To do this, click on the “Spectral Subset” button that has “9/9  bands”  
 displayed.   

   A smaller menu “File Spectral Subset” pops up.  We will select bands 2 – 7 with 
 the Shift or Ctrl key, and then press    Add Range  > OK     

 Note the “Spectral Subset” number changes to “6/9 Bands” on the “Compute 
 Statistics Input File” menu.   

 > OK on the “Compute Statistics Input File” window (lower left) 

 See menu below for selecting 6 of the 9 bands. 
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A “Compute Statistics Parameters” menu pops up.  (see below)  Check all the boxes.   

 Accept the default names for the ENVI statistics .sta file and the .txt Report 
 FileName.  If the default name is blank, use “VNIR-SWIR_stats…” 

  Click OK when done. 
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 A Statistics View window pops open because the “Output to the Screen” option 
 was checked.  This Toolbox report is more complete than the Quick Stats report. 

  Push the triangle in the white strip on the right vertical bar next to the chart 
  to reveal details and edit colors and data values. 

  At the bottom of the window are tables.  Scroll down to the “Correlation”  
  table.  

 1.000 is perfect correlation.  The more highly correlated the bands, the higher 
 the correlation value.  Band have perfect 1.00 correlation to themselves in this 
 table (also called a Correlation Matrix).  Negative correlation values (-) indicate 
 that when pixels are light in one band they are dark in the other band. 

Question 1:  (Provide correlation values to the nearest two decimal places). 

  A.  What is the correlation between OLI bands 3 (green) and 2 (blue)? 

  B.  What is the correlation between OLI bands 4 (red) and 2 (blue)? 

  C. What two bands have the least correlation (most difference spectrally)?  

  D.  What two bands have the highest correlation (most similar spectrally)? 

 Open the text document that lists the statistics. 

2) Let’s look at the image in two ENVI views that are linked.  The Saudi Landsat scene 
has active sand dunes, some pivot irrigation plots, and stabilized barren ground without 
vegetation. 

 File > View > Two Horizontal Views      
 Right-click  on file in Layer Manager > Change RGB Bands..       

  View 1:  Load 4-3-2 as R-G-B.   (these are the visible bands).  
   Drag and drop the color image from View 1 to View 2 
   (you can also load View 2 using the Data Manager) 

  View 2:  Right-click  on file in Layer Manager > Change RGB Bands..       
   Load 5-4-3 as R-G-B    (this is a color IR image). 

  File > View > Link Views > Link All 

 Use the Pan to roam around both images.  Zoom in and out.  Interpret what  
  is displayed in the scene 
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 Right-click on the Landsat dataset in one of the Views in the Layer Manager  

    > Band Animation.  Slow down flicker.  You can pan around while flickering. 

Question 2:   Compare the visual gray tone of the sand dunes in the northeast and  
  east of the band 2 (blue) and the three reflected infrared bands (5-7).   
  Does this match the values in the correlation table?  Explain.  

3) Let’s look at a Scatter plot of the 9-band Saudi Landsat data.  Return to one view.  
 Views > One View           
 Only the 9-band Landsat file should be checked in the Layer Manager. 
 Display  > 2D Scatter Plot    
  Compare different combinations of bands. 
   Save an image of the band 2 versus band 5 scatter plot.   

  File > Save Plot As > Image…  “Your name_bands_2-5_Scatterplot” 
   save as a jpg or png. 

   Upload your image of the Scatterplot to the instructor. 

Question 3:   How does the scatter plot of bands 2 and 3 and the plot of bands 2 and 5  
  compare to the correlation table values? 

4) Resize Data        We will clip out a subscene of Band 5 (NIR) from the 9-band Saudi  
   dataset. 

 ENVI Toolbox > Raster Management > Resize Data 
  ‘Resize Data Input File” window pops up.  Highlight the Saudi Landsat 9- 
  band dataset if needed. 

  Click on “”Spectral Subset” button.  “9/9 Bands” is shown next to this  
  button.  A “File Spectral Subset” window pops up.  Highlight Band 5 > Add  
  Range  and “1/9” shows up in the text next to the Spectral Subset button  
  on the Resize menu.  > OK 

  Click on “Spatial Subset” button > “Select Spatial Subset” window pops  
  up.   (see screen capture below) 

   > Click on “Image”  >  “Subset by Image” window pops up.  
  > change Samples and Lines to 300 x 300  
  > move subset box to center of image >  OK > OK > OK.   

 The menus are displayed below with the 3 OK buttons. 
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  A “Resize Data Parameters” window pops up showing the 300 x 300  
  dimensions of the subset area.  (see below).    

  Name the subset image “Your name_subset_band5_ENVI”.   The image  
  will be in ENVI format (.img with .hdr file)   > OK 

  Resize menu 

 The resized ENVI image will display in the center of the larger image in the ENVI 
 view and will be listed in the Layer Manager.   
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 We want to make the clipped band 5 NIR grayscale image more useful for GIS, 
 so we will next convert the ENVI image to the universal geotiff format. 

  Highlight the resized file in the Layer Manager  
  File  > Export Selected Layer to TIFF 

   NOTE:  The same export tool is available with Right-click on the  
   resized file in the Layer Manager > Export Layer to TIFF 

  Rename the file “Your name_subset_band5_geotiff” 

  Check the “Display result” box > OK 
  Upload your geotiff of the resized image to the instructor. 

5) Rotate/Flip Data    We will use an image that does not have any coordinates.  This 
tool is useful when georeferencing scanned images and maps to place them in a 
position where N is approximately up. 

 Right-click View > Remove All Layers  

 In the Lab_3_Data folder is a grayscale image without coordinates from Lab  
 1 named “E 8-bit.tif” 

 File > Open > “E 8bit.tif”   > Zoom to Full Extent 

 Right-click “E 8bit.tif” in the Layer Manager > View Metadata.  Does this image  
   have any coordinate information? 

 Toolbox > Raster Management > Rotate/Flip Data 
  Select “E 8-bit.tif” in the Rotation Input File menu.  > OK 
  In the “Rotation Parameters” menu, Choose the “Standard 90” 
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  Rename the rotated ENVI file “Your name_rotate 90_ENVI” 

  The rotated file automatically displays in ENVI.   
  Upload the rotated image and the same-name .hdr file to the instructor 

6) Layer stacking    Landsat and other multispectral data are delivered as individual 
bands.  In order to generate spectral profiles, complete spectral classification, and do 
other image enhancement tasks, the bands have to be stacked into one database.   

We will use the Landsat 8 bands of Thermopolis that are located in the “Remote 
Sensing Digital Database \ Ch_3_Landsat” folder.  Open the subfolder 
“Plates_7and27_Thermopolis”.  Open the subfolder “Bands”.  

You will see bands OLI bands 2 – 7 and TIR band 10 as .tifs with .tfw files (the .tfw 
contains georeferencing information). 

 In ENVI, Right-click View > Remove All Layers  

 File > Open  highlight the seven  .TIFF  files > Open    (see below) 

 

 The seven bands should be displayed in ENVI.  Zoom to Full Extent 

 Toolbox > raster Management > Layer Stacking 
 The “Layer Stacking Parameters” window pops up > Import File… 
 The “Layer Stacking Input File” window pops up.   
 Highlight the seven bands  > OK    
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 In the “Layer Stacking Parameters” window the georeferenced bands 
 automatically fill in the map projection parameters.   > Reorder Files…   

 See below.  Reorder if band number are not sequential (2 to 7 and then 10) > OK 

 

 Name the output stack “Landsat8_Thermopolis_Stack_7 bands_ENVI” 

  The Data Manager will list the 7 bands. 

 Display different color combinations of your new stacked Landsat bands. 

7) Edge Enhancement 

Let’s remove all the layers in the view and load a commercial, high spatial resolution 
image discussed in the textbook Chapter 4 (see Figure 4-9).  The data is provided by 
DigitalGlobe.  The scene covers a portion of Tokyo with their Worldview-3 satellite (WV-
3). 
 Right-click on View > Remove all the other images in the View. 

 File > Open >   “Remote Sensing Digital Database \      
   Chapter_4_Other_MSS_Satellites” \ High_resolution_Satellites \ 
                      Worldview-3_pan-MSS_Tokyo”    folder  

      Select “Tokyo_WV-3_4-bnd_30cm_pan-sharpened_MSS_11-bit_GeoTIFF” 
      > Open 
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 We’ll create a natural color image with 30 cm spatial resolution.  DigitalGlobe 
 delivers data with bands 1, 2, 3, 4 as reflected blue, green, red, near IR light.  

 Select Band 3 – Band 2 – Band 1 as Red – Green – Blue 

 Zoom-in to the lower left corner so the two red & white construction cranes, the 
 street below, and the southwest corner of the baseball stadium is in your view.  

  Set scale to 1:300 

 Let’s use the Sharpen Slider in the 2nd from top row of icons to see what happens 
 with high pass and low pass filters. 

Question 4:  A. Describe the change in visual appearance of the red & white 
construction cranes when the Sharpen slider is set to 100 and to the far left of the slider 
(beyond the no change vertical line on the slider). 

  B. What level of sharpening provides an image that you find most 
informative (answer with the number to the right of the slider) 

To improve our understanding of edge enhancement, we will now use the Toolbox for 
high pass and low pass filtering of our Tokyo 4-band dataset. 

Chapter 9 Digital Image Processing has an extensive discussion on edge enhancement 
(see Figures 9-14 to 9-18).  We will be using a High Pass filter that  is similar to the 
Laplacian filter shown in Figure 9-14, but the center and corner pixel values are 
different. See ENVI Tool below that is opened via the Toolbox. 

 Filter > Convolutions and Morphology     
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 Press the buttons across the top to see the many possible variations. 
  Click on the Help button to obtain a better understanding of the tools.  

 The high-pass filter that we will use is shown above.  This filter “….Removes the 
 low frequency components of an image while retaining the high frequency (local 
 variations).”  ENVI Help. 

 As a recap of what is discussed in Chapter 9, let us assume that the 3 x 3 filter 
 cell is on a pixel with a DN value of 52. The algorithm does the calculation shown 
 below for the center cell to every pixel in the image…except along the margin of 
 the image!  The center pixel is changed from 52 to 64 in the example below. 

           [-65 + -55 + -65 + -60  +416 + -60  +-60 + -55 + -60]  = [416 + -480] = = +64 

 

 First we will do the high pass filter with 0% image add back. 

 Filter > Convolutions and Morphology  >  0% Add Back  >  Apply to File 

 A “Convolution Input File” window pops up – select the Tokyo 4-bnd dataset. 
  Apply this high pass filter to all four bands – so just say OK 
  The Convolution Parameters window pops up – name your file 
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 You should see something like the image below – a high pass filter applied with 
0% add back on the Tokyo satellite image – edges are emphasized….maybe good for 
input to AI and fracture/fault/linear feature detection…  but not a visually pleasing 
image.  You usually have to do some contrast stretch to make the image appear without 
being oversaturated (blown out). 

 

 Repeat the Convolutions and Morphology high pass filtering, but change the Add back 
to 95%.  Addback means the percentage of the original image added back to the edge-
enhanced image.  95% Add back is often used to create a sharper image for 
interpretation. 

 In the ENVI Layer manager compare the original color image with the image 
 that has been edge-enhanced with a high pass filter but with 95 % image add 
 back.  Is the 95% add back more informative compared to the original? 

 
Let’s do a Low-Pass Filter.  Low pass filters “…Preserves the low frequency 
components of an image, which smoothes it.”  ENVI Help.  Low pass filters are useful 
for noisy data and used extensively in geophysics. 

 Toolbox > Filter > Convolutions and Morphology > Convolutions > Low Pass 

  Kernal size = 3      0% Image Add Back  

  Repeat but with Kernal size = 13     0% Image Add Back 

Question 5:  What is the difference in image appearance when a low pass filter with a 3 
x 3 kernal is applied compared with a low pass filter with a 13 x 13 kernel? 
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Lab 3 Image Processing               Name: 

Upload the following files to the instructor: 
     (3) “Your name_bands_2-5_Scatterplot” 
 
  (4) “Your name_subset_band5_geotiff” 
 
  (5) “Your name_rotate 90_ENVI.img”  with ENVI .hdr file (two files) 

 
Question 1:  (Provide correlation values to the nearest two decimal places). 

  A.  What is the correlation between OLI bands 3 (green) and 2 (blue)? 

  B.  What is the correlation between OLI bands 4 (red) and 2 (blue)? 

  C. What two bands have the least correlation (most difference spectrally)?  

  D.  What two bands have the highest correlation (most similar spectrally)? 

Question 2:   A. Compare the visual gray tone of the sand dunes in the band 2 (blue)  
  and the three reflected infrared bands (5-7).  Does this match the values in 
  the correlation table?  Explain.  

 

Question 3:   How does the scatter plot of bands 2 and 3 and the plot of bands 2 and 5  
  compare to the correlation table values? 

 

Question 4:  Describe the change in visual appearance of the red & white construction  
  cranes when the Sharpen slider is set to 100 and to the far left of the slider 
  (beyond the no change vertical line on the slider). 

  B. What level of sharpening provides an image that you find most   
  informative (answer with the number to the right of the slider). 

 

Question 5:  What is the difference in image appearance when a low pass filter with a 3  
  x 3 kernel is applied compared with a low pass filter with a 13 x 13 kernel? 
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Lab 4    Image Processing 2 
Utilizes Textbook’s Remote Sensing Digital Database: Chapters 3, 5, and 8 data. 

The objectives of this lab are to use image enhancement tools (see Chapter 9 Digital 
Image Processing for discussion of enhancements) to process thermal IR, UAS (drone), 
and multispectral data and to introduce band math.  The tasks we will complete with this 
lab are done with tools in the ENVI Toolbox: 

 Band Math 
 Density slice  
 Mosaicking 
 Masking 

Four digital files are to be uploaded to the instructor and four questions are to be 
answered on the last page of this handout. 

IMPORTANT NOTE: The “new” ENVI with the GIS-look does not retain display 
enhancements for images when you use Save As. These include rotating, zooming, 
contrast, brightness, sharpening, stretching, Portals, or viewing multiple layers. Use the 
Export View To > Image File to retain displayed enhancements.  Unfortunately, it 
appears that when exporting an enhanced 1-band grayscale image, ENVI generates a 
grayscale file that contains 3 identical grayscale bands.  This is bad.  Can you find a fix? 

1) Band Math  
In this exercise we will convert raw DNs displayed on an ASTER thermal IR surface 
temperature image of the Ghanzi area, Afghanistan to degrees Celsius (°C).  See 
textbook Chapter 5 and Figure 5-6 for more background information. 

 Open the ENVI software.   File > Open  

 Locate the nighttime, Level 2 ASTER TIR surface temperature image  
 (AST- 08 product) from the Remote Sensing Digital Database following this path:   
 
 \ Ch_5_Thermal_IR \ Fig_5-6 Afghanistan_ASTER_Surface_Temp \ 
 Nightime 

 Choose the TIF image in the “Nightime” subfolder:
 “Ghazni_AST_08_TIR_Surface_Kinetic_Temp_Nighttime_31aug2013_integer” 

 Zoom to Extent          Click-on the Cursor Value icon 
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Use the Select Arrow to move the crosshairs around the ASTER TIR image. 
  Move from bright pixels to dark pixels. 
  View Metadata 
  Quick Stats        
   Select Plot (drop-down menu in upper left) > Histogram Band 1 

NOTE:  The Terra platform that hosts the ASTER system is moving from south to north 
during the nighttime orbit.  The rotation of the earth is demonstrated by the wedge-
shaped black margins of NO DATA on the East and West margins.   The system 
records a null DN of 2000 in this NO DATA area.  Ignore the wedge-shaped margins. 

Question 1:  A. What is the range in DN values (min – max)? 

  B. What is the DN range for the bin with the highest Count (located at the  
  peak of the histogram)? 

1a) Brilliant people at the Jet Propulsion Lab (JPL) and NASA deliver calibrated ASTER 
thermal IR products for a variety of applications at no cost.  The original DNs of the 
pixels in a Level 2, AST-08 product (calibrated surface temperature) can be converted 
to degrees Celsius (°C) using the following formula (Gillespie and Rokugawa, 2001): 

  XXXX = DN of pixel on calibrated AST-08 Level 2 image 
  2730 = constant 
  YYY = Value when 2730 subtracted from DN on image (XXXX) 

  XXXX – 2730 = YYY * 0.1 = ZZ.Z°C 

You can do this calculation on paper or with a calculator for each pixel you measured 
with the Cursor Value tool earlier.  That is very inefficient.  Fortunately, many image 
processing and GIS software packages include tools for you to write your own 
mathematical operations that can be applied to the entire image.   

ENVI supplies the Band Math tool.  Band Math is a powerful tool for remote sensing.   
Let’s use it! 
 Toolbox > Band Algebra > Band Math 
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Push Help to see examples and better understand how band math works!! 

   Our formula XXXX – 2730 = YYY * 0.1 becomes (float(b1) - 2730) * 0.1 

  “float” is used before each pixel’s original DN value to ensure our degree  
  Celsius result supports a decimal point. 

 Enter the Band Math formula into the “Enter an expression” box  
    > Add to List  

  Save the Band Math formula as “ASTER TIR DN to Celsius” so you can  
  use it again in the future. 
   > OK       The “Variables to Bands Pairings” window pops up. 
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  Click-on the “Band 1” in the “Available Bands List”  
   The thermal IR band will automatically fill in the “Variables used in  
   expression:”    Name the output file “ASTER TIR Celsius_ENVI”. 
   This new image will be in ENVI format (.img with .hdr). 

 The ASTER TIR °C image automatically loads into the View.  The new image will 
 be very dark if “No stretch” is set.  Contrast stretch with” Linear 1%” 

 Roam around the image with your “Cursor Value” tool.   Very dark blobs of pixels 
 along the East margin have negative °C values.  These may be clouds or errors.  
 Best to ignore. 

 If you are more comfortable with Fahrenheit degrees (°F), use this formula for 
 converting °C to °F 
  (32°C × 9/5) + 32 = 89.6°F 
 
Question 2:   A. What is the highest temperature in °C recorded by the ASTER TIR  
  system?  (Hint: Refer to the Quick Stats Histogram table) 

  B. Do you think you should use this highest temperature if only one pixel  
  recorded it?   YES  or   NO 
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 1b) Our “ASTER TIR Celsius_ENVI” grayscale image is not useful for GIS.  Let’s 
 quickly convert it to a geoTIFF format. 

 Right-click on “ASTER TIR Celsius_ENVI” in the Layer Manager  
  > Export Layer to TIFF 

  Name your geotiff output file “Your Name_ASTER Temp GIS.tif” 

  Upload to the instructor. 
  If you have access to a GIS, open your geoTIFF image in the GIS. 

 
2) Density Slice.   Use the “Raster Color Slices” tool in the ENVI Toolbox. 
Temperature patterns on our ASTER TIR °C grayscale image can be understood more 
easily if we perform a density slice on the image. 

 Highlight the  “ASTER TIR Celsius_ENVI” image in the Layer Manager. 

 ENVI Toolbox > Classification > Raster Color Slices 
  A “Data Selection” window pops up – ensure the “Band Math (…)” entry 
  under our “ASTER TIR Celsius_ENVI” image is highlighted. >  OK 

 Automatically ENVI generates a “Raster Color Slice” image with 16 slices! 

  NOTE Problem!  ENVI created 12 density slices where there is no data 
  because our ASTER TIR DN histogram is not “normal” – it is skewed to  
  the right.    Image processing algorithms often assume a “normal”   
  distribution of data.  But often the data DNs are skewed!!  Always look at  
  your results to see if they are reasonable.  See below 
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 We MUST correct this very bad and misleading density slice image!! 
  Click-on the 2nd to the upper left icon “New Default Color Slices…” 

  The “Default Raster Color Slices” window pops up. (see below) 

 

  Change the Num Slices to “’6” and the Data Min to “5” > OK 

 You now see the color density slices more accurately reflect the distribution of 
 surface temperatures on the ASTER TIR image.   

 In the “Edit Raster Color Slices: Raster Color Slice” window now on your screen, 
 save the color density slices as a shapefile.  Drop-down menu on diskette (6th 
 icon from left) > Export as Shapefile… 

  Name your shapefile “YourName_ASTER_Temp_Density_Slice” 
  If you have access to a GIS, load this shapefile and color-code. 

  Upload your shapefile to the instructor. 

NOTE:  Converting a raster color density slice image to a vector polygon shapefile 
enables you to improve the symbology and legend, and fuse with other layers in your 
GIS.  The nighttime surface temperature shapefile is awesome when faded and draped 
on the 30-meter SRTM DEM (available in the Remote Sensing Digital Database, 
Chapter 5 Thermal IR folder) 

3) Mosaicking. 
This exercise is quick and simple with ENVI.  We will load two overlapping color images 
acquired by a USGS drone and digitally mosaic them into one image.  

 Remove all files from the Data Manager and Layer Manager. 

 The two georeferenced images are in the Remote Sensing Digital Database. 
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  File > Open   Open the folder “Ch_8_sUAS_Manned-Aircraft” and its subfolder 
 “UAS_USGS_West Fork Mine”.  The two images to load are 

   “dji__0260_georef_GIS.tif” and “dji__0770_georef_GIS.tif” 

 Zoom to Extents 
  With the Cursor Value, roam over the black edges around the images. 

Question 3:  What is the DN at the black edges of the two images? 

 ENVI Toolbox > Mosaicking > Seamless Mosaic  > green + sign (Add Scenes) 

 In the “Data Selection” menu, select both images (ctrl key) or Select All > OK 

 Click-on the “Color Correction” tab > do not check Histogram matching 
  (the mosaicked image is overly bright if you check this function) 

 Click-on the “Seamlines/Feathering” tab > check None 

 Click-on the “Export” tab > “Output Format” dropdown menu TIFF 
  “Output Filename” > “Drone mosaic” 
  “Data Ignore Value” . “0”   (zero – so the black margins that overlap are  
                                              transparent) 
 Click “Show Preview”     (see tool and tabs below)  

 

 Check the preview.  If OK, Click Finish 

  The processing could take a minute or two.  The mosaic is over 160 MB. 
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 Zoom in along the seam between the two images.  (Scale 1:250). 

 Let’s save a thumbnail jpg and upload it to the instructor. 

 File > Chip View To > File   Choose “Output Format” as JPEG. 

  Name the file “YourName_drone_mosaic_thumbnail” 

  No need to display.  Look at it when it is saved to your folder for this lab. 
   My thumbnail was tiny – 60 KB and it looked OK! 

 Upload thumbnail jpg to the instructor. 

4) Masking. 
Exit the GIS-look ENVI that we have been using, and open ENVI Classic.  
I find that older ENVI Classic is much more efficient at generating a Mask  
from a multispectral data set compared with the new ENVI front end.   
I have included the Masking exercise with the new ENVI front end as an   
alternative supplement at the end of the Lab Manual.   

We are going to use a Landsat TM SWIR1 band (TM band 5) to mask water around 
islands in the Bahamas so we only process the features on the islands without 
interference or noise from the water. 

 The textbook Chapter 3 discusses how Landsat was used for generating a 
 bathymetry map of the seafloor in this area. Plate 9 and Figure 3-16 show the
 enhanced satellite image with masks that you will be using in this exercise.  

The Landsat data is in the Remote Sensing Digital Database \ Ch_3_Landsat folder. 

In ENVI Classic   File > Open Image File 

 Follow this path:   \ Plate_9_Bathymetry \ Original_Landsat_Data 

 to the “Exumas_Bathy_1984_Landsat_6-band_clip_GeoTIFF” data  > Open 

An “Available Band List” window pops up with the six bands.  (see below). 
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 Click the “RGB Color” button  >  Click on Band 3 first, Band 2 second, and Band 
 1 last to create a natural color image (reflected red-green-blue light as R-G-B). 
  
 Click-on “Load RGB”.   A 3-window display pops up.  The color image is 
 automatically loaded  in “Display #1” with its 3 windows.The full scene is in the 
 lower left “Scoll”, a 1:1 zoom factor image is in the large (“Image”) window 
 (outlined in red on the “Scroll” window), and an enlargement is in the “Zoom” 
 window (outlined in red on the “Image” window.    The “Available Band List” is to 
 the right.   See below. 
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NOTE:  Remember that Landsat TM 30 m bands are numbered 1-5 and then 7 
(SWIR2).  See textbook Table 3-1.  TM band 6 is a 60 m thermal IR band.  We did not 
include the thermal IR band in our layer stack, so TM band 7 is listed as “band 6” by 
ENVI (and other image processing software).   
 
4a) You are looking at a natural color image of the clear water, underwater sand bars in 
shades of blue, and white carbonate sands around the islands.   
  
 Access one “Contrast Stretch” tool in the “Image Window” by clicking-on  
  Enhance >     In the Drop-down menu  Select   “ [Scoll] Linear 0-255” 
   this will reset the displayed image to the original DNs. 
    
 In the “Image” window      Tools > Cursor Location/Value…      

  A “+” shows up in the “Image” window and a small  
  “Cursor Location/Value” window pops up.   If you are looking at the   
  original data (not contrast-stretched) the “Scrn:” and “Data:” R-G-B DN  
  values are identical.     

   Move the Cursor Value tool around the image to understand the  
   range of DNs in the water and on land.   

  To brighten the color image  Enhance > “[Scroll]” Linear 2%  
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   Move the Cursor Value tool around the image.  Note how the  
   enhanced pixels on the screen (“Scrn:”) have DNs that are different 
   compared with the original “Data:” 

 Now we will compare the individual grayscale bands to the natural color image by 
 opening up a second Display (“Display #2). 

  In the “Available Bands List” menu,   click-on “Band 1” >  
   click-on “Gray Scale”  >   click-on “Display #2”  > New Display   >   
   click-on “Load Band” 
  Band 1 pops up in Display #2 to the right of Display #1. 

 4b) Let’s link the two views so we can compare the color image to the bands.  
  In Display #2    Tools > Link > Link Displays    

   The “Link Displays” window pops up.    > OK 

 

   Choosing to start the link in Display #2 makes Display #2 the  
   master when moving around the scene  

 Now you can move the Image rectangle outline in the “Scroll” window of Display 
 #2 around to  see different parts of the scene in color and as grayscale bands. 

  Sequentially display Bands 1 through 6 in Display #2.  Contrast-stretch  
  as needed with the Enhance tool.   Press the Image or Scroll   
  window with the cursor and the linked Display image is shown. 

  In the Cursor Location/Value tool, look at the original DN value for the  
  grayscale bands as you roam around from shallow to deeper water.  
  The original DN values are on the “Disp  #2 Data:” line. 
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Question 4:  A.  What happens to the visibility of the underwater sand bars and ripples  
  on the sea floor as you display the blue, then green, and then red bands? 
  (Hint: read the textbook Chapter 3 and look at Plate 9)  
  B.  Why?   

  C. What happens to the brightness of water as you display the reflected  
  infrared bands (Bands 4, 5, 6)?  (Contrast-stretch each band to make the  
  change more clear).  
  D. Why? 

4c) Landsat TM band 5 (SWIR1) does a good job of differentiating water from land.  
Using the “Available Band List”   Load Band > Band 5 as a “Gray Scale” into Display 
#2..  Now we will make a binary (black and white) image of Band 5 in Display #2. 

Tools > Color Mapping > ENVI Color Tables    (see below) 

 

The B-W Linear grayscale from black to White should be displayed.  (See above). 
Move the stretch buttons toward the center of the sliders.   You are doing a linear 
stretch, with the top slider moving pixels toward the left side to pure black (DN =  0) and 
the bottom slider moving pixels toward the right side to pure white (DN =  255).  Align 
the slider buttons so the black-white pattern has a sharp boundary  (see below).  This 
could be termed a “Linear 50%” contrast stretch.   
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 Look at the Band 5 image in Display #2.  The pixels are only black or white.   
 (See “Cursor Location / Value”   “Disp #2…Scrn:” DN values). 
  
 Our goal is to display islands as white and water as black.  The Linear 50% 
 stretch is excessive - a significant portion of the land on the islands is black 
 which should represent water. 

 Redo the sliders on the “#2 ENVI Color Tables” window.  Move the vertical Black-
 white boundary left so that the land on the islands is displayed as white.  

 Press the Image or Scroll window with the cursor and the linked Display image 
 is shown.  This will help you determine when you have an appropriate land – 
 water boundary.  I decided on the following black – white boundary. 

 

 Note that there are lakes on the islands and the white sands may be saturated – 
 so the SWIR TM band 5 records these as dark pixels.  These pixels are in the 
 black water class.   

To save our TM Band 5 Black-White image we use Display #2 Image drop-down menus 
File > Save Image As > Image File   The Output Display to Image File window pops up. 
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 Choose the defaults.  The “Resolution “ is “8-bit (gray scale)” Save the image as 
 “TM_Band5_BW_8-bit_ENVI” 

 The saved image automatically shows up in the “Available Band List” and is 
 highlighted so it easily displays next. 

  “Available Band List” > push “Display #1” button > New Display >  
  push “Load Band”     Our TM Band 5 8-bit image is loaded into Display #3. 

4d)  Build the Mask.  Now we will convert our 8-bit grayscale image (with 255 levels of 
gray even though only 0 and 255 are used) to a Mask with DNs of 0 and 1. 

 We use the drop-down menus on the ENVI Classic Toolbar (see below). 

 

 Basic Tools > Masking > Build Mask    Select Display #3  

 The “#3 Mask Definition” window pops up.   Our TM Band 5 8-bit image is 
 highlighted by ENVI.    Options > Import Data Range  (shown below on left) 

                  

 The “Import for Data Range Mask” menu pops up.  Enter 0 and 1. 
 This sets the mask for “water”    > OK 
  
 In the Options drop-down menu ensure “Selected Areas “Off” 
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 Name the Mask “Water_Mask_0-1_Off” so that you remember you used 0-1 and 
 “off” in the Mask Definition.   > Apply 

NOTE:  The combination of 0-1 and “off” in the Mask Definition ensures that the mask 
will be opaque over water pixels and transparent over land pixels so water will not 
interfere with processing analysis of the land cover on the islands.   This is always 
confusing and trial & error with these parameters seems to be the typical way to get the 
Mask you want… 

 The mask automatically loads into the “Available Band List” and is highlighted. 
  Push “Display #...” drop-down menu and choose “New Display” 
  Push “Load Band? 

 Move your Cursor Location/Value tool over the water and land.  They should 
 have DNs of 0 and 1, respectively. 

4e)  Apply the Mask 

 ENVI Toolbar > Basic Tools > Masking > Apply Mask   
  The “Apply Mask Input File” window pops up.  This is the data we want to  
  mask – the 6-band Landsat dataset. 

 “Select Input File:”   Select the 6-band Landsat dataset  > OK 
 Buttons pop in on the “Apply Mask Input File” window  (see below) 

     

 Click-on the “Select Mask Band” button.  Our water mask shows up at the top of 
the “Select Mask Input Band” window  (see above)   > OK   > OK 
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 An “Apply Mask Parameters” window pops up.  (see below) 

 

 Name the file “Landsat_6-band_Water_Masked_ENVI”  > OK 

 The masked Landsat displays in the “Available Bands List” 

 Display a color IR image (TM bands 4-3-2 as R-G-B) 
  Click the “RGB Color” >  Push the “Load RGB” button   
  Your masked color image will display in your last Display. 
 
 Move the Zoom window over a large island > Enhance > [Zoom] Equalization 
  You are contrast-stretching using only the pixels in the Zoom window. 
  This stretch reveals significant differences in the vigor of vegetation  
   on different islands and within larger islands. 

4f) Our masked ENVI color IR Landsat is more useful in GIS so others can view it – and 
we could import our color IR image into Google Earth if it was a geoTIFF. 
 
 We want to save the 3- band color composite so we use the ENVI Image menus 
  File > Save Image  As > Image File… 
   Choose “Resolution” drop-down menu   “24-bit Color (BSQ) 
   Choose “Output File Type” drop-down menu   “TIFF/GeoTIFF 

  Name the GIS-ready dataset:  
   “YourName_Landsat_ColorIR_Masked_Water_GIS”  > OK 
 

 Upload the 24-bit GIS-ready color IR image to the instructor. 

 If you have access to a GIS, load the 6-band multispectral dataset. 
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Lab 4   Image Processing 2              Name: 

Upload the following files to the instructor: 
 
 (1) “Your Name_ASTER Temp GIS.tif”  geotiff 

 (2) “YourName_ASTER_Temp_Density_Slice” shapefile 

 (3) “YourName_drone_mosaic_thumbnail” jpg 

 (4D) “YourName_Landsat_ColorIR_Masked_Water_GIS”  geotiff 

Question 1:  A. What is the range in DN values (min – max)? 

  B. What is the DN range for the bin with the highest Count (located at the  
  peak of the histogram)? 

Question 2:   A. What is the highest temperature in °C recorded by the ASTER TIR  
  system?  (Hint: Refer to the Quick Stats Histogram table) 

  B. Do you think you should use this highest temperature if only one pixel  
  recorded it?   YES  or   NO 

Question 3:  What is the DN at the black edges of the two images? 

 

Question 4:  A.  What happens to the visibility of the underwater sand bars and ripples  
  on the sea floor as you display the blue, then green, and then red bands? 
  (Hint: read the textbook Chapter 3 and look at Plate 9). 

 

  B.  Why?   

 

  C. What happens to the brightness of water as you display the reflected  
  infrared bands (Bands 4, 5, 6)?  (Contrast-stretch each band to make the  
  change more clear).  

 

  D. Why? 
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Lab 5  Band Ratios and Principal Components 
Utilizes Textbook’s Remote Sensing Digital Database: Chapter 3 data. 

The objective of this lab is to use Information Extraction tools (see Chapter 9 Digital 
Image Processing for discussion) to process multispectral Landsat data in Reflectance.  
The tasks we will complete with this lab are done with tools in the ENVI Toolbox. 

Three digital files are to be uploaded to the instructor and eight questions are to be 
answered on the last pages of this handout. 

IMPORTANT NOTE: ENVI does not retain display enhancements for images when you 
use Save As. These include rotating, zooming, contrast, brightness, sharpening, 
stretching, Portals, or viewing multiple layers. Use the Export View To > Image File to 
retain display enhancements and original scale (choose Zoom Factor 1.0000). 

We will use Landsat 8 bands of Thermopolis that have been converted from radiance to 
reflectance to ensure our band ratios are accurate.  Reflectance data are also required 
for spectral libraries that we will work with in a later lab.  The data set is located in the 
“Remote Sensing Digital Database \ Ch_3_Landsat” folder.   

1) Start up ENVI 

Open the subfolder “Plates_7and27_Thermopolis”.  Open the subfolder 
“Landsat8_Reflectance_6bnds_VNIR-SWIR”.   

Select “OLI_Thermopolis_Sep2015_reflectance_bnds2-7_ENVI”  > Open 

 >  Zoom to Extents 

 If you have your ENVI Display preferences set at “No Stretch”, the 12-bit bands 
 will appear white with some of the Wind River in yellow and green?! 

 Click-on the Histogram Stretch tool     

 With “No Stretch”, the histogram low and high vertical DN bars are set to “0” 
 and “255” (8-bit)  while the data are 12-bit.  
  Click-on the contrast stretch drop-down menu and select “Linear 1%” 
  Analyze the stretched histograms in the Histogram Stretch tool. 

Open the Data Manager.  Move the slider all the way to the right so you can see the 
wavelengths of the six Landsat 8 bands.  The USGS attaches the center wavelength of 
each band to the file name (excellent!) when they convert Landsat from radiance to 
reflectance.  The USGS also ensures the bands are correctly labelled: OLI 2 – 7. 

2) Band Ratios:  Band ratios (or ratio images) are prepared by (digitally) dividing the DN 
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in one band by the corresponding DN in another band for each pixel in an image.  In a 
ratio image, the darkest pixels represent the smallest ratio values and the lightest pixels 
represent the largest ratio values. The darkest signatures are areas where the band in 
the denominator (7 in the 5/7 ratio image) has a greater reflectivity (higher DN value) 
than the band in the numerator. The brightest signatures show pixels where the 
numerator is larger than the denominator.  Bands should be corrected to reflectance 
prior to band ratioing.  
 
    Look at Figures 9-25 A and C along with textbook discussion in Chapter 9. 

OLI Band Ratio 4/2 (red/blue): 
Spectra of weathered iron-bearing (ferrous) minerals have strong reflectance in 
the visible red region of the electromagnetic spectrum (TM band 3 or OLI band 4) 
wavelengths at ~0.63 to 0.69 um).  Because red-colored material, or Iron-bearing 
minerals, have a weak reflectance in the visible blue portion of the spectrum (TM 
band 1 or OLI band 2) at ~0.45 to 0.52 um) a ratio image of TM bands 3/1 or OLI 
bands 4/2 could indicate iron- stained areas.  Areas with iron-staining will be 
bright. 
 
OLI Band Ratio 6/7 (SWIR1/SWIR2) 
Landsat TM band 7 (OLI band 7) is preferentially absorbed by the hydroxyl-
bearing clay minerals as compared with TM band 5 (OLI band 6); therefore, a 
ratio image of TM bands 5/7 (OLI bands 6/7) could show anomalously high 
concentrations of these clay minerals as bright areas.   
 
ENVI Toolbox > Band Algebra > Band Ratios 
 Select Band 4 first.  ENVI automatically places Band 4 in the Numerator. 
 Select Band 2 next. ENVI places Band 2 in the Denominator. 
 Click “Enter Pair” > OK 
 The “Band Ratios Parameters” window pops up.   
  Enter an Output Filename:  “Landsat iron ratio_ENVI” 
  Accept “Floating Point” as the output data type (each pixel DN will 
  have a decimal place). 
 
 The iron ratio grayscale image needs to stretched. 
 
ENVI Toolbox > Band Algebra > Band Ratios 
 Select Band 6 first.  ENVI automatically places Band 6 in the Numerator. 
 Select Band 7 next. ENVI places Band 7 in the Denominator. 
 Click “Enter Pair” > OK 
 The “Band Ratios Parameters” window pops up.   
  Enter an Output Filename:  “Landsat clay ratio_ENVI” 
  Accept “Floating Point” as the output data type (each pixel DN will 
  have a decimal place). 
 
 The clay ratio grayscale image needs to stretched. 
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3) Let’s open up four Views.  Views > 2 X 2 Views 
 Slide the iron ratio image into View 2. 
 Slide the clay ratio image into View 3.   
 Turn off the iron and clay ratio images in View 1. 
 
 Zoom to Extent and Optimized Linear stretch for the View 1 (natural color), View 
 2 and View 3. 
 
 Views > Link Views  >   GeoLink active >   Link All    > OK 
  Pan around     Zoom in & out 
 In the Cursor Value window,  
   select “Link Views” and “Display Information for All Views” 
 
Question 1:  Activate View 2 with the iron ratio image.  Put your cursor on the brightest 
pixel you see in the Chainman Shale (Red Rose Anticline (see textbook Figure 3-11H if 
you don’t remember where that is).   (Show only two decimal places for the DN below). 
 A.  What is the Data value (DN) for the bright pixel on the iron ratio image: 
 
 B.  What is the Data value (DN) for the same pixel on the clay ratio image: 
 
Question 2: Put your cursor on the brightest pixel you see in the clay ratio image in a 
Wind River agricultural field (see textbook Figure 3-11H if you don’t remember where 
the river is).  (Show only two decimal places for the DN below). 
 A.  What is the Data value (DN) for the bright pixel on the clay ratio image: 
 
 B.  What is the Data value (DN) for the same pixel on the iron ratio image: 
 
4) You are planning field work and only want to visit sites in the field with the highest 
potential iron content and potential clay content.  To make a useful map we can 
interactively determine which pixels we want to be pure white and which we want to be 
pure black.  The pure white pixels have the highest potential iron and clay content in the 
Thermopolis field area.   In the Layer Manager, highlight View 2 with the iron ratio 
image. 
 
 ENVI Toolbox > Classification > Raster Color Slices 
  The “Data Selection” window pops-up 
  Select your “Landsat_iron_ratio_ENVI” image first > OK 
 
  The  “Edit Raster Color Slices: Raster Color Slice” window pops-up 
       (The default density slice has 16 levels and a rainbow color scheme) 
 
   Change the color scheme and the number of slices. 
  
   In the upper left corner of the window is the  
    “Change Color Table…” icon and next to it the 
    “New Default Color Slices…” icon. 
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   In the Change Color Table window Select “B-W Linear” 
   In the “New Default Color Slices” window Change 16 to 2 

      
 
In the “Edit Raster Color Slices: Raster Color Slice” window, move the vertical line 
separating the black and white patterns on the histogram while looking at the grayscale 
ratio image.  Choose a black-white dividing DN that shows only the most promising 
sites on the band ratio image for you to find iron-stained rocks at the surface – that may 
indicate hydrothermal alteration and mineralization!  To reduce your field area (saving 
time and money), density-slice your iratio image so only a few areas have white pixels.  
 
You can also change the “Slice Min” value in the table to the left of the histogram to 
move the black/white line left and right. 

 
 

 Let’s save your Black-White prospecting image for your GIS. 
 
 Ensure that the “Raster Color Slice” is checked and highlighted in your Layer 
 Manager (the black and white slices for the iron ratio image are in a subfolder) 
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File > Export Selected File to TIFF  > name the image  
       “Your Name_Iron_Sites_GIS” 
Check the “Display result” so you can see if the output identical to your black-
white iron image in View 2.     Upload to the instructor. 

 
5)  You are now an agricultural soil scientist and want to find sites in the Thermopolis 
area that have the highest potential for clay to support your proposed grape vineyard.  
In the Layer Manager, highlight View 3 with the clay ratio image.  Repeat the process 
you did for the black-white iron image under Step 3).    
 
Name your GIS output image “YourName_Clay_Sites_GIS”.   Upload to the instructor. 
 
6) Normalized Difference Vegetation  Index (NDVI)   
 (see textbook Figures 9-27, 9-37) 
 
 The difference in reflectance values between NIR and red wavelengths is used to 
 map vegetation greenness (also termed vigor and stress).  Healthy plants reflect 
 NIR light but absorb red light (cholorphyll).  Scientists like to have a number 
 describe a situation – an “index”. 
  
 NDVI is an index that is normalized so the value varies between -1 and +1> 
 NDVI = (NIR – red) / (NIR + red) 
 NDVI  = (OLI 5 – OLI 4) / (OLI 5 + OLI 4)  
     = (145 – 35) / (145 + 35) = 110 / 180 = +0.61 (healthy vegetation!) 
 
 Highlight View 4 (so the NDVI image is displayed in this empty view) 
  
 6a) ENVI Toolbox > Spectral > Vegetation > NDVI 
  Select the six-band Landsat dataset as the Input File 
 
The “NDVI Calculation Parameters” window pops-up. 
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  The selection of NDVI Bands is correct – the 3rd band in the dataset is red 
               and the 4th band is Near IR. 
  Name “Landsat_NDVI_ENVI” 
  Leave as “Floating Point” so range of DNs in the NDVI pixels  
  should range between -1.0 and 1.0  (pixels with noise or error could 
   be outside this range)   > OK 
 6b) Zoom to Extents  > Contrast stretch with “Linear 1%” 
 
 Link View 4 with the NDVI image to the other 3 Views 
 Views > Link Views   click-on New Link or Link All 
 
 Turn off the density slices in Views 2 and 3.   Enhance all the grayscale ratio 
 images with “Linear 1%”    Pan around and zoom in & out of the linked Views
  
Question 3:   A. Why do you think the clay ratio image in View 3 is so similar to the 
  NDVI  image (vegetation greenness or vigor) image in View 4? 
 
  B.  Roam around the linked Views.  What type of feature has pixels on the 
  clay ratio image that are bright but dark on the NDVI image?     
      (hint: look also at the color image in view 1 – change the bands to  
    OLI 7-5-2 as R-G-B.  Look at the iron band ratio image also). 

 
 6c) Use the Cursor Value tool and click around the NDVI grayscale image. 
 
Question 4:  A. What range of NDVI values do you find on your NDVI image? 
  
  B.  Did you find any negative values? 
 
 6d) Right-click on the NDVI image in the Layer Manager > Quick Stats 
  Select Plot drop-down menu > “Histogram Band 1” 
 
Question 5:  A. What range of DN values (Min and Max) do you find in the metadata for 
  the NDVI image? 

 
  B. Is the range of DNs in the image’s metadata different than what you 
  found clicking around the image with the Cursor Value tool?  YES   NO   
 
  C.  Approximately how many pixels have values greater than +1.0?   
 
  D.  Approximately how many pixels have values less than -1.0?  
 
  E.  How many pixels are in this image?  (Remember Metadata?) 
 
  F. What is your opinion about those pixels in the metadata with DNs 
  outside of the NDVI  -1 to 1 range?   
 



7 
 

7 Introduction to Remote Sensing  Principles, Interpretation, and Applications 
F. F. Sabins and J.M. Ellis, 2020, Waveland Press.    Contact:  jellis@ellis-geospatial.com 

 

It is very important to use your brain and eyes - look at the image, metadata, and 
statistics - to help you understand the quality and technical issues with your imagery to 
ensure that what you are doing makes sense – and that the maps you generate are 
useful.  We’ll see the impact of blindly using all the DNs that are in the NDVI image in 
the final NDVI exercise below. 
 
 6e) Let’s color-code the NDVI to highlight those pixels with vigorous vegetation 
  ENVI Tool Box > Classification > Raster Color Slices  
  Select the grayscale NDVI image   > OK  
 
 The ENVI density slice program uses the DN range documented in the metadata. 
 
 The “Edit Raster Color Slices: Raster Color Slice” tool pops-up.  Evaluate it! 
 
Question 6:   A.  What density slice colors appear on your NDVI image in View 4? 
 
  B.  Is this NDVI image what you want for a final, color-coded product? 
 
We must modify the min and max DN values that we allow to be used by the density 
slice tool to reflect what we visually see in the image.  The remote sensing analyst has 
to make a decision about what is most valid and what  is noise and needs to be ignored.   
This decision should be documented in your color-coded NDVI GIS image’s metadata. 
 
 Along the top right portion of the “Edit Raster Color Slices…” window are DN 
 values for “Histogram Min” and “Max” automatically placed by ENVI based on the 
 unedited NDVI input image. 
 
 Change the Min to -1.0 and the Max to 1.0 
 
 Click-on the “New Default Color Slices…” icon in the upper left.  
  Change “Num Slices” from 16 to 5.   
  Note “Data Min” is -1.0 and “Data Max” is 1.0 in the lower left. > OK > OK 
 
 How many colors do you see on your NDVI image in View 4? 

There is much research documentation that in terrain such as Thermopolis (semi arid) 
we have a low probability of finding pixels with NDVI values below -0.2.  GIS Resources 
indicates the following NDVI values can be expected: 

1. Barren rocks, sand, or snow show very low NDVI values (-0.1 to 0.1) 
2. Shurbs and grasslands or senescing crops  (– 0.2 to 0.5) 
3. Dense vegetation or tropical rainforest  ( – 0.6 to 0.9) 
4. Deep water  ( -1) 

ENVI’s Help indicates vegetation typically ranges between NDVI values of 0.2 and 0.8. 
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Given the above, let’s change our density slice min value to -0.1 since most of us didn’t 
find any DNs more negative than -0.1 while analyzing our NDVI image with the Cursor 
Value tool earlier. 

 6f)  In the Layer Manager, Right-click on the “Slices” folder that contains the 5 
 colors and their ranges under the “Raster Color Slice” file  > Edit Color Slices… 

 The same menu pops up that we saw in Exercise (6e) above.  Update the Min 
 value to -0.1 and the Max value to 1.0.  We have to reset the number of slices 
 also. 

  Click-on the “New Default Color Slices…” icon in the upper left.  
  Change “Num Slices” from 16 to 5.   
 
  Your color-coded histogram should look like what is shown below:  

  > OK 
 

 
 
 Your 5-level density slice of the NDVI image should look like this.  Agricultural 
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 fields that are heavily irrigated are displayed in red.  Less vigorous (or more 
 open) fields are displayed in yellow and green.  A very useful and new product! 
 
 File > Chip View To… >  Image  >  Select “JPEG” in the dropdown window. 
 
 Name the color-coded NDVI image “YourName_color-coded_NDVI_jpg” 
 
 Upload to the instructor. 
 
7) Principal Components 
 
 Highlight Views 2, 3, 4 and for each view File > Close All Files  
 In View 1 > Change RGB Bands  to OLI 5-3-2 (NIR-Red-Green) as R-G-B 
 Leave 4 Views – only View 1 has an image. 
 
Principal Components (PCs) are covered in the textbook Chapter 9,  
See Figures 9-22, 9-23 A-F, 9-24 and Plate 27.  The reflectance image used in this 
exercise does not cover the exact same area as the textbook Landsat example which is 
also in radiance.  So the PCs developed in this exercise will not look exactly like the 
ones in the textbook.  PCs are specific to the dataset being processed. 
 
Why PCs?  When you compare the individual multispectral bands in a dataset there is 
strong visual similarity.  Think back to Lab 3 and the correlation matrix for the 
Thermopolis Landsat bands.  The high correlation means there is much redundancy of 
information in the multispectral data set.  PCs reduce this redundancy by compressing 
all of the information contained in the original grayscale bands set into a new set of 
grayscale images named PC1, PC2, PC3, etc.  Each successive PC image accounts 
for a progressively smaller proportion of the variation in the original data set. 
 
 Highlight View 2  (this will put the PCs into this empty View) 
 
    ENVI Toolbox > Transform > PCA Rotation > Forward PCA Rotation New Statistics      
 and Rotate 
  (PCA) means principal component analysis 
  Use ENVI Help to learn more about this analysis and step-by-step details 
 
    Select the 6-band Landsat data set > OK   Accept Defaults for subsets & Mask  > OK 
 
 The “Forward PC Parameters” window pops-up. 
 
  Name the output Stats file  “Landsat_6PC_stats” 
  Name the output file   “Landsat_6PC” 
  Accept defaults EXCEPT change “floating point” to “byte”   > OK 
 
 The “PC Eigenvalues” window pops-up (see below) and the 6 PCs load into  
 View  2. 
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To see the Eigenvalue values (shown on the right above), you choose  Export > ASCII 
in the PC Eigenvalues menu.  The ASCII file is a simple .txt file that lists the PC 
Eigenvalues.   
  
NOTE:  PC Eigenvalues indicate the proportion of original information (total variance) in 
the multispectral dataset (all the bands) that each PC contains.  To determine the 
percentage of the total variance within each PC, you sum the Eigenvalues and divide 
each PC Eigenvalue by the summed total.   
 
 Views > Link Views   View 1 has 6 Landsat bands, View 2 has 6 PC images. 
   Look at the Data Manager list of bands and PCs 
 
 7a) Next we will examine the grayscale bands and PCs with “Band Animation” 
  Highlight View 1 >   Right-click file in Layer Manager > Band Animation 
   Slow the flicker rate to 1 or 2 seconds 
   Note the high visual correlation between bands 
   You may have to use “Linear 1%” stretch on the bands 
 
  Highlight View 2 >   Right-click file in Layer Manager > Band Animation 
   Note the low visual correlation between PC images 
   You may have to use “Linear 1%” stretch on the bands 
 
  Both Views should be in Band Animation mode,  Zoom in to the Red Rose 
  Anticline – band animation should still be working in both Views. 
 
 7b) Let’s load a grayscale band into View 3 and a grayscale PC into View 4 
  Highlight View 3 > “Data Manager” > Select OLI Band 1 > Load Grayscale 
   OLI Band 1 will display in View 3 
 
  Highlight View 4 > “Data Manager” > Select PC Band 1 > Load Grayscale 
   PC Band 1 will display in View 4 
 
  Views > Link Views  > Link All > OK 
 
  Zoom in to the Red Rose Anticline.  In View 3 use the Data Manager to 
  load another OLI band.  Compare a few OLI bands to PC 1.  

 

   Eigenvalue 
PC1:  1,270,891 
PC2:  212,665 
PC3:  51,161 
PC4:  11,321 
PC5:  5048 
PC6:  729 
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Question 7:   A. Does the PC 1 image look very similar to the OLI bands, especially in 
  areas with topographic relief (ridges, cliffs, valleys, etc.)?  YES   NO 
    
  B. What percentage of the variance in the 6-band Landsat data set is in 
  PC1?  (Hint:  Use the values in the PC Eigenvalues table above) 
 
  C. What percentage of the variance in the 6-band Landsat data set is in 
  PC5?  (Hint:  Use the values in the PC Eigenvalues table above) 
    
 7c) Zoom out so both the Red Rose Anticline and the Wind River agricultural 
 fields are visible in the 4 views.   
  Highlight View 2  > Use the Data Manager  > Select PC2 – PC3 – PC4 as 
  R-G-B  >  Load Data  > Try different stretches > last stretch “Linear 1%”  
 
  Highlight View 3  > Use the Data Manager  > Select PC4 – PC5 – PC6 as 
  R-G-B  >  Load Data  > Try different stretches > last stretch “Linear 1%” 
 
  Highlight View 4  > Use the Data Manager  > Select PC3 – PC4 – PC5 as 
  R-G-B  >  Load Data  > Try different stretches > last stretch “Linear 1%” 
 
  Pan over the Wind River agricultural fields and note the increased level of 
  information available with PC color images compared with the traditional 
  color IR image in View 1 
 
Question 8:   A.  Which PC color image in Views 2, 3, and 4 provides the most  
  information for you about the agricultural fields? 
 
  B.  The PC color image generated from PC4-PC5-PC6 as R-G-B has what 
  percentage of the total variance in the 6-band Landsat dataset? 
   (Hint: refer to Eigenvalue table above and use your calculator) 
 
NOTE: If we converted our NDVI grayscale image to a Mask, we could mask out the 
non-vegetated terrain in the Thermopolis scene and generate more detailed and 
informative PCs over the agricultural and natural vegetated areas.  The Mask could be 
inverted and vegetation eliminated from the PC analysis to extract more unique 
patterns on the PC images over terrain with geologic outcrops. 
 
Principal Components provide unique and often very subtle but important information 
about features of interest.  PCs should be applied to any multispectral data set to see 
what spectral patterns may be hidden in the original bands. 
 
The Landsat 8 OLI sensor (VNIR-SWIR) is so noise-free that the PC 5 image is almost 
noise-free and even the PC 6 image displays unique spectral information.  Awesome 
remote sensing technology! 
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Lab 5   Band Ratios and Principal Component   Name: 

Upload the following files to the instructor: 
 
 (4) “Your Name_Iron_Sites”  geotiff 
  

  (5) “Your Name_Clay_Sites”  geotiff 

  (6) “YourName_color-coded_NDVI_jpg”   jpg 

 
Question 1:  Put your cursor on the brightest pixel in the Chainman Shale (Red Rose 
Anticline (see textbook Figure 3-11H if you don’t remember where that is). 
 A.  What is the Data value (DN) for the bright pixel on the iron ratio image: 
 
 B.  What is the Data value (DN) for the same pixel on the clay ratio image: 
 
Question 2: Put your cursor on the brightest pixel in a Wind River agricultural field (see 
textbook Figure 3-11H if you don’t remember where the river is). 
 A.  What is the Data value (DN) for the bright pixel on the clay ratio image: 
 
 B.  What is the Data value (DN) for the same pixel on the iron ratio image: 
 

Question 3:   A. Why do you think the clay ratio image in View 3 is so similar to the 
  NDVI  image (vegetation greenness or vigor) image in View 4? 
 
  B.  Roam around the linked What type of feature has pixels on the clay 
  ratio image that are  bright  but dark on the NDVI image?     
      (hint: look also at the color image in view 1 – change the bands to  
    OLI 7-5-2 as R-G-B.  Look at the iron band ratio image also). 
 

Question 4:  A. What range of NDVI values do you find on your NDVI image? 
  
  B.  Did you find any negative values? 
 

Question 5:  A. What range of DN values (Min and Max) do you find in the metadata for 
  the NDVI image? 

 
  B. Is the range of DNs in the image’s metadata different than what you 
  found clicking around the image with the Cursor Value tool?  YES   NO   
 
  C.  What is your opinion about those pixels in the metadata with DNs 
  outside of the NDVI  -1 to 1 range? 
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Question 6:   A.  What density slice colors appear on your NDVI image in View 4? 
 
  B.  Is this NDVI image what you want for a final, color-coded product? 
 
Question 7:   A. Does the PC 1 image look very similar to the OLI bands, especially in 
  areas with topographic relief (ridges, cliffs, valleys, etc.)?  YES   NO 
    
  B. What percentage of the variance in the 6-band Landsat data set is in 
  PC1?   
 
  C. What percentage of the variance in the 6-band Landsat data set is in 
  PC5? 
   (Hint:  Use the values in the PC Eigenvalues table above) 
 
Question 8:   A.  Which PC color image provides the most information for you about the 
  agricultural fields? 
 
  B.  The PC color image generated from PC4-PC5-PC6 as R-G-B has what 
  percentage of the total variance in the 6-band Landsat dataset? 
   (Hint: refer to Eigenvalue table above and use your calculator) 
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Lab 6  Georeferencing                  
The objective of this lab is to learn how to georeference a raster file with no coordinates 
(named a “warp image file” in ENVI) to a raster image (named a “base image file” in 
ENVI) that is in a coordinate system (see Chapter 9 Digital Image Processing for 
discussion).  Georeferencing does not account for distortions in the input file due to 
topography – that requires correction with the orthorectification process which is beyond 
this lab. The tools for georeferencing are in the ENVI Toolbox. 

Three georeferenced files are to be uploaded to the instructor.  There are two questions 
at the end of the handout for you to answer. 

The first exercise will use a 1959 scanned aerial photograph as the warp image file and 
a 2000 orthorectified aerial photograph as the base image.  Portions of these aerial 
photographs are discussed in the textbook’s Chapter 1 (Figures 1-5 and 1-9), Chapter 2 
(Figure 2-20 and Plate 4), and Chapter 7 (Plate 25).  Both aerial photographs are in the 
Lab_6_Data folder. 

ENVI uses the term “Registration” for georeferencing.  The new “GIS-look” ENVI 
provides a workflow wizard to simplify the process. 

 

However, I was unable to make the ENVI Wizard work properly – it may be a software 
bug or a conflict with my Windows Operating system?    Try the Wizard  - it is found in 
the ENVI Toolbox   
  > Geometric Correction > Registration > Image Registration Workflow 

 

Therefore, the step-by-step guidance in this lab will use the 
 “ENVI Classic” front-end which never fails and is used by power users. 
The concepts and steps are very similar between the ENVI Classic 
and the newer “GIS-look” ENVI.  The newer ENVI just displays the 
steps so they are easier to view and more steps are automated.         
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The ENVI Classic toolbar has drop-down menus that replicate the tools in the “newer” 
ENVI front-end that we have been using for almost all the labs. 

Exercise 1.  Georeferencing a scanned aerial photograph 
                          to an orthorectified aerial photograph. 

1) Using your computer’s file management system,  Open the Lab_6_Data folder and 
its subfolder “1_Airphotos” to view the base image and the scanned image.  You will 
see the orthorectified base image – it is a .tif file with the coordinate information in the 
.tfw file.  Double-click on the .tfw file and open with simple software that can read .txt 

files.   

 .tfw files are attached to a georeferenced raster .tif with the same name so that 
 essential coordinate information is available when the raster file is loaded into a 
 GIS or image processing system.  The .tfw file we will be using looks like this: 

 

 The 1st line is the pixel size in the x-direction in meters.  The 4th line is the pixel 
 size in the y-direction in meters.  The 2nd and 3rd lines document the rotation (if 
 any).  The 5th line is the x-coordinate for the center of the upper left pixel and the 
 6th line is the y-coordinate for the center of the upper left pixel.  

NOTE: The .tfw does not tell you the coordinate system which is required by a GIS. 
Geotiff raster files can have georeferencing information (coordinate system, map 
projection, ellipsoid, datum, etc.) embedded in their header but if they don’t you have to 
make educated guesses about the geotiff’s coordinate system based on the coordinates 
in lines 5 and 6 of the .tfw file.  The guess relies on your knowledge about common 
coordinate systems used for the geographic area that is being mapped.  If you guess 
correctly, the geotiff  will load into the correct location using your geospatial software. 
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2) We are going to georeference a scanned 1959 aerial photograph to an orthorectified 
2000 aerial photograph (this base image has it’s map projection as UTM 10N, Datum 
NAD-83).   

 First we load these two images in separate ENVI Classic displays. 
 File > Open Image File   Drive to the Lab_6_Data folder  

 

 Select “2000_Aerialphoto_2ft_ortho_base_GIS”  > Open 

  The “Available Bands List” window  
  pops-up with the base image. 

  Accept default “Gray Scale” 

  Click-on “Load Band”  

  The base image will automatically 
  load into Display #1.  
     

 

 File > Open Image File  Select  “Scanned_6aug1959_Wetlands_Airphoto_Nup_” 
  The warp image is displayed in the “Available Band List” window.  
  Click-on “Display #1” drop-down menu > Click-on “New Display” 
  Click-on “Load Band”. The warp file will load in Display #2. 

 Your ENVI Classic set-up should look like the screen-capture below. 
 Each Display has a Scroll window with the entire scene, an Image window  
 with the raster files displayed as 1:1, and a Zoom window.  Place   
 cross-hairs in the Zoom window by clicking on the small square with no   
 lines at the bottom left corner of the Zoom window.    

 Move the red outlined square in the “Scroll” window with your cursor to pan 
 across the scene and look at subareas in more detail in the “Image” window.   

 Move the red outlined square in the “Image” window to look at subareas in more 
 detail in the “Zoom” window. 
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3) Before proceeding further it is important that you visually evaluate both images to 
understand common features between the two images, the extent of overlap, and 
potential GCP locations on both images.     Much development and environmental 
change has occurred in this area along the Interstate 680 corridor between 1959 and 
2000.  Look at the four sites listed below for potential GCPs. 
 
 a) Storage tanks associated with a refinery are in both the 1959 and 2000 
 images.  Look for common infrastructure in the two photographs that can be 
 used for an initial GCP (seed-tie-point).    

 b) You can see a wetlands in the upper right portion of the two photographs.  
 Zoom-in to the wetlands in both Views.  You can see on the 1959 photograph a 
 straight channel trending NW-SW has been dredged through the meandering 
 stream.  In the 2000 photographs remnants of the channels and levees 
 associated with the meandering stream and dredged channel can be seen 
 protruding through the water.  The 1959 vegetated wetlands has evolved into a 
 water body – a large pond- by 2000.  Look for common features in the two 
 photographs that you can use for an initial GCP (seed-tie-point).  

 c) Look at the lower right portion of the photographs.  You can find common 
 street  patterns in the subdivisions that you can use for an initial GCP (see-tie-
 point) 

 d) Look at the lower left portion of the photographs.  You can interpret a reservoir 
 with a dock in the 1959 and 2000 photographs that extends into the water body – 
 this is an excellent initial GCP (see-tie-point).  
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4) Look at the “Registration” options in the ENVI Classic Header Toolbox.  (see below) 

 

 Select GCPs: Image to Image registration means pixels in the input warp image 
 are being georeferenced to pixels in the base image by identifying ground control 
 points  (GCPs).  

 Select GCPs: Image to Map registration means pixels in the input warp image 
 are being assigned coordinates based on visual correlation with the grid on a 
 map. 

 Warp from GCPs means that GCPs are already available and can be applied to a 
 warp image – no need for the remote sensing analysts to pick new GCPs 

5) We will select the “Select GCPs: Image to Image” tool from the Map > Registration 
drop-down menu.  The “Image to Image Registration” window pops up. 

 

 Display #1 has the Base Image.  Display #2 has the Warp Image  > OK 

The “Ground Control Points Selection” window pops-up.  Press on the “Show List” 
button in the lower left corner to open up the “Image to Image GCP List” (see below) 
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6) Now we will start collecting GCPs.  You have to collect 3 GCPs before any 
automated prediction tools can be enabled by the ENVI software.  Try to get these first 
three GCPs (also called “seed tie points) spread over the scene.  Pick the GCPs using 
the Zoom Display and cross-hairs. 

GCP #1:  Zoom-in to the dock in the reservoir on both photographs (discussed in 3d 
above).  In Display #1 and #2 Zoom windows place the cross-hairs on what you 
interpret as the same location on the base image and on the 1959 warp image.   

         
 If you don’t see cross-hairs, click on the right “+” icon in the lower left corner of 
 the “Zoom” window. 

“Predict” tool used  
after 3 GCPs are  

collected. 
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 In the “Ground Control Points Selection” window > press “Add Point”.  You will 
 see your GCP #1 fills in the first row in your GCP list window. 

GCP #2:  Pan over the right side of the aerial photographs and find a street pattern that 
is identical between 1959 and 2000 (3c above).  Example below. 

 

GCP #3:  Find matching features in the wetlands (3b) or in the refinery (3a).   

If you make errors, just delete the GCP in the GCP list and redo the point. 

NOTE:  Pick GPCs at the base of buildings and tanks.  This minimizes location errors.  
The tops of buildings, oil storage tanks, and tall trees can have significant offset from 
their location on the ground due to inherent radial distortion from the camera lens.   

7) After you have entered the first 3 GCPs, you can take advantage of the “Predict” tool.  
You select locate a GCP in the base image with your cursor and cross-hairs, click-on 
the “Predict” button on the “Ground Control Points Selection”.  ENVI will automatically 
use the georeferencing information in the first 3 GCPs to predict where the 4th GCP is 
located in the warp image.  To make the location of the predicted GCP more accurate, 
use your cursor to move the cross-hairs in the warp image to the most correct pixel 
based on visual comparison of the feature in the base and warp images.  After you 
correct the predicted GCP in the warp image > Add Point.   

8) The rest of the GCPs that you select should be spread evenly around the warp image 
to ensure a more accurate georeferencing of the warp image to the base image.  This is 
a good time to review the Georeferencing discussion in the textbook’s Chapter 9.  

Question 1:  Why should you have your GCPs distributed across the warp image and 
not confined to one corner or arranged along a line? 

NOTE:  Anytime you get confused, click-on Help in the ENVI Classic toolbar, open the 
Index tab, and type “Registration” in the  “Search Index” window.  
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9) After you pick your 5th GCP, the GCP list fills in the cells for C and Y Error and the 
RMS error (root mean square).  You try to minimize the RMS error by adding more and 
better points that are spread across the image and by deleting GCPs that have 
excessive error. 

To see the RMS error listed in order, in the “Image to Image GCP List” click on the 
“Options” button and click on the “Order Points by Error”.  The GCPs will be listed in the 
table with the GCPs with the largest error at the top. 

To see the overall RMS Error, look at the “Ground Control Points Selection” window. 

 

10) Pick 10 GCPs distributed across the warp image.  It is very difficult to find any 
control in the northeast portion of the 1959 aerial photograph.  See example below of 10 
GCPs posted on the 1959 warp image. 

 

Your final table should look something like this (see next page).  To save your GCPs,  
  File > Save Table to ASCII…   
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  Name the GCP file “1959_10pts” 

  

11)  As noted in the Chapter 9 “Georeferencing” section, it is often best to apply a first-
order (linear) polynomial transformation to digitally georeference your warp image into 
the map projection of your base image.  First order cannot bend the warp image – it can 
only change the location, scale, and skew of x and y and rotate the image.  You only 
need 3 GCPs to do a first-order transformation, but typically one would use at least 8 
GCPs. 

2nd order (parabola) transformations can bend the warp image.  This can cause pixels 
on the margins of your warp image to be digitally “rubber sheeted” far away from their 
true location.  A 2nd order transformation can minimize the radial distortion caused by 
the camera lens if the GCPs are well distributed and there is minimal topographic relief.  
You need 6 (9 with some software) GCPs to do a second-order transformation, but 12 
or more is preferred. 

On the upper right corner of the “Ground Control Points Selection” window is a “Degree” 
window.  “1” means 1st order (linear) warp – and the total RMS Error is posted at the 
bottom of this menu.  Change the “Degree” window to “2” and you will see the RMS 
Error changes.  A reduced RMS Error for 2nd degree compared to 1st degree does not 
mean the warped image will look better – there may be significant errors away from the 
GCPs along the margins of the warp image. 

For this exercise we will use a 1st degree (linear) transformation. 

12) In the “Ground Control Points Selection window”, click-on Options > Warp File 
   The “Input Warp Image” window pops-up.  Select the 1959 warp air photo > OK 
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   The “Registration parameters” window pops-up.  Choose “Resampling” as Bilinear 
 See textbook Chapter 9 for discussion of resampling 
      Nearest neighbor: retains spectral information in pixels, but is blocky. 
 
     Bilinear: uses DNs from 4 pixels in base image to assign DN to the   
   corresponding warped image pixel. Smoother appearance than  
   with nearest neighbor resampling. 

  Cubic convolution:  uses DNs from 16 pixels in base image to assign DN  
   to the  corresponding warped image pixel.  Smoothest appearance  
   for the warped image. 

   Accept defaults – Polynomial and 1st degree. 

 
   Change Resampling to Bilinear 

 
   Name the warped file  
         “1959_Aerial_Photo_UTM10_ENVI” 

 

   > OK 

 

  

  

13) The warped image is resampled to the pixel size in the Base image – 0.6 m or 2 
feet.  The original 1959 scanned air photo was 1716 x 1716 in size.  The georeferenced 
1959 air photo is ~3808 x 3808 in size.   

 To see metadata on files, use the ENVI Classic Toolbar 
    > File > Edit ENVI Header and select the file of interest. 
   Double-click on the file and more information is revealed. 

14) The 1959 warped air photo is listed and highlighted at the top of the “Available Band 
List”.  Select “New Display” and press “Load Band”.  The georeferenced 1959 air photo 
will be in Display #3. 

15) So the warped air photo is useful for GIS, CAD, and other geospatial programs we 
will save it as a geoTIFF. 
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 Display #3 > File > Save Image As > Image File >  

 The Output Display to Image File window pops-up 
  
  Ensure Resolution is “8 bit (gray scale) 
  Change Output File Type to “TIFF/GeoTIFF” 
  Name the file “YourName_1959_Aerial_Photo_GIS” 
   
  Upload the georeferenced 1959 air photo to the instructor 
 
 A geoTIFF file will not automatically display in the “Available Band List” menu. 

16) To visually evaluate how good your georeferencing was, let’s link Display #1 (Base 
Image) and Display #3 (georeferenced image). 
     Display #1 > Tools > Link > Link Displays  
 The “Link Displays” window pops-up. 
    Change Display #2 to “No” (see below)  > OK 

 

 Roam around using the square box in the Scroll Window of either Display #1 or 
 Display #2.  Appreciate the incredible development and environmental change in 
 this area during the late 20th century!   

17) With the “newer” GIS-look ENVI front end, you can load the two georeferenced 
images into one view and use Swipe or Flicker to compare and note changes. 

If you access to a GIS, load the two georeferenced images and open streaming vector 
and raster base maps to compare your georeferenced air photos with what is available 
online. 

18)  Now that you have completed one cycle of the ENVI Classic georeferencing 
workflow, let’s try another georeferencing exercise using a 15 m ASTER satellite image 
and non-georeferenced jpgs of scanned 1980 wetland and 1880 interpreted wetland 
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maps of the Suisun subregion, California created by the San Francisco Estuary Institute 
as documented below:

 

19) Using your computer’s file management system,  Open the Lab_6_Data folder and 
its subfolder named “2_ASTER_Maps”  The contents are shown below: 

 

The ASTER will be the Base Image.  The 1980 and 1880 SFEIs maps are the Warp 
Images.  We’ll start our ENVI Classic georeferencing effort with the ASTER and the 
1980 map of the wetlands. 

20) First we close the airphoto displays.  “Available Band List” > File > Close All Files 

  Next we load these two images in separate ENVI Classic displays. 
 File > Open Image File   Drive to the Lab_6_Data folder  

 Select “Base-ASTER_CIR_2003_15m_GIS.tif”  > Open 
 Load the color image into Display #1. 
  ENVI automatically loads the three bands of the color IR satellite image. 
   

NOTE: The band sequence (R-G-B) is interpreted correctly by ENVI if the  vegetation is 
red in the color image in Display #1.  If vegetation is bluish, the sequence of bands in 
the ASTER geoTIFF is different from what ENVI expected, and you have to manually 
correct the loading of the ASTER bands to make the vegetation red.  

 Next Select “1980_SFEI_map.jpg” > Open 
 Change “Display #1” in the lower right corner to “New Display” 
 The SFEI map is in Display #2. 

21) Roam around the image and map and look for potential GCP points.  Railroad and 
road track intersections and other man-made infrastructure are good candidates for 
GCPs.  Look at the legends in the 1980 and 1880 folders to understand the symbology 
on the SFEI maps. 
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22) Start the georeferencing process.   
 ENVI Classic Toolbar > Map > Registration > Select GCPs: Image to Image 
 
ENVI georeferences the warp 1980 map as an ENVI file.  Let’s save your 
georeferenced 1980 wetlands map as a .tif 

 Display #3 > File > Save Image As > Image File >  

 The Output Display to Image File window pops-up 
  
  Ensure Resolution is “24-bit Color (BSQ) 
  Change Output File Type to “TIFF/GeoTIFF” 
  Name the file “YourName_1959_Aerial_Photo_GIS” 
 
 Name “Your name_1980_SFEI_GIS.tif” 

23)  Open the georeferenced 1980 map (base image) and the 1880 interpretation map 
(warp image) in separate Displays.   

Question 2:  Why did we georeference the 1980 map to the 2003 ASTER image first – 
and then georeference the 1880 map to the georeferenced 1980 map.  (Hint: think 
about dates of the three files and look at the features (roads and railroads) common to 
the two SFEI maps).   

Load the georeferenced 1980 in Display #1 and the scanned 1880 jpg map in Display 
#2.  Repeat the georeferencing workflow. 

When done, save your georeferenced 1880 interpreted wetlands map as a .tif 
 Name “Your name_1880_SFEI_GIS.tif” 

24) If you have access to a GIS, load the ASTER, 2000 orthorectified air photo, 
georeferenced 1959 air photo, georeferenced 1880 wetlands map, and georeferenced 
1980 wetlands map into the GIS.   

You have created something new.  These georeferenced images and maps can be 
uploaded into Google Earth, ESRI ArcGIS Globe, or any geospatial software system.  
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Lab 6  Georeferencing                          Name: 

Upload the following files to your instructor: 

 (15) “YourName_1959_Aerial_Photo_GIS”   .tif 

 

 (22) “Your name_1980_SFEI_GIS”    .tif 

 

 (23) “Your name_1880_SFEI_GIS”    .tif 

 

Question 1:  Why should you have your GCPs distributed across the warp image and 
not confined to one corner or arranged along a line? 

 

 

Question 2:  Why did we georeference the 1980 map to the 2003 ASTER image first – 
and then georeference the 1880 map to the georeferenced 1980 map.  (Hint: think 
about dates of the three files and look at the features (roads and railroads) common to 
the two SFEI maps).   
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Lab 7   DEMs and Lidar 
Utilizes Textbook’s Remote Sensing Digital Database: Chapter 7 data. 

The objectives of this lab include enhancement of DEMs generated with radar and lidar 
using image-processing tools and visualization to improve understanding of the models.  
ENVI Toolbox contains the tasks that we will use for this lab.  A short video for the lidar 
section that reviews the tools in the new ENVI LiDAR display is in the Lab_7_Data 
folder  

Two digital files are to be uploaded to the instructor and ten questions are to be 
answered on the final pages of this handout. 

Radar DEMs 

1) Airborne L-band and P-band radar were flown over the Fairbanks, Alaska area to 
generate a Digital Surface Model (DSM) and a Digital Terrain Model (DTM).  See 
discussion in the textbook Chapter 7.  The data are located in the Remote Sensing 
Digital Database \ Ch_7_DEMs in the Chapter 7 folder. The path is: 

 Plate 23 P-and X-band GeoSAR_AK \ 
          GeoSAR_DSM-DTM_ \  DSM, DTM, and Ortho_Radar_Image folders 

  
Subfolders in “GeoSAR_DSM-DTM_” folder 

2) Review the “READ ME…” pdf in the “Plate 23 P-and X-band…” folder.  The READ 
ME file provides an overview of the technology applied and examples from the textbook 
of final products that can be generated with remote sensing and GIS software. 

3) Open the newer ENVI “GIS-look” program  > File > Open >   

 drive to the “Ortho_Radar_Image folder and select “ORI_N6445W14800.tif” 
 > Open 
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 > Zoom to Full Extent Fairbanks is on the East side of the image, North 
     of the Chena River. 
      
Question 1: A. In which direction is the radar beam pointing  (N, S, E, or W)?  

  B. Why does the river south of Fairbanks have a very dark? 

4) DSM:  Open the DSM folder and  load  “DSM_N6445W14800.tif” into the View. 
 Right-click on this DSM layer in the Layer Manager > Quick Stats 
 The “Statistics View:….” window pops-up. 
  In the upper left, Select Plot > Histogram Plot 1 
 
Question 2: What is the minimum elevation of this DSM? 
 
 
 4a) ENVI Toolbox > Classification > Raster Color Slices    
 Select the DSM in the “Data Selection” window    >  
 Accept Defaults: 16-slices, rainbow color scheme > OK  

 4b) ENVI Toolbox > Terrain > Create Hill Shade Image 
 Select the DSM in the 
 “Select Hill shade Input DEM File” window    > OK 
 The “Hill shade Image Parameters” window pops-up 
  Enter “25” for Sun Elevation Angle 
  Enter “270” for Sun Azimuth Angle 
  Select “B-W LINEAR” for Color Table to Apply 
  Change “Stretch” to “0.0”  (no stretch applied) 
  FileName:  “YourName_DSM_hs_ENVI”  > OK 

 
 The hill shade DSM displays in the View.  Zoom to Full Extent 
 Zoom-in and pan around  

Question 3: What natural and man-made features are generating the surface on the 
DSM?   (Hint: Turn off all layers in the Layer Manager except the hillshade DSM and the 
ORI radar image.  Turn the top layer on & off to identify features.  ) 

Turn on the Raster Color Slice layer in the Layer Manager.  If your hillshade DSM is 
above this layer in the Layer Manager, use the Transparency Tool to fade the hillshade 
DSM so the color on the DSM can be seen. 
 Zoom-in to an area of interest.   
 Type in the scale 1:25,000 (near the top-center of the ENVI display window) 
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 Let’s save a jpg of the enlarged area (this display) for the instructor 

 File > Chip View To > Image     
 The “Chip to File Parameters” window pops-up.   
 Choose Output Format “JPEG” 
 Name the file “YourName_color-coded_25K_DSM” 
 Don’t “display result”    We will look at the jpg outside of ENVI. 

 Open up your jpg.  Is the quality acceptable?  What’s missing?  Where’s the 
 scale bar, legend, coordinate grid – essential cartography elements for GIS and 
 map-making?  This is just a picture – it has very little value in the real world. 
  
 The new ENVI GIS-look front end seemingly cannot attach cartographic 
 elements to exported images – unless you start ENVI in 32-bit mode and have an 
 ArcGIS license…?  That is not good – if this is true and there is no work-around. 
 You can create and export images with scale, coordinate grid, N-arrow, logos, 
 text boxes, and other cartographic elements using the older ENVI Classic and 
 the “QuickMap” tool. 
 
 Going forward, if you use this new ENVI front end, Export your enhanced 
 imagery and DEMs in the geoTIFF format  so you can use GIS software to add 
 symbology and critical cartographic elements.  

 4d) Let’s create a 3D Surface View with  
 our color-coded hill shade DSM (displayed here).   

 BUT first, the two files are separate in the color-coded,  
 hillshade DSM – 1) the faded grayscale hillshade  
 and 2) the 16-slice color DSM.   
  
 We need to combine these two images into one so 
 we can use the 3D Surface View (and other  
 visualization software).   The combined color-coded  
 hill shade image will be draped over the DEM to enable 
 perspective 3D viewing. 

 To combine the full scenes of the two files that we see on the screen into one 
 raster  image file we should “Zoom to Full Extent” to see what is going to be 
 saved. 
 File > Export View To > Image File   
 The “Export View to Image File” window pops-up. 
  We want the Full scene, so click the button next to “Full”  
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  Note the pixel size is the original data size, the Zoom Factor is 1.0000 
  We can output in ENVI format for this exercise. 
  Name the Output file:  “hs_with_color-coded_DSM_ENVI”   > OK 

 The “hs_with_color-coded_DSM_ENVI”  image is displayed in our View. 

 4e) Now we can use the ENVI visualization tool! 

 ENVI Toolbox > Terrain > 3D Surface View 
 The “Select 3D SurfaceView Image Bands…” window pops up 
 
 Sequentially select Band 1, Band 2, Band 3 that make up the  
 “hs_with_color-coded_DSM_ENVI”  color image so that the R, G, B buttons are 
 filled in the correct sequence in the” Available Bands List” menu.  > OK 
 
 Next we select the “Associated DEM Input File”.   
 Select > “DSM_N6445W14800.tif”  > OK 

 The “3D SurfaceView Input Parameters” window pops-up. 
  Click on “512” and accept the other defaults  > OK 

 The 3D SurfaceView display pops-up with your color-coded, hill-shade DSM 
 with 5X vertical exaggeration draped on the DSM.  Many options are available in 
 this display, including saving the surface view as a VRML file. 

 

 

Let’s show this to the instructor.  In the “3D SurfaceView” display, 
 File > Save Surface As > Image File     
 The “Output Plot to Image File” window pops up (see next page).   

 We want a color jpg of this perspective view so we set Resolution as “24-bit 
 Color (BSQ)”, Output File Type as “JPEG”, and Compression Factor as “0.95” 
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 Name the jpg “YourName_DSM_Perspective_View”  > OK 

 Upload to the instructor. 

 Close the “3D_SurfaceView” window. 

5) DTM   Let’s compare the DTM to the DSM.  Views > Two Vertical Views 

Activate View 2 by clicking on the empty View 2.   

 File > Open drive to the “DTM” folder.   Select “DTM_N6445W14800.tif”  > Open 
Zoom to Full Extent. 

 5a) ENVI Toolbox > Terrain > Create Hill Shade Image 
 Select the DTM in the “Select Hill shade Input DEM File” window    > OK 
 The “Hill shade Image Parameters” window pops-up 
  Enter “25” for Sun Elevation Angle 
  Enter “270” for Sun Azimuth Angle 
  Select “B-W LINEAR” for Color Table to Apply 
  Change “Stretch” to “0.0”  (no stretch applied) 
  FileName:  “YourName_DTM_hs_ENVI”  > OK 

 5b) Views > Link Views   “Link Views” window pops-up > Link All > OK 

 We want to use the “Cursor Value” tool to see the elevation at the same pixel on 
 the DSM and DTM.   
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 The DTM and hillshade DTM and the DSM and hillshade DSM should be turned 
 on in the Layer Manager.  Un-check all other files. 

 5c) In the Cursor Value menu,  
  press “Link Views” button and  
  press “Display Information for all Views” button. 

  Now you should see the elevation in the DTM and DSM appear in the  
  Cursor Value window. 

 

 

 

  

 

     DTM elevation is here (226.6 m) 

 

 

 

     DSM elevation is here (235.6 m) 

 
 
Question 4: A. what is the DTM and DSM elevation at the airport runway? 
 
  B.  What is the elevation of the DTM and DSM about 3.5 km NW of the  
  airport runway, along the crest of the ridge? 

  C.  What causes the DSM and DTM to have different elevations along the  
  crest of the ridge about 4 km NW of the airport runway? 

  D.  Why was one radar wavelength used primarily for the DSM and the  
  other radar wavelength used to generate the DTM?   

Lidar 
6) Let’s start over with a new ENVI Display.  File > Exit   to close the Radar DEMs 
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Using your computer’s file management system,   
 Open the Remote Sensing Digital Database and then open the subfolder 
 “Ch_7_DEMs”.  There are five DEM examples in this folder.  We are going to use 
 the lidar data in the subfolder “Plates_21-22_ LiDAR_DVC-CA”.   
          (See file structure below) 

 

The lidar data is in standard .las format and is located in the “DSM_First-Return-LiDAR” 
and “DTM_Last-return-LiDAR” folders.  This .las data was processed and converted to 
geoTIFFs to simplify use in a GIS, CAD, or other geospatial software.  These geoTIFFs 
are located in the “DSM_First-Return_Answer” and DTM_Last-Return_Answer” 

A color orthoimage is in the “Aerial_Orthophoto” folder.  Open these folders to 
familiarize yourself with the many files that you will be working with in this lab.  Many of 
the files are intermediate forms that were generated by ENVI, ERDAS, and ArcGIS 
software as the original lidar data was processed. 
 

6a) We will be working with lidar data of a suburban area west of Pleasant Hill, 
California. 

The source of the lidar data is the Contra Costa County 2008 Orthophotographs & Lidar 
project.  Available at: https://gis.cccounty.us/Downloads/Lidar/2008/   the zip is 70 GB! 
 
The lidar and orthorectified image are in the State Plane CA III FIPS 0403 Feet (US) 
NAD-83 Coordinate System. 
 
6b) Start up a new ENVI Display.    File > Open    the orthorectified aerial color image 
      “g09d2_3_color_mar-apr2008_1meter”  > Open 
 >  Zoom to Full Extent 

https://gis.cccounty.us/Downloads/Lidar/2008/
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 Review what and where the land cover/land use features are in this area, 
 including single family dwellings, golf course, non-irrigated grass-covered terrain, 
 a road network with many curves, etc. 

6c) Now we will review the metadata associated with the .las lidar files 
 ENVI Toolbox > LiDAR > View LAS Header 
 Drive to the “Data” folder and open the “DSM_First-Return-LiDAR” 
 Select “G09D2_3(2).las”  > Open 
 Examine the metadata in the header. 
 
Question 5:  A. What is the minimum and maximum elevation (Z) in the DSM? 

 ASPRS helped establish standards for lidar data.  The points are classified into 9 
categories as shown below.  However, the metadata for our dataset lacks this 
classification as it notes with “0” that the lidar points were  “Created, never classified” 

 

Portion of the metadata for our lidar data 

 

 

 

 

 

 Now we will look at the metadata for the DTM. 
 ENVI Toolbox > LiDAR > View LAS Header 
 Drive to the “Data” folder and open the “DTM_First-Return-LiDAR” 
 Select “G09D2_3.las”  > Open 
 Examine the metadata in the header. 
 
Question 6:  A. What is the minimum and maximum elevation (Z) in the DTM? 

  B. How many lidar points are in this DTM data set?     
   (NUM_POINT_RECORDS) 
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6d) Now we will switch to a new display ENVI has created to view and interact with lidar 
data.  A 9-minute video is included in the Lab_7_Data_Video folder that provides an 
overview of the ENVI LiDAR tools and display options to help you be more efficient 
working your way through the lidar portion of this lab.  
 
 ENVI Toolbox > LiDAR > Launch ENVI LiDAR 
 We will first load the DSM into this view.   File > Open  Select “G09D2_3(2).las” 
 > Open   You should see this display.  The DSM is displayed as a “Solid” surface. 

 In the layer manager, right-click on “DSM” > change to “Wireframe” 
 Zoom-in until you see clearly see the the 1 meter grid. 
 In the layer manager, right-click on “DSM” > change to “Solid”  Zoom-out 

 
 

 The window at the lower left shows the extent of the entire DSM.  It has a 
 rectangular outline that shows what portion of the DSM is shown in the main 
 display.  Use your cursor to draw an outline around the entire thumbnail image 
 (approximately 918 x 616).  The entire DSM is shown in the main display.  

6e) Interrogate the drop-down menus and the ribbon of icons across the top of the ENVI 
LiDAR window.  We’ll activate a few of them. 

 



10 
 

10 Introduction to Remote Sensing  Principles, Interpretation, and Applications 
F. F. Sabins and J.M. Ellis, 2020, Waveland Press.    Contact:  jellis@ellis-geospatial.com 

 

 View > Height Legend  (note the units are in meters!) 
 Help > Help Contents  (very useful to read before proceeding too far) 
 Reset Perspective View  icon > Move your mouse around to rotate and tilt the  
      model  
  Zoom-in on the grove of trees along the top margin of the DSM.  Change  
  the rendition of the model between Wire Frame to Solid (see below) 

     

Question 7:  A. Why do the trees have elongated, near-vertical sides around the extent  
  of the tree canopy? 

  B. What do the red dots at the top of the canopy represent? 

 Reset Isometric View icon > Click on the model in the display  and roll your  
      mouse wheel to zoom in and out.  
     > Click on the left and right buttons on your mouse 
      and pan around the model.   

 Reset Isometric View icon > Click-on the Select Cross Section icon. 
 Move your cursor to the bottom margin of the model, click once and move your 
 cursor to the top of the model and click once to generate a N-S cross section. 

7) A “Cross Section” window pops-up at the bottom of the ENVI LiDAR window.  
  We’ll interact with a few of the tools at the top of the display. 
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 Often the width of the window automatically becomes too large.  At the upper 
 right of the “Cross Section” display is “Thickness (cm):”    Change to “500”. 

 The “Movement” tool has up-down arrows.  The default value seems to be “100”.  
 Clicking on the arrows moves the cross section in a direction perpendicular to the 
 cross section.  Increase number to “500” and the cross section moves in larger 
 increments. 

 The “Angle” rotates the cross-section.  Increasing the number from the default of 
 “1.000” moves the cross section in larger increments. 

 “Reset Position” places the cross section back to its original position (maybe? To 
 the bottom margin of the DSM...).  Click the “Movement” Arrow to move the cross 
 section across the model at intervals of “500”. 
  
 You can zoom into a feature of interest in the cross section with your mouse 
 wheel. 

Question 8:  What features do you see on the DSM cross section as you traverse the  
  model? (refer to the orthophotograph in the ENVI window that we opened  
  first)  

8) Click on the “Measurement Tool” icon (a ruler) in the ENVI LiDAR window.  Measure 
the height of some of the trees in the “Cross Section”.   

Question 9:  What is the height (in feet) of the tallest tree that you measure? 

 To remove the white banners with the XY and Z elevation at the measurement 
 sites > Right-click on the white banner > Delete Annotation  
 To remove the Cross Section vector lines on your ENVI LiDAR display, close (X) 
 the Cross section display.  

9) The last DSM exercise will use the “Color by Viewshed Analysis” icon in the upper 
ribbon of the ENVI LiDAR menu.   
 
Viewshed analysis is widely used to evaluate the visual impact to a person standing at a 
specific location of existing land cover/land use features, new construction, proposed 
logging, new hedgerows or barriers to “hide” infrastructure, etc.    

 

 Ensure you are zoomed-out so the entire DSM is displayed (use thumbnail tool in 
 lower left corner) 
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 Click-on the “Color by Viewshed Analysis” icon.  Instructions pop-up. 

 > OK 

 The DSM turns into a grayscale image. 
 Move your cursor to the southern slope near the top of the hill in the north margin 
 of DSM.  (imagine you are hiking up the slope toward the crest and turn around – 
 what do you see?) 
  Ctrl-Click at the site for the Viewshed Analysis  
 
  Those features that you can see from this site are displayed in green  
  (maybe).  The Add Observer Point menu pops-up.  Change Radius to  
  “500” and Visible Color to “Red” > OK 

    

  The pop-up instructions above tell us how to export this analysis. 
     File > Export > Viewshed Analysis Raster 
  This Export option did not allow me to name the file, or to direct it to a  
  specified folder…maybe you can figure out how to make the export work  
  for you…  
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  I’m just going to do a simple screen capture of my Viewshed perspective  
  view using the ENVI LiDAR  File > Screenshot to Powerpoint > Save As 
   
  “LastName_DSM Viewshed” 

  (If you don’t have Microsoft Powerpoint software on your computer, just  
  take a screen capture of your viewshed DSM and save it as a jpg) 

  Upload this graphic to the instructor. 
 

10) We’ll next look at the DTM.   File > Open > “G09D2_3.las”  > Open 
 The DSM disappears.  The DTM is loaded into the display.   
 In the Thumbnail display of the DTM (lower left corner), draw a large rectangle 
 over the East half of the DTM  so you capture the red hill and dark blue terrain. 

 The ENVI LiDAR can only display a 2000 x 2000 area on the main display.  
 Accept the program’s redrawn area. 

 The ENVI LiDAR program displays the DTM, but in the Layer Manager it is 
 labelled as “DSM”.  The software cannot identify the type of DEM being loaded. 

 Right-click  on “DSM” in the Layer Manager and alternate between Solid and 
 Wire Frame.  Zoom in to see the level of detail in the DTM. 

 If you see a grayscale DTM in the display, click on the Height Palette Editor” icon 
 and load the “Rainbow” palette (lower left corner of the menu) 

  Note the flat pads that have been constructed for the suburban homes  
  with cut and fill on the sloping terrain. 

  Notice how the trees in the DSM have been removed from the hill in the  
  north portion  of the DTM model. 

 Display the “Solid” model.  Click-on the “Reset Perspective View” icon. 

 Click on the “Filter Points By Height” icon.  (see below) 
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 Move the “Minimum (Min.) Project Height” slider to the right. 
 Set your minimum height at “100.00”   > OK 
 
Question 10.  What are you simulating by raising the minimum height on the DTM? 
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Lab 7   DEMs and Lidar                          Name: 

Upload the following files to the instructor: 
 
 (4) “YourName_color-coded_25K_DSM”    jpg 
 
 (4)  “YourName_DSM_Perspective_View”      
  
 (9) “LastName_Viewshed”   Powerpoint, jpg, or other format. 
  

 
Question 1: A. In which direction is the radar beam pointing  (N, S, E, or W)?  

  B. Why does the river south of Fairbanks have a very dark? 

Question 2: What is the minimum elevation of this DSM? 

Question 3: What natural and man-made features are generating the surface on the 
DSM?   (Hint: Turn off all layers in the Layer Manager except the hillshade DSM and the 
ORI radar image.  Turn the top layer on & off to identify features. ) 

Question 4: A. what is the DTM and DSM elevation at the airport runway? 
 
  B.  What is the elevation of the DTM and DSM about 3.5 km NW of the  
  airport runway, along the crest of the ridge? 

  C.  What causes the DSM and DTM to have different elevations along the  
  crest of the ridge about 3.5 km NW of the airport runway? 

  D.  Why was one radar wavelength used primarily for the DSM and the  
  other radar wavelength used to generate the DTM?   

Question 5:  A. What is the minimum and maximum elevation (Z) in the DSM? 

Question 6:  A. What is the minimum and maximum elevation (Z) in the DTM? 

  B. How many lidar points are in this DTM data set?     
   (NUM_POINT_RECORDS) 

Question 7:  A. Why do the trees have elongated, near-vertical sides around the extent  
  of the tree canopy? 

  B. What do the red dots at the top of the canopy represent? 
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Question 8:  What features do you see on the DSM cross section as you traverse the  
  model? (refer to the orthophotograph in the ENVI window that we opened  
  first)  

Question 9:  What is the height (in feet) of the tallest tree that you measure? 

Question 10.  What are you simulating by raising the minimum height on the DTM? 
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Lab 8   RGB-IHS-RGB Transform and Image Sharpening 
Utilizes Textbook’s Remote Sensing Digital Database: Chapter  4 data. 

The objectives of this lab include learning about RGB and IHS (or HSV) color systems, 
the RGB to IHS to RGB transform, and different techniques for image sharpening.  The 
transform exercise is long & tedious, but it will teach you about different image file types 
and shortcomings/complicated work-arounds with ENVI software.  The tasks are done 
with tools in the ENVI Toolbox. 

Six questions are to be answered on the last page of this handout and one digital file is 
to be uploaded to the instructor. 

1) RGB-IHS-RGB transform 
Chapter 2 discusses the additive and subtractive systems of primary colors Red, Green, 
and Blue.  Chapter 9 discusses an alternative approach to color - the Intensity (Value), 
Hue, and Saturation system.  Figure 9-19 shows the scaling used for the IHS system.  
IHS is equivalent to HSV (ENVI uses HSV) 

Color images often have a pastel appearance because the images are undersaturated. 
RGB images have their saturation (purity of color) increased by transforming the RGB 
colors into IHS color space, and contrast-stretching the Saturation grayscale image.  
After the Saturation image is contrast-stretched, the IHS images are transformed back 
to RGB colors.  See Figure 9-20 and Digital Image 9-1.  Edge enhancement and the 
replacement of the intensity image with the panchromatic band can also be done prior 
to transforming the IHS images back to a RGB color composite. 

We will create an ASTER color IR image from a 9-band ASTER multispectral dataset 
and contrast-stretch the color IR with a “Linear 1%” stretch.   

1a) The 9-band ASTER data set is in the “Remote Sensing Digital Database \ 
Ch_4_Other MSS_Satellites” folder within the “ASTER_VNIR-SWIR” subfolder. 

 

 Start-up ENVI > File > Open > drive to the “ASTER_Geo” subfolder > select > 
 “ASTER_2002_Reflectance_30m_9-band_ENVI_.img” > Open 

 Zoom to Full Extent > Choose “Linear 1%” stretch.  You should see a color IR 
 image displayed in the View.  Click-on the 9-band file in the Layer Manager to 
 ensure that the Bands 3N-2-1 are loaded into R-G-B.  ASTER does not collect a 
 blue band, so Band 3N = NIR, 2 = Red, and 1 = Green. 
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 Highlight the 9-band file in the Layer Manager.  We will export this enhanced 
 color IR image using   File > Export Selected Layer to TIFF… > Name the color 
 IR image “ASTER_CIR_Original” and check “Display result”  >  OK 

 The exported color IR image should look exactly like the 3N-2-1 as R-G-B color 
 composite made from the 9-band data set.   

 The Chugwater Redbeds in the Red Rose Anticline appear as yellow rocks in a 
 Color IR image (see Figure 3-11H for location if you forgot) 
  
 Uncheck the 9-band dataset in the Layer Manager.   

 Let’s open 4 Views.     Views > 2 x 2 Views 
 The 3-band color IR image is in View 1.  Zoom to Full Extent 

 Highlight View 2 (empty View in the upper right).  This will ensure the IHS (HSV) 
 color composite is displayed in View 2. 

     1b) First we’ll use ENVI’s programmed “Saturation Stretch” Tool.   
 ENVI Toolbox > Transform > Saturation Stretch 
  The “Saturation Stretch Input Bands” window pops up. 
  Select the 3-bands in our CIR original image as R-G-B > OK 
  Name the output “ENVI_Sat_Str_”  > Open > OK 
  The ENVI saturation stretched CIR image appears in View 2 
 
  Views > Link Views > Link All > OK   (empty Views don’t link) 

  Pan and zoom around, comparing the original CIR image to the ENVI  
  saturated stretch image.   

Question 1:  Discuss the differences in the colors between the original ASTER CIR  
  image and the ENVI saturated stretched CIR image.  Do you prefer the  
  “instant” ENVI saturation stretch or your 2% saturation stretch that you  
  created at the end of this exercise?  (see page 7 below)  WHY? 

How was the Saturation enhancement done???  What steps are involved?  Next we’ll 
do our own saturation stretch.  First we transform our RGB image to IHS (or HSV) color 
space. 

 In the Layer Manager, drag & drop the “ENVI_Sat_Str” CIR image into View 1  
  (so we don’t get confused later).  You can uncheck this image in View 1. 
 Right-click “ENVI_Sat_Str” image in View 2 in the Layer Manager > Remove 

 Highlight the empty View 2 so our IHS image is loaded here. 
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 ENVI Toolbox > Transform > Color Transforms > RGB to HSV Color Transform  
 The “RBG to HSV Input Bands” window pops-up. 
 Sequentially click-on Band 1 to Red, Band 2 to Green, Band 3 to Blue > OK 

 The “RGB to HSV Parameters” window pops-up. 
 Select the Original CIR bands 1, 2, 3 as R, G, B  > OK 
 Name the file “ASTER_IHS”  > OK 
 
 The HSV color composite displays in View 3.  We want to see the individual Hue, 
 Saturation, and Value (Intensity) grayscale images in Views 2, 3, and 4. 

 Open the “Data Manager” 
  The “ASTER_HS” I, H, S grayscale images are at the top of the list. 
  Highlight View 2 
  Click-on Hue > Load Grayscale >  Zoom to Full Extent > Linear 1% 
 
  Highlight View 3 
  Click-on Saturation > Load Grayscale >  Zoom to Full Extent > Linear 1% 

  Highlight View 4 
  Click-on Value (Intensity) > Load Grayscale  >  Zoom to Full Extent >  
               Linear 1% 
 The four views should look like the screen capture below.  
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 Open the Histogram Stretch icon to the right of the Contrast Stretch drop-down 
 menu. 
 Click on each View and look at the histogram.  Look at the horizontal   
 scale on the histograms.  The scale used on the horizontal axis     
 (brightness) is different for the RGB image (View 1) and the Hue image   
 (View 2).  Saturation and Intensity (Value) use the same scale, which is   
 different than the scale used by RGB images and Hue images. 
 
Question 2:   A. Which HSV grayscale image has a significant skew to the left (meaning 
   most pixels are dark)? 

  B) What is the range of brightness for Hue pixels? 

  C) What is the range of brightness for Intensity (Value) and Saturation  
  pixels? 

  D) What is the brightness value on the horizontal axis of the Saturation  
  (View 3) histogram when you slide the vertical line to the left  so that 95%  
  of the pixels are below that brightness value  (Hint:  look above the vertical 
  line for the data brightness value and percentage of pixels to the left of the 
  vertical line). 
 
1c)  We want to pan and zoom to the same pixels in the four views. 
 Views > Link Views > Link All > OK 

 Select the Cursor Value tool and click-on the “Link Views” and the “Display 
 information for all Views” icons located along the top of the tool. 

Question 3: With the Cursor Value tool, Click-on a light brown – light orange agricultural 
field (fallow – no vigorous crops growing) in the color IR in View 1.  The data values for 
each type of image are listed in the “Data:”  entry space of the Cursor Value window.  
Write the data values you find for the same feature in the table below  

          
    

 

 

 

 

View Type of Image Data Value (brightness) 

View #1 Color IR  

View #2 Hue  

View #3 Saturation  

View #4 Intensity (Value)  



5 
 

5 Introduction to Remote Sensing  Principles, Interpretation, and Applications 
F. F. Sabins and J.M. Ellis, 2020, Waveland Press.    Contact:  jellis@ellis-geospatial.com 

 

1d) We want to brighten the Saturation grayscale image, but we cannot use the “Linear 
1%” because that would take the darkest 1% of the pixels and turn them black.  

 Highlight View 3 (Saturation)  >  Zoom to Full Extent  > Change the contrast-
 stretch from “Linear 1%” to “No stretch” 
 Open the “Histogram Stretch” 
 Move the Histogram away from View so you can see how the brightness 
 changes in the Saturation image as you send bright pixels to pure white (1.0) 

 Drag the maximum vertical slider (right side of the histogram) to the left so 
 that 2% of the pixels are brightened to 1.0.  (98% of the pixels are to the left 
 of the vertical slider).  The brightness value should be 0.8. 
 
NOTE:  The bright red, color IR pixels in the irrigated fields may be oversaturated and 
blend together with this saturation stretch (a visual loss of information).   

 Now we want to save the brightened Saturation grayscale image. 
 File > Export View > Image File  >  Ensure “Full” is active  >  
   Accept the other Defaults  >  
 
 Name the file “Sat_5pct_brighter_ENVI”  >  Display Results > OK 

 Press on the “+” sign next to the brighter Saturation image (.dat format) in the 
 Layer Manager View 3 list 
  Unfortunately, ENVI created a 3-band grayscale image when we only  
  want 1 band in the grayscale image!!  This is a bad software shortcoming. 
  
 “We must save our brightened grayscale Saturation image as a NEW, 1-band 
 grayscale image! 

 File > Save As  >  Save As (ENVI, NITF….)” 
 The “Data Selection” window pops-up.  Ensure our brightened Saturation 
 image is selected. 

 Click on “Spectral subset” button  >  The Spectral Subset window pops-up. 
 Select “Band 2” > OK  > OK    (all 3 bands are identical – so pick any one) 
 
 The “Save File as Parameters” window pops-up. 
  Name file “Sat_2pct_brighter_1band”    >  Check “Display results” > OK 

 Uncheck the older files in View #3 so only our “Sat_2pct_brighter_1band”    
  is checked.  >  



6 
 

6 Introduction to Remote Sensing  Principles, Interpretation, and Applications 
F. F. Sabins and J.M. Ellis, 2020, Waveland Press.    Contact:  jellis@ellis-geospatial.com 

 

1e)  Right-click on the “Sat_1pct_brighter_1band”   file in the Layer Manager. 
 > View Metadata > Raster tab 
 Our brightened, 1-band saturation image is a Byte data type.  8-bit.  DN 
 brightness ranges from 0 to 255.   
 
 Look at the histogram brightness values with the Histogram Stretch tool. 
  Brightness ranges from 0 to 255.  (see all the pixels at 255 on the right  
  vertical axis – we sent 5% of the pixels to pure white) 
BUT our Saturation image in IHS color space was a float (decimal) grayscale image 
with brightness DNs that ranged from 0 to 1. 

1f) So we have to convert our 8-bit image to a float image with DN range from 0 to 1. 
 ENVI Toolbox > Raster Management > Stretch Data 
 The “Data Stretch Input File” window pops-up. 
 Ensure our new 1-band Saturation .dat file is selected. > OK 

 The “Data Stretching” window pops up   
 Accept defaults. 

  Fill in the “Output Data Range” as Min = 0 and Max = 1 
  Data Type should be “Floating Point”   
   name the new grayscale image “Sat_2pct_brighter_1band_float0-1” 

    (see filled-in menu below) 

  > OK 
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1g)  Uncheck other files in View #3.   Only our new float grayscale Saturation image 
should be displayed and checked in the Layer Manager  
  
 View metadata for our new float image.  >  Close 
 Look at the histogram with the Histogram Stretch tool –  
  we can see 0 to 1 on brightness axis!! 

 We have increased the mean brightness and the standard deviation of the 
 saturated grayscale image by our 2% clip of the brightest pixels.   
 The original Saturation image had a mean of 0.21 and a StdDev of 0.19 
 
Question 4:  What is the mean and StdDev of the stretched saturation grayscale image? 
  (Hint:  Quick Stats has the answer).   This confirms numerically what we  
  see visually between the original and stretched saturation image. 
 
1h) Now we will combine our Hue, Intensity, and our brightened float 0-1 Saturation 
image and transform this new IHS combination into a hopefully much more vibrant color 
IR image!   
       ENVI Toolbox > Transform  > Color Transforms > HSV to RGB Color Transform 
 The HSV to RGB Input Bands window pops-up 

 The “H” is filled with our “ASTER IHS” Hue Band 1 
 The “S” is filled with our new brighter, float, 0-1 Saturation image at the top of  
  the list   (“Sat_5pct_brighter_1band_float0-1”) 
 The “V” is filled with our ASTER IHS” Val Band 3   > OK 

 Name the transformed RGB color IR image “ASTER_my_sat_str_ENVI” 

1i) The new color IR image in View #3 is much brighter and vibrant compared with our 
original color IR image in View #1!!  Success!!  
 To make a useful GIS geoTIFF of the brighter Color IR image in View #3 
  File > Export Selected Layer to TIFF >    
  name “ASTER_CIR_my_sat_str_GIS”    click “Display result” 

1j) After all that work, let’s save a chip view of the brighter Color IR image for the 
instructor.   
 Zoom to Full Extent > File > Chip View To… >  File >  Select JPEG 
 Name your output “YourName_ASTER_CIR_my_sat_str” 

  No need to display result   >OK 
 
 Upload the jpg to the instructor. 
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2) Image Sharpening 
This will be a short, simple exercise using DigitalGlobe’s high resolution satellite 
imagery over Tokyo.  In almost all cases a panchromatic (grayscale) image is acquired 
with higher spatial resolution compared with the multispectral color bands that collect a 
narrower wavelength range within a larger pixel.   The pan and multispectral bands are 
collected at the same time, so alignment/registration issues are minimized. 

Start up a new ENVI display.  The data are in “Ch_4_Other_MSS_Satellites” folder, 
inside the “High_resolution_Satellites” subfolder and its “Worldview-3-pan-MSS_Tokyo” 
folder. 
 
 Read the pdf description of the awesome Worldview-3 satellite is in the Tokyo 
 folder. 

 File > Open   drive to the Tokyo folder described above 
 Select  “Tokyo_WV-3_30cm_panchromatic_GIS” and  
   “Tokyo_WV-3_4-bnd_120cm_11-bit_MSS_GeoTIFF” 

 Views > Two Vertical Views 
 Drag the pan image into View #2  > Remove the pan image in View #1. 
  
 Views > Link Views > Link All > OK 
 Zoom to Full Extent   >  Contrast stretch 
 Pan around and zoom in and out –  
 Zoom in to the baseball field in the lower portion of the image. 
  Do you see a difference in the level of detail between  
              the 120 cm color and 30 cm pan images? 
 
NOTE:  30 cm is the highest spatial resolution allowed by the U.S. government for 
civilian applications at this time (April 2019) Brighten both Views with “Linear 2%” 
 Open the “Data Manager”    
  DigitalGlobe’s multispectral band sequence is:  
   Band 1, 2, 3, 4 = Blue, Green, Red, NearIR 

 Click on the “+” sign next to the multispectral data set.   
  Bands 3-2-1 are loaded as R-G-B 

Question 5:  Is the 3-band image displayed in View #1 natural color or color IR? 

 Highlight View #2 with the pan image 

 ENVI Toolbox > Image Sharpening > Gram-Schmidt Pan Sharpening 
 The “Data Selection” window pops-up 
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 Select “Low Spatial Resolution Multi Band Input File:” 
   Select the 120 cm data set  >  OK 
  
 The “Data Selection” window pops-up again 
 Select “High Spatial Resolution Pan Band Input File:” 
   Select the 30 cm pan image  >  OK 

 The “Pan Sharpening Parameters” window pops-up 
  Sensor choose WorldView-3 
  Accept Resampling Bilinear  
  Output Format TIFF (we are going to load this into GIS) 
  Name  “Your Name_pan-sharp_WV3_GIS” 
  check Display result    > OK (The filled in menu is shown below) 

 

 The fusion or pan-sharpening process can take a long time.  There is an 
 activity indicator in the lower right of the ENVI Display window. 

NOTE:  Use ENVI Help and type in “sharpening” in the Index search box.   Learn about 
the differences with the many tools ENVI offers.  

2a) move the 120 cm multispectral data into one view and in the other view display our 
30 cm pan-sharpened image.   
 Both files should default to 3-2-1 as R-G-B.  The two Views should still be 
 linked.  Contrast stretch both files with “Linear 2%” 

 Zoom to Full Extent  Evaluate the imagery and answer question 6A below. 
 Zoom-in to the in-field at the baseball stadium in the lower left corner of the  
   scene and answer question 6B below. 
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Question 6:  A. Do you see much difference in spatial detail when both the 120 cm and  
  30 cm images are Zoomed to Full Extent? 
 
  B. Describe the difference in spatial detail when zoomed-in to the baseball 
  in-field at baseball stadium. 
 
  C.  Each 120 cm pixel covers how much more area compared to each 30  
  cm pixel?  (Can answer with cm-based measurement or a magnitude  
  difference (for example, 5 x more area)  

2b) Let’s see what a color IR image looks like at the baseball field. 
 Right-click the pan-sharpened 4-band dataset in Layer Manager > 
  Change RGB Bands > select Band 4 as R, Band 3 as G, Band 2 as B > OK 

 Right-click the 120 cm,  4-band dataset in Layer Manager > 
  Change RGB Bands > select Band 4 as R, Band 3 as G, Band 2 as B > OK 

 A color IR image should be more detailed compared to a color image 
 because the long wavelength Near IR band is not scattered as much as the 
 short wavelength Blue band by the atmosphere. 

 Zoom out and then zoom in to the tennis courts in the lower right portion of 
 the scene.  The WorldView-3 imagery is discussed and the tennis court 
 features are interpreted in the textbook’s Figure 4-9.   
 
 Do you see a remarkable difference in clarity between the 30 cm Color  IR 
 image and the 120 cm color IR image? 

If you have time, try out the other image-sharpening algorithms.  The difference in 
colors and sharpness with different algorithms can be significant.   
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Lab 8  RGB-IHS-RGB and Image Sharpening     Name: 

Upload the following files to the instructor: 
 
 (1j) “YourName_ASTER_CIR_my_sat_str”  .jpg 
 
 

Question 1:  A. Discuss the differences in the colors between the original ASTER CIR  
   image and the ENVI saturated stretched CIR image.    

   B. Do you prefer the “instant” ENVI saturation stretch or your 2%   
   saturation stretch that you  created at the end of this exercise?  (page 7)   
   WHY? 

 
Question 2:   A. Which HSV grayscale image has a significant skew to the left (meaning 
   most pixels are dark)? 

   B) What is the range of brightness for Hue pixels? 

  C) What is the range of brightness for Intensity (Value) and Saturation 
   pixels? 
  
  D) What is the brightness value on the horizontal axis of the Saturation 
  (View 3) histogram when you slide the vertical line to the left  so that 95% 
  of the pixels are below that brightness value  (Hint:  look above the vertical 
  line for the data brightness value and percentage of pixels to the left of the
  vertical line).   
 
  
Question 3: With the Cursor Value tool, Click-on a light brown agricultural field (fallow – 
no vigorous crops growing) in the color IR in View 1.  The data values for each type of 
image are listed in the “Data:”  entry space of the Cursor Value window.  Write the data 
values you find for the same feature in the table below  

          
    

 

 

 

 

View Type of Image Data Value (brightness) 

View #1 Color IR  

View #2 Hue  

View #3 Saturation  

View #4 Intensity (Value)  
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Question 4:  What is the mean and StdDev of the stretched saturation grayscale image? 
  (Hint:  Quick Stats has the answer). 
   

Question 5:  Is the 3-band image displayed in View #1 natural color or color IR? 
 

Question 6:  A. Do you see much difference in spatial detail when both the 120 cm and  
  30 cm images are Zoomed to Full Extent? 
 
  B. Describe the difference in spatial detail when zoomed-in to the baseball 
  in-field at baseball stadium. 
 
  C.  Each 120 cm pixel covers how much more area compared to each 30  
  cm pixel?  (Can answer with cm-based measurement or a magnitude  
  difference (for example, 5 x more area) 
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Lab 9  Unsupervised Classification 
Utilizes Textbook’s Remote Sensing Digital Database: Chapter 3 data. 

The objectives of this lab are to learn about unsupervised classification techniques, 
including naming classes, combining classes, converting the raster thematic map to a 
GIS shapefile, and the importance of apply a mask to improve your classification map.  
The tasks are done with tools in the ENVI Toolbox. 

Two digital files are to be uploaded to the instructor and five questions are to be 
answered on the last page of this handout. 

1) Unsupervised Classification 

We will return to the Exumas Islands in the Bahamas where in Lab 4 we created a Mask 
to eliminate the impact of water on our image processing of the islands.  We want to use 
the spectral characteristics of the six Landsat VNIR-SWIR bands to generate an 
unsupervised classification map of the islands. 

Unsupervised classification uses the computer program to cluster the pixels into natural 
groupings based on the spectral characteristics of the pixels with no direction from the 
analyst, except for setting basic parameters such as number of classes, number of 
iterations performed by the program, and minimum number of pixels per class. The 
analyst leverages his/her experience and knowledge about the features being classified 
so a land use/land cover name can be attached to each class and classes can be 
combined.  Unsupervised classification is a very fast way to evaluate the spectral 
richness and mapping potential of your multispectral or hyperspectral data. 
 
The textbook Chapter 9 has an extensive discussion on unsupervised classification. 
 
The multispectral data is located in the “Remote Sensing Digital Database \ 
Ch_3_Landsat” folder, inside the “Plate_9_Bathymetry” subfolder. 
 
1a) Start-up a new ENVI display.   File > Open     drive to the  
 “Plate_9_Bathymetry” folder and  
 Open the “Original_Landsat_Data” folder >  
 Select > “Exumas_Bathy_1984_Landsat_6-band_clip_GeoTIFF.tif”  > Open 
 A natural color image should display (TM bands 3-2-1 as R-G-B) 
 
 Zoom to Full Extent  >  Contrast stretch “Linear 2%” 
 Open the “Data Manager” to see the six bands. 
 Use the Data Manager to display a total IR color composite (4-5-6 as R-G-B) 
  and color IR (4-3-2 as R-G-B)   > Stretch both “Linear 2%” 
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1b) We will first do an unsupervised classification on the entire 6-band scene. 
ENVI Toolbox > Classification > Unsupervised Classification > IsoData Classification 
 
ISODATA unsupervised classification calculates class means evenly distributed in the 
data space then iteratively clusters the remaining pixels using minimum distance 
techniques. Each iteration recalculates means and reclassifies pixels with respect to the 
new means. 
 
 The Classification Input File window pops-up > Select the 6-band clip > OK 
 The ISODATA Parameters window pops-up (see below) 

 
 We will accept all the defaults,  
  except change the “Maximum Iterations” from “1” to “10”. 
 
 Click-on Help to learn what each parameter means in the ISODATA menu.   
  (this is highly recommended for class discussion in the lab) 
 
 Name the output file “Exumas_unsup_land-water”  > OK 
  The ISODATA Classifier window pops-up and you will see the iteration count  
  being posted.  The classification stops at the 10th iteration. 

 Examine the classification map.  Use the  “Swipe” tool to compare the 
 classification map with the color images. 
 
Question 1:   How many classes do you see on the islands? 
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1c) The ocean water and seafloor captured most of the classes in our map.  We have 
generated a very poor (unacceptable) spectral classification map for the islands.   

 Remove our very poor classification map from the Data Manager. 

Now we will apply the water mask that we built in Lab 4.  The water mask for this scene 
is in the Lab_9_Data folder. 

 First we will load our water mask into the Layer Manager.  
 File > Open > drive to the “Lab_9_Data” folder >  
 Select “Water_Mask_0-1_Off” > Open 
 The Black and White Mask is displayed.   
 Use the “Cursor Value” tool to query the  DNs for the black and white pixels. 

Question 2:  What are the DN values for Black and White pixels in the Mask? 

        ENVI Toolbox > Classification > Unsupervised Classification > IsoData Classification 

 The Classification Input File window pops-up > Select the 6-band clip 
 Click-on the “Select Mask Band”   
 Select  “Mask Band” under the “Water_Mask_0-1_Off” file name   > OK  > OK 
 
 The ISODATA Parameters window pops-up (see picture above) 
 We will accept all the defaults,  
  except change the “Maximum Iterations” from “1” to “10”. 
 
 Name the output file “Exumas_unsup_water-masked”  > OK 
  The ISODATA Classifier window pops-up and you will see the iteration count  
  being posted.  The classification stops at the 10th iteration. 

 Examine the classification map.  Use the  “Swipe” tool to compare the 
 classification map with the color images.   Y 
  
 You may see the new classification map swiping with the B-W water mask 
 image.  Move the “Water_Mask_0-1_Off” to the bottom of the files listed in the 
 Layer Manager so that the color IR or other color image directly under the new 
 classification will be displayed in  the Swipe tool. 

 Zoom-in on the larger islands. 

1d) Let’s look at the statistics of this classification map.   
 Right-click on the “Classes” folder in the Layer Manager > 
 Select “Statistics for All Classes”  > the “Data Selection” window pops-up > 
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 Select our new classification map “Exumas_unsup_water-masked”  >  OK 

 The “Classification Statistics View” window pops-up 

Question 3:   A. What percentage of our classification map is unclassified (this is the  
  area in the scene covered by our water mask)? 

  B. Which class on the islands has the highest percent coverage?  

  C. How many pixels are in the class with the highest percent coverage? 

1e) Let’s evaluate the patterns on the classification map with different color image band 
combinations (and contrast stretches) to help us interpret the features on the map 

 Let’s start with the color IR image in View #2 and link the two views to help 
 interpret the classification map.   Views > Two Vertical Views >  
  Drag the color IR image in View #2 in the Layer Manager 
  Views > Link Views > Link All > OK 
  Contrast stretch the Color IR image with different stretches. 

 Right-click on the “Classes” folder in the Layer Manager > 
 Select “Edit Class Names and Colors”  >  
 the “Edit Class Names and Colors” window pops-up     (see below) 

 

 Use the “Cursor Value” tool to query the Class number.  In the “Cursor Value” 
 tool menu Click on the “Link” and the “Display Information for Views” icons 
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 Click on different colors in your classification map with the “Cursor Value” tool to 
 decide what feature they represent.   
 Zoom-in and  pan to different islands.    
 Use the Flicker tool to compare classified map pixels to color image pixels. 
 
 Change the band combinations in View #2 and try different stretches on the 
 images that bring out different patterns  - these patterns may correlate with your 
 classification map 

NOTE: This is a very good class exercise with the instructor writing the class answers 
on a White Board so everyone participates in the decision-making.  

 Build a small chart and write down what you think the class represents. 

 

 a) Where do you see Class 5, 6, 7, 9, and 10 pixels most often?  

 b) There are only 378 pixels in Class 8 (dark green).  Tough to find!  Do you see 
 this class in areas with very bright white sand?  Maybe this is dry sand – sand on 
 a topographic high? 

 c) In the color IR and total IR images is there a trend in vegetation vigor (redder 
 pixels may indicate more vigorous vegetation, denser vegetation cover, or 
 different plant communities)  that you can correlate with the patterns of Class 2 
 (green), Class 3 (blue), and Class 4 (yellow) on the islands? 

Question 4:  What types of other imagery, maps, and other ancillary information would  
  help you interpret the classes with more confidence?   

  

 

                   Class interpretation 
 
 
1. Mask 
2. Saturated/underwater beach sands 
3. 
4. 
5. 
6. 
7. 
8. 
9. 
10. 
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1f) Let’s name the classes and combine those that maybe represent the same feature. 

 We will use the  “Edit Class Names and Colors” menu. 
 In the “Class Name” window in the center of this menu, select Unclassified > 
  Edit:  enter the name “Water”  and follow this with the next 3 entries 

  Unclassified = Water 
  Class 1 = Vigorous vegetation 
  Class 2 = Medium vegetation cover 
  Class 3 = Sparse vegetation    > OK    You will see the new names show  
   up in the classification map legend (see below) 

  

 To open up the Edit menu again,  
  Right-click on the “Classes” folder in the Layer Manager > 
  Select “Edit Class Names and Colors”  >  
  the “Edit Class Names and Colors” window pops-up      
  
  Change the name of Class 8 to “Dry sand on elevated beach” > OK 

1g) Now let’s combine classes 5, 6, 7, 9, 10 into one class. 

 
 ENVI Toolbox > Classification > Post Classification > Combine Classes 
 The “Combine Classes Parameters” window pops-up. 

 We want to sequentially Select Class  6, 7, 8, 10 in the “Select Input Class” 
 list and assign each one to the “Ouput Class” 5.  After we fill in the Input and 
 Output windows we press “Add Combination” and the combined classes  
 show up in the bottom window.  (see below)    
 
 Your Combine Classes Parameters menu should look like is shown below. 

 



7 
 

7 Introduction to Remote Sensing  Principles, Interpretation, and Applications 
F. F. Sabins and J.M. Ellis, 2020, Waveland Press.    Contact:  jellis@ellis-geospatial.com 

 

  > OK 

 The “Combine Classes Output” window pops-up. 
  Remove Empty Classes?  Yes 
  Name the output file “combined beach sand”    (see below) 

  > OK    

 Automatically ENVI displays the classification map with the updated legend in the 
 Layer Manager (see above). 

1h) Now we want to rename “Class 5” to “beach sand” and change colors on our map. 
 To open up the Edit menu again,  
  Right-click on the “Classes” folder in the Layer Manager > 
  Select “Edit Class Names and Colors”  >  
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  the “Edit Class Names and Colors” window pops-up      
  Rename “Class 5” as “beach sand” 
 
  Let’s change colors in the lower window 
  Just select the class and  touch the color box that appears 
  Check “Display Result”   > OK 
 
1i) The new legend pops-up in the Layer Manager.  Let’s rename this map 
 Right-click on “combined beach sand” > “Rename Item” >  
  Rename “Exumas Landsat Land Cover Map”  > click on Green Checkmark 
 Your map name and legend should look like this in the Layer Manager 

 

1j) Our map has a “salt and pepper” appearance with isolated pixels and narrow strings 
of pixels.  Land cover maps are typically generalized with a “Majority” filter (see textbook 
Chapter 9 for explanation).  The Majority filter provides a more visually appealing map. 

     ENVI Toolbox > Classification > Post Classification > Majority/Minority Analysis 

 The Majority/Minority Parameters  
 window pops-up. 

 Select All Items 
 
 Accept Defaults 

 Name the output file 
       “Exumas Landcover Map_maj” 
 > OK 
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 The majority-filtered classification map is displayed on top of the original “salt and 
 pepper” map. 
 
 Use the “Flicker” tool and zoom in on larger islands to compare the two maps. 

Question 5:  Which map (original or majority-filtered) do you like the most?   Why? 

 In the Layer Manager, select (highlight) the majority filtered classification map. 

  File > Chip to File > File   The “Chip to File Parameters”  window pops-up   

  Select output format “JPEG” 

  Name the output “Your Name_unsup map_maj” 
  uncheck the Display result  > Save 

  Upload the jpg file to the instructor. 

1k) Raster classification (thematic) maps are converted to vector polygon maps to make 
them more useful in GIS applications.  You can add more attributes to the vector 
polygon map and it is a much smaller file compared to a raster thematic map. 

First we convert the raster map to an ENVI .evf vector file, and then we convert that .evf 
file into the universal shapefile format (.shp). 

      ENVI Toolbox > Classification > Post Classification > Classification to Vector 
 Select the Input file “Exumas_Landcover_Map_maj”  > OK 
 Select All Items in the “Raster to Vector Parameters” menu that pops-up 
  Accept Defaults (Output as Single Layer) 
 Name the ENVI vector file “Exumas_Landcover_Map_maj_evf”  > OK 

    The evf vector file may show up in the Data Manager.  Load into the View. 

     ENVI Toolbox > Vector > Classic EVF to Shapefile 
 The “Select Input EVF files” menu pops- up.   
 Locate and select your “Exumas_Landcover_Map_maj_evf.evf   File  > Open 
 
 The “Output EVF Layer to Shapefile” window pops-up. 
 Name the shapefile “Exumas_Landcover_Map_maj_vec_GIS”    > Open    > OK 

 

The .evf and .shp vector files should look like this in the folder where you are saving 
images and these vector files. 
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1l)  With ENVI, you can superimpose the GIS shapefile on your final classification raster 
map.   
 File > Open    drive to your folder that has the shapefile 
 > select the file that  has “.shp” as the type   > Open 

 Right-click on the shapefile in ENVI’s Layer Manager > View/Edit Attributes 
  Use the slider to scroll across the fields in the attribute table. 

 Turn off (unclick) all the layers in the View with the shapefile 
  Zoom to Full Extent 
 
 In the Layer Manager, select (highlight) the majority filtered classification map. 

  File > Chip to File > File   The “Chip to File Parameters”  window pops-up   

  Select output format “JPEG” 

  Name the output  In the Layer Manager, select (highlight) the majority  
  filtered classification map. 

  File > Chip to File > File   The “Chip to File Parameters”  window pops-up   
  Select output format “JPEG” 
  Name the output “Your Name_unsup map_maj_shp” 
  uncheck the Display result  > Save 

  Upload the jpg file to the instructor. 

If you have access to a GIS, display your final, majority-filtered classification raster map 
and the vector shapefile.  Right-click on the shapefile and look at the attributes. 

You can import your shapefile into Google Earth and compare you map to the imagery 
Google Earth streams over the Exumas Island 
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Lab 9  Unsupervised Classification           Name: 
  

Upload the following files to the instructor: 
  
 (13j) “Your Name_unsup map_maj”   jpg 
  
 (1l) “Your Name_unsup map_maj_shp”   jpg 
 
 

 
Question 1:   How many classes do you see on the islands? 
 

Question 2:  What are the DN values for Black and White pixels in the Mask? 
 

Question 3:   A. What percentage of our classification map is unclassified (this is the  
  area in the scene covered by our water mask)? 

  B. Which class on the islands has the highest percent coverage?  

  C. How many pixels are in the class with the highest percent coverage? 

 

Question 4:  What types of other imagery, maps, and other ancillary information would  
  help you interpret the classes with more confidence?   

 

Question 5:  Which map (original or majority-filtered) do you like the most?   Why? 
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Lab 10  Supervised Classification 
Utilizes Textbook’s Remote Sensing Digital Database: Chapter 9 data. 

The objectives of this lab are to learn how to build training sites, understand the 
parameters that impact the accuracy of supervised classifications, and convert your 
raster classification map into a GIS vector polygon file (see Chapter 9 Digital Image 
Processing for discussion).  The classification exercise will be done on a subscene of 
the Landsat 8 image used in the textbook (see Figures 9-28, 9-29, and 9-33 and Plates 
(29 and 30). This subscene is in the Lab_10_Data folder.  The tasks we will complete 
with this lab are done with tools in the ENVI Toolbox. 
 
Two digital files are to be uploaded to the instructor and six questions are to be 
answered on the last page of this handout. 

The Landsat 8 image was acquired on September 23, 2014 of Martinez, California.  The 
non-irrigated vegetation is dry.  To successfully complete accurate supervised 
classification maps the analyst must have a knowledge of the types of features that are 
being spectrally classified.  

1) Start-up ENVI.  File > Open  drive to the Lab_10_Data folder  >  Select 
   “Martinez_Landsat8_6bnd_2PC_CLIP2_ENVI_” 

 A natural color image (OLI bands 4-3-2 as R-G-B) is displayed in View 1 
 Apply a contrast stretch to brighten the color image 

 Open “Data Manager”  You see 6 VNIR-SWIR bands and two PC images (PC3  
     and PC4) 
 Let’s look at all the bands.   
 Right-click on the 8-image Landsat file in the Layer Manager > Band Animation 
  Slow the flicker down…1 second delay maybe. 

Question 1:  Which of the 8 grayscale images are most different? 

2) Let’s look at the complete statistics between the 8 grayscale images 
 ENVI Toolbox > Statistics > Compute Statistics  
  Click-on  “Histograms” and “Covariance”   Output to the Screen  > OK 

 Review the Correlation Matrix while looking at the “Band Animation” 
 
Question 2:  What features on the ground lead to the negative correlation between PC 4 
image (“Band 8”  in the correlation table) and Bands 1, 2, 3, and 4  (Hint: opposite 
graytones in the images  - one has bright pixels and the other has dark pixels for the 
same feature). 
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In the upper left corner is the “Select Plot” drop-down menu.  Select “Histogram  1” 
first, the “Histogram 2” and then “Histogram 3”. 
 
Question 3:  Are these three visible band images normal or slightly skewed to the left? 

 In the upper left corner is the “Select Plot” drop-down menu.  Select “Histogram 
 4” first, the “Histogram 5” and then “Histogram 6” – the 3 reflected IR bands. 

Question 4:  What is unique about the histograms for the reflected IR bands compared  
  to the visible light bands? 

3) Let’s analyze the Landsat scene and define 8 land cover classes.  We will then select 
training sites for each class using heads-up digitizing of polygons with ENVI’s ROI 
(regions of interest) tool.  8 is an arbitrary number for this lab.  (17 training sites were 
developed for the textbook example that used a larger Landsat scene of this area). 

 What land cover classes do you find on the image?   
 Classes should be spectrally unique. 
(This is a good exercise class exercise with the instructor copying the land cover 
classes on a White Board and everyone voting for the top 8).  

 Split the ENVI display into 4 Views and fill each with a different color composite 
 using the Data Manager and highlighting (selecting with your cursor) each View 
 to be filled. 
 Views > 2X2 Views 
 View #2 load a color IR image 
 View #3 load a enhanced color (Bands 7-5-3 as R-G-B) 
 View #4 load PC4-PC3-Band 6 as R-G-B 
 Link the Views     Views > Link Views > Link All >  OK 
 Zoom to Full Extent   >  Zoom–in  and pan around 

 Placeholder Classes for processing in this exercise**  
  1) River water 
  2) Ponded water 
  3) Irrigated grass 
  4) Dry grass 
  5) Wetlands 
  6) Suburbs 
  7) Industry 
  8) Trees (on western slopes with dry grass and deep shadows in valleys) 

 ** OK if class develops more or less classes and different classes for their 
 processing 
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4) Now we will generate training sites (ROIs) for the 8 land cover classes. 

To give yourself more room to draw training sites (ROI polygons), let’s Remove Views 
2, 3, and 4.  Right-click on Views 2, 3, and 4 in the layer Manager > Remove View 
 
NOTE:  ROIs should be neatly drawn so that the pixels inside the ROI are “pure” for the 
class being defined.  Zoom-in and draw the polygon over only those pixels that correlate 
with the class being mapped.  You should have more than one polygon for each training 
site.  Try to draw ~5 polygons over pixels that represent a class. 

Open the ROI tool (icon located at the top center of the ENVI display window) 

 

 Click on the “New ROI” icon, change name from ROI #1 to “River water”. 
  We will accept default polygon drawing tool.  
 The “River Water” ROI is displayed in the Layer Manager and in the Data 
 Manager. 

 
 Zoom-in to the feature of interest, and draw the around the pixels of interest. 
 When done drawing the polygon, double-click your mouse, the polygon line will  
 join both ends to create a closed polygon that is filled with a solid color. 

 The ROI tool keeps track of the number of polygons in your class  
 (“Record Count”).  If you want to delete one of the polygons just use the counter 
 with arrows at the bottom of the ROI tool to bring up the polygon and then you 
 can that specific polygon using the  “Delete Record” tool. 
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 When done with one ROI, just click on “New ROI” and repeat the process. 

 When the “ROI Name:” turns blank while you are mapping the ROI, just click on 
 the small down-arrow on the right to have your active ROI show up again in the 
 tool.  The name field turns blank sometimes when you use the Zoom and pan 
 tools.  
 
 Make the polygons large in the suburbs, industry, dry grass, and river water so 
 the program has the range of spectral values in the ROI. 

As an example of training site polygons for the 8 ROIs, see below:

  

 Let’s send our training sites to the instructor. 

 File > Chip View To > File   Choose Output Format  “JPEG” 
 Name the file “YourName_TrainingSites” 
 
 Upload the jpg to the instructor 

 Now we want to save the ROI file. 
 Regions of Interest (ROI) Tool > Save As > Select All Items 
 Name the ROI file “Landsat8_Martinez_8_ROIs” 

5) Now that we have our training sites, we can start the supervised classification 
program. 
ENVI Toolbox > Classification > Supervised Classification >  
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       Maximum Likelihood Classification 
` The “Classification Input File” window pops-up. 
 Select our “…6bnd_2PC” dataset > OK 
 
 The “Maximum Likelihood Parameters” window pops-up  > Click on Help for  
 excellent information on the Maximum Likelihood algorithm. 

 Select All Items > Accept Defaults except “Output Rule Images? Change to “No” 
 Name the output file “Landsat_Martinez_8class_Sup” 

 The computer crunches the numbers and displays your supervised classification 
 map 

NOTE:  Maximum likelihood classification assumes that the statistics for each class in 
each band are normally distributed and calculates the probability that a given pixel 
belongs to a specific class. Unless you select a probability threshold, all pixels are 
classified. Each pixel is assigned to the class that has the highest probability (that is, the 
maximum likelihood). 
The many other classification algorithms have advantages and disadvantages, just as 
the Maximum Likelihood does.  Open Help and search for “Classification workflow”  
Read about the different methods and review the “Classification Tutorial” 
 
6) Your classification map could look like this: 

 
This is a raster thematic map.  It has 9 classes (one is “unclassified”). 
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Let’s look at the map’s statistics.   
Right-click on the “Classes” folder > Statistics for All Classes…. 
The “Data Selection” window pops-up       Select our 8 class map > OK   
Scroll down to the “Class Summary” table (see below) 
 

 

 
Every pixel was classified. 
   
The largest class is “Industry” 
 
The smallest class is “Irrigated 
grass” 
 

 
7) As with the unsupervised classification, let’s minimize the “salt and pepper” 
appearance of this map by running a 3 X 3 majority filter across the scene. 
 
ENVI Toolbox > Classification > Post Classification > Majority/Minority Analysis 
 Choose the 8-class supervised map > Select All items > Accept Defaults  
 Name the output file: “Landsat_Martinez_8class_Sup_maj”   > OK 
 
The generalized classification map displays on top of the raw map.  Swipe to compare. 
 Let’s look at the generalized map’s statistics.   
 Right-click on the “Classes” folder > Statistics for All Classes…. 
 The “Data Selection” window pops-up    Select our 8 class Majority map > OK   
 Scroll down to the “Class Summary” table (see below) 
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Question 5:  What class lost the highest percent of pixels and what class gained the  
  highest percent of pixels when the majority filter is applied to the original  
  classification image? 

8) Move the color Landsat image beneath the majority-filtered classification map in the 
Layer Manager so you can compare with swipe and fade tools 
 Swipe the generalized map over the color Landsat image 
  (you 
 Fade the generalized map over the color Landsat image (Blend View tool) 
  These tools seen uncontrollable?!  Too fast for analysis? 
 
 Stop the Blend Tool.  Use the manual slider for transparency in the upper right 
 corner of the ENVI display.  Fade the map on and off to see what classes fit well, 
 and what classes have errors (misclassified pixels) 

 To provide colors on the 8 classes that are easy to understand (i.e. dark green 
 for trees, bright green for irrigated grass, blue for river water, etc.) Right-click on 
 the majority classes folder in the layer manager > Edit Class Names and Colors 

 Display the Landsat as a grayscale image (OLI band 5 (SWIR1) is good) to 
 provide an easy-to-understand backdrop to the faded/partially transparent color 
 classification map. 

Question 6:  A. What class(es) do you interpret as least accurate? 
 
  B. What class(es) do you interpret as most accurate? 
 
  C. Why do think some classes are more accurately classified compared to 
  others? 

9) As with the unsupervised classification, this ENVI raster thematic image is not easily 
viewed by others.  So we are going to convert it to an ENVI polygon vector file (.evf) and 
then convert the .evf to the universal .shp file.   

      ENVI Toolbox > Classification > Post Classification > Classification to Vector 
 Select the Input file “Landsat_Martinez_8class_Sup_maj”     > OK 
 Select All Items in the “Raster to Vector Parameters” menu that pops-up 
  Accept Defaults (Output as Single Layer) 
 Name the ENVI vector file “Landsat_Martinez_8class_Sup_maj_vec”   > OK 

If the .evf file does not automatically load into the Layer Manager, File > Open >  “…evf” 
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The .evf vector file should be displayed in the View.  Turn off all the raster layers. 

     ENVI Toolbox > Vector > Classic EVF to Shapefile 
 The “Select Input EVF files” menu pops- up.   
 Locate and select your “Landsat_Martinez_8class_Sup_maj_vec.evf”   
   File  > Open 
 The “Output EVF Layer to Shapefile” window pops-up. 
 Name the shapefile “Landsat_Martinez_8class_Sup_maj_GIS”    > Open    > OK 
 
If the .shp file does not automatically load into the Layer Manager, File > Open >      
  “Landsat_Martinez_8class_Sup_maj_GIS.shp” 

10)  Let’s display the hillshade DEM of this Martinez area under our land cover shapefile 
in ENVI.   
 From the ENVI display window File > Open     
 Drive to the Chapter 9 folder in the Remote Sensing Digital Database and open 
 the DEM folder 

      Ch_9_Image_Processing \ Plates 29-30_Spectral_Classification \ DEM 
 
Select “DEM_Martinez_GIS_hs045_30elev.tif”  > Open 
 The hillshade DEM displays in the ENVI View. 
 Drag the hillshade DEM below the landcover shapefile so the vectors show up on 
 top of the DEM. 

Let’s send this display of vector land cover map over the hillshade DEM to the instructor 
 File  > Chip View To  >  Image     Select “JPEG”   uncheck “Display result” 
  
 Name the vector map + hillshade DEM graphic  
 “YourName_landcover_hs-DEM” jpg 

11) If you have access to Google Earth,  import the land cover shapefile (see below) 
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 Select and right-click on the imported shapefile in the Google Earth Places list > 
 Save Place As  >  Accept default name.  > Save    
  

 Your shapefile is now in the .kmz format (a universal format) 
 Upload the kmz to your instructor. 
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Lab 10 Supervised Classification                     Name: 

Upload the following files to the instructor: 
  
 (4) “YourName_TrainingSites”  jpg 
  
 (10) “YourName_landcover_hs-DEM”   jpg 
  

Question 1:  Which of the 8 grayscale images are most different? 

Question 2:  What features on the ground lead to the negative correlation between PC 4 
 image (“Band 8”  in the correlation table) and Bands 1, 2, 3, and 4  (Hint: 
 opposite graytones in the images  - one has bright pixels and the other 
 has dark pixels for the same feature). 

Question 3:  Are these three visible band images normal or slightly skewed to the left? 

Question 4:  What is unique about the histograms for the reflected IR bands compared  
  to the visible light bands? 

Question 5:  What class lost the highest percent of pixels and what class gained the  
  highest percent of pixels when the majority filter is applied to the original  
  classification image? 

Question 6:  A. What class(es) do you interpret as least accurate? 
 
  B. What class(es) do you interpret as most accurate? 
 
  C. Why do think some classes are more accurately classified compared to 
  others? 
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Lab 11   Hyperspectral 
Utilizes Textbook’s Remote Sensing Digital Database: Chapter 9 data. 

The objectives of this lab are to become familiar with hyperspectral data, learn about 
spectral libraries and different methods for processing hyperspectral data.  The tasks 
we will complete with this lab are done with tools in the ENVI Toolbox.   

Two hyperspectral datacubes are available to be analyzed. The first datacube has VNIR 
data and is analyzed for vegetation.  The second datacube has SWIR data and is 
processed for minerals.  Different image processing tools are utilized with each 
datacube.  Lab time may be a limiting factor for both datacubes to be processed and 
analyzed in one session.   

Therefore, this lab exercise is clearly separated into two sections – with the first section 
utilizing the hyperspectral VNIR datacube (pages 2 – 8) and the second section 
analyzing the hyperspectral SWIR datacube (pages 9 – 25).  

The VNIR vegetation section has two digital uploads to be uploaded to the instructor 
and six questions to be answered on the last pages of this handout (page 26).  The 
SWIR geologic section has one digital file to be uploaded to the instructor and eleven 
questions to be answered on the last pages of this handout (pages 27 and 28). 

The VNIR vegetation section includes the following image-processing tasks: 
 - Normal and continuum removed spectral profiles. 
 - Using the chlorophyll absorption feature to document vegetation vigor. 
 - Editing spectral profiles for presentation. 
 - Building a 3D cube. 
 - Minimum Noise Transform (MNF). 
 - Unsupervised classification of select MNF bands. 

The SWIR geologic section includes the following image-processing tasks: 
 - Using the USGS Spectral Library converted to the 50-band SWIR dataset. 
 - Comparing spectral profiles at select pixels with published mineral maps. 
 - Using the Spectral Library Viewer and adding/deleting files. 
 - Using ENVI’s “Spectral Hourglass Wizard”. 
  Data dimensionality determination,  
  Pixel Purity Index (PPI),  
  n-Dimensional Visualization, 
  Spectral Analyst tool. 
  Spectral Angle Mapper (SAM) classification. 
  SAM Rule images. 
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Hyperspectral VNIR Datacube for Vegetation Analysis   
The first datacube was acquired over semi-arid terrain of the High Plains in central 
Colorado.  This datacube contains 128 bands of reflected VNIR wavelengths.  The data 
is courtesy of Galileo Group, Inc.  A white paper by Galileo is included in the folder 
containing the datacube – it is highly recommended that you review this 22-page 
overview of commercial hyperspectral capabilities and case histories. 

The datacube is in the Chapter 9 folder of the Remote Sensing Digital Database.  The 
subfolder “AISA_VNIR_Hyperspectral” contains the datacube, a USGS topographic 
map, and metadata. 

1) Start-up ENVI   > drive to the “Ch_9_Image_Processing \ AISA_VNIR_Hyperspectral” 
 folder   >      Select “AISA_Semiarid_Hyperspectral_VNIR_ENVI”   and  
    “ESRI  USGS TOPO Basemap_GIS.tif  > Open 
 
 We use the ENVI version of the datacube because it displays the center 
 wavelength of each band.  The GeoTIFF version does not and you have to refer 
 to the folder named  “Table of AISA VNIR bands and wavelengths”. 

 The datacube automatically opens as a color IR image  
  (Band 90 - Band 65 – Band 38 or NIR-Red-Green as R-G-B) 

 Drag the topo map beneath the color IR image in the View. 
 Zoom in so the color IR image fills your View. 

 Open the “Data Manager” to see the list of 128 bands with their wavelength. 

2)  Highlight (select) the hyperspectral file in the Layer Manager >  
 Display > Profiles > Spectral 
 With your cursor (the “Select” arrow is highlighted), Click-on bright red pixels and 
 note how the spectral signature of pixels remains relatively constant. 

 The units of the horizontal axis are nanometers.  The Data Value on the vertical 
 axis is a measure of brightness or reflectance. 

 Click-on the Options drop-down menu and select “RGB Bars” to see where the 
 3 bands displayed in the ENVI View are located in the VNIR spectrum. 

 Click-on the small black triangle in the white band on the right side of the 
 “Spectral Profile” menu to display properties of the plot. 
  Scroll down the “General” and “Curve” menus. 
  You can change the symbology, name, and range of wavelengths   
  displayed with these menus.  
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 With your cursor, click on the spectral profile line to see the exact wavelength 
 and brightness (Data Value) for that part of the profile 
 
3)  Review Figure 9-37A and B and the text in the textbook’s Chapter 9. 

 Click your cursor on a brightest red pixel (most vigorous vegetation) in the scene.  
 This spectral profile is unique to vegetation. 
 
Question 1: What is the name of the unique sharp increase in brightness (Data Value) 
between 680 and 745 nanometers? 

Question 2: Why is the reflected brightness highest in the 520 – 600 nm range 
compared to the 400 – 520 nm and the 600 - 680 nm ranges? 
 

 There is another way to view spectral profiles named “Continuum Removed”.  
 This type of profile is generated by the algorithm fitting a “convex hull” arc over 
 the top of the spectrum.  The continuum removed spectral profile is very useful 
 for evaluating absorption features (depth, shape, and width). 

 Click-on the “Y: Data Value” drop-down menu at the bottom of the Spectrum 
 Profile window.  Choose “Continuum Removed” 
 The shape of the spectral profile changes to highlight absorption features. 

Question 3:  What causes the unique absorption feature for healthy vegetation that is 
between ~600 and 680 nm?  (Hint: think about what is causing the higher reflectance 
values at shorter and longer wavelengths). 
 

 The name of the deep absorption feature unique to vegetation that is revealed 
 with the “continuum removed” tool is the “chlorophyll absorption feature”.   
  
 Click-on the “Options” drop-down and select “Vegetation Index (NDVI)” 

 
Question 4:  A. What is the calculated NDVI value for your brightest (most vigorous)  
  pixel? 

  B. What is the calculated NDVI value for the gray terrain (in the color IR  
  image gray may represent dormant, dry grasses and other ground   
  vegetation)? 

  C. How did the program calculate NDVI?   
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4) Let’s move our cursor around the image clicking on five pixels that represent a trend 
from most vigorous vegetation (bright red), to less vigorous vegetation, to the gray 
terrain (dry vegetation?) to barren ground on the road (white pixels).  Place your cursor 
on a bright red pixel to start this task - the deep chlorophyll absorption feature is 
redisplayed in the “Spectral Profile” window. 

 We will stack these five spectral profiles in one window so we can compare the  
 signatures.  Click-on the icon at the bottom of the Spectal Profile window that 

 looks like a staircase    This stacking feature is only active when the icon is 
 highlighted.  

 You have to press the Shift key on your keyboard when you click on the image to 
 collect a spectral signature in order for the spectra to stack in the profile window.
 Have the Properties window (right side of the Spectral Profile window open so 
 you can delete spectra you don’t like. 

 You can edit the names of the 5 spectra, change the line thickness, and add a 
 legend to the side so that this change in a spectral signature as vegetation cover 
 becomes less vigorous or is reduced for a report.  An Example is below with the 
 Properties menu open so that you can see where some changes were made. 

                
 You can Export the spectral profiles and the legend to several different graphic 
 formats (see .png graphic below).   This makes the spectral work you have done 
 more accessible to others who don’t have or want to do image processing.  
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 For this lab, it is an option to customize your 5 spectral profiles so you can learn 
 about the symbology tools in ENVI.  Use the “Curve” tab to customize your 
 legend.  Use the “General” tab to add the legend to the Export, change line 
 thickness, etc.  The symbology work takes some time…but is worth it if you are 
 going to present your results to others. 

 Export > Image   >  Name the plot “YourName_5_Spectral_Profiles” as a .png. 

 Upload your png graphic to the instructor. 

Question 5:  Discuss in 2 or 3 sentences what happens to VNIR spectral profiles when 
you move from vigorous vegetation to no vegetation (barren terrain). 

 
5) Let’s visualize the data cube. 
 ENVI Toolbox > Spectral > Build 3D Cube  
 Select the 128 band datacube > OK 

 For the front of the datacube, let’s generate a color IR image using the same 
 bands as were automatically displayed in the View by ENVI (these three bands 
 are designated in the metadata for automatic display).  Select the following 3 
 input bands: 
  R = Band 90 
  G = Band 65 
  B = Band 38   > OK   > the “”3D Cube Parameters” window pops-up 

  Accept defaults (rainbow color scheme and spectral scale) 
  Name the visualization “Colorado_3D_cube” 

 The processing may take 1-2 minutes. 
 The 3D cube is an ENVI .img file with .hdr header.   
 This format is not useful for a report graphic.    
 Let’s save our 3D cube as a full resolution, .tif.   

  Uncheck the topo map. 
  Zoom in to the datacube so it fills your view. 
  File > Export View To > Image File      
  Ensure “Output Extent” is Current”  
  Leave “Zoom Factor” as 1.000 
  Change Output Format to “TIFF”   
  Uncheck “Display result” 
  Name the 3D cube “YourName_3D_Datacube”  > OK 
  Upload your excellent graphic to the instructor. 
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6) To help understand the richness of the hyperspectral data, we can compress the 128 
bands with an algorithm named “Minimum Noise Transform” (MNF) which is similar to 
Principal Components.   Open Help and search for  “MNF” to learn more – a lot more 
about MNF.  MNF Rotation transforms determine the inherent dimensionality of image 
data, segregate noise in the data, and reduce the computational requirements for 
subsequent processing (Boardman and Kruse, 1994). 
 
We will run the MNF program, select those grayscale MNF bands that contain the vast 
majority of variance and little noise, and then perform an unsupervised classification on 
the selected MNF Bands to determine if this enhancement improves our understanding, 
pattern recognition, and mapping of vegetation, soils, and clearings . 

ENVI Toolbox > Transform > MNF Rotation > Forward MNF Estimate Noise Statistics 
  Select the AISA 128 band hyperspectral data   > Open 
  Accept defaults on the MNF Transform Input File  > OK 
 
  The “Forward MNF Transform Parameters” window pops-up 
  Output Noise Stats Filename: “VNIR_MNF_noise_” 
  Output MNF Stats Filename:  VNIR_MNF_stats” 
  Output Filename: “VNIR_MNF_128bands”    >  OK 

  The computation of MNF bands will take some time – be patient. 

  When done, the 128 MNF bands appear in the Data Manager and a color  
  composite of MNF Band 3 – 2 - 1 as R – G –B is displayed in the View. 

  The MNF Eigenvalues plot also appears (VERY similar to the PC plot) 
 

The MNF Eigenvalues plot 
 
Note the rapid drop-off in Eigenvalue. 
 
This plot indicates that most of the original 
information in the data cube (variance) is 
now contained within the first 10 to 15? 
MNF bands. 
 
We will use the Band Animation tool to 
examine the MNF bands and create color 
composites to determine how many MNF 
bands we will use going forward. 
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7) Determine the number of MNF bands for further processing.  Zoom-in so the image 
fills your view. 
 If the MNF image in the View is black, click “Linear 1%” 
 Right-click on “VNIR_MNF_128bands” file in Layer Manager 
 >  Band Animation        
 You may have to stop Band Animation and stretch the MNF file in the Layer 
 Manager with “Linear 1%” 
 Keep moving the slider back to 1 after you start to see too much noise 
  Set timer for 1 second  

 MNF Band 1 has noise and all bands >10 to 15 have excessive noise? 

 Close the Band Animation tool   > Use the Data Manager to generate color 
 composites from MNF Band 2 to MNF Band 10.  Evaluate quality. 

 We will create a new MNF Band dataset with bands 2-10  
  File > Save As > Save As (ENVI, NITF…) “Data Selection” menu pops-up  
  “VNIR_MNF_128 bands” should be highlighted.   
  > Click “Spectral Subset” > Select bands 2 – 10 > OK  > OK 
  Name the output file “VNIR_MNF_9bands” in ENVI format   >  OK 

8) The 9-band MNF dataset appears in the Data Manager.  You may have to load a 
color MNF 4-3-2 as R-G-B using the Data Manager to have the 
“VNIR_MNF_9bands.dat” file appear in the Layer Manager. 
 
9) We’ll run an unsupervised classification on the 9-band MNF file to determine if new 
information is seen compared to the color IR and other band combinations. 
 
ENVI Toolbox > Classification > Unsupervised Classification > IsoData Classification 

 Choose the “VNIR_MNF_9bands.dat file”  >  OK 

 The ISODATA Parameters window pops-up. 
 Change the Max number of classes to 15 
 Change Maximum Iterations to 15 
 Change Threshold % (0-100) to 3.00 
 Accept other defaults Press “Help” to learn what these parameters mean. 

 Output Filename :  “VNIR_9-MNF_iso_15cla”   > OK 

10) If not already done, change to 2 vertical Views.  Have the unsupervised 
classification in one view and the color IR image in the second view.  Link the Views. 
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Question 6:   A. Do you think there is new information and patterns in the classification  
  map about vegetation, soils, barren ground, etc. that made our MNF and  
  isoDATA effort worthwhile?   

  B. Do you see shadows in the classification map?  If so, what class   
  number represents many shadows? 

  C.  What class number represents the most vigorous vegetation? 

Close all files in the Data Manager.  Return to one blank View. 
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 Hyperspectral SWIR Datacube for Geologic Mineral Mapping  
The second hyperspectral datacube is in the Chapter 9 folder of the “Remote Sensing 
Digital Database” in the “Ch_9_Image_Processing \ Dig_Img_1-2_Hyp-Multi_Cuprite-
NV” subfolder.  Digital Image 1-2 shows the Cuprite, Nevada area of interest. 
 
File > Open  drive to the “Dig_Img_1-2_Hyp-Multi_Cuprite-NV” folder, and open the 
“AVIRIS SWIR 50 bands” subfolder.   We will be working with only SWIR data. 
Select “cuprite_AVIRIS95_atm_50-SWIR_ENVI_” > Open 
 Apply a Linear 1% stretch 

 Open the Data Manager.  Select Bands 214 – 193 – 173 as R-G-B  > Load Data 

File > Open  return to the  “Dig_Img_1-2_Hyp-Multi_Cuprite-NV” folder and open the 
“Cuprite_Geology_Maps” folder.   We will load two geology maps. 
 Select “Field_Alteration_Zones_Ashley-Abrams_GIS.tif” and  
  “USGS Hyperspectral Map_GIS_JARS_9_1_0960044.tif” 

1) Cuprite is in the mining district of Nevada, located about 200 km northwest of Las 
Vegas.  Hydrothermal alteration is extensive at Cuprite.  There are three mapped zones 
(silicified, opalized, and argillized) that include mineral assemblages (see below).  The 
silicified zone contains abundant quartz, chalcedony, minor alunite, kaolinite and post-
alteration calcite.  Opalized rocks (opalite) contain opal with variable amounts of 
kaolinite and alunite, and  minor calcite.  Argillized areas are typically within or adjacent 
to opalized zones and contain primary quartz, unaltered sanadine, opal, montmorillonite 
and kaolinite. (Kruse, Baugh, and Perry, 2015, Validation of DigitalGlobe Worldview-3 
Earth Imaging satellite shortwave infrared bands for mineral mapping: Journal of 
Applied Remote Sensing, SPIE, v. 9, p. 096044-1 to 096044-17). 

 
Ashley and Abrams, 1980, USGS Open File Report 80-367.  
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Kruse, Baugh, and Perry (2015) also provide the USGS hyperspectral mineral map and 
legend (available in the Remote Sensing Digital database as “USGS Hyperspectral 
Map_GIS_JARS_9_1_096044.tif” and “Hyperspectral Legend” (see below). 

 
To see this legend picture on your screen, drive to the “Lab_11_Data” or the 
“Cuprite_Geology_Maps” folder and open “Hyperspectral_Legend.tif”.  You can see and 
enlarge this legend on your computer screen with any computer picture viewer program 
while mapping in ENVI. 

Next we’ll be comparing the geology maps, legend, and AVIRIS SWIR color image. 

 

2) To expedite this lab, I used the USGS Mineral Spectral Library (available from the 
USGS; in ENVI available as “usgs_min.sli” ) that was developed with detailed VNIR-
SWIR signatures of minerals in a laboratory setting, and I converted this library to a 
spectral library that fits the airborne AVIRIS 50-band SWIR data.  Then I extracted 14 
minerals that were mapped by the USGS at Cuprite (see legend above) and created a 
new spectral library for this lab’s AVIRIS 50-band SWIR data.   

This focused spectral library is named            
   “USGS_Min_Spec_Cuprite_50band_14minerals.sli”  
and is found in the Lab_11_Data folder.     
 

The 14-mineral Cuprite library is shown below.  The list of minerals on the right is shown 
as spectral signatures in the reverse sequence on the left.  Note the red alunite band is 
at the bottom of the spectral signatures and at the top of the list on the right.  Many 
unique absorption features that are used to identify minerals occur at different 
wavelengths. 
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NOTE:  My 14-mineral spectral library (above) has significant limitations because I did 
not account for differences in composition when creating the Cuprite 14 mineral spectral 
library. Many minerals have more than one entry in the “usgs_min.sli” spectral library 
because of differences in composition.   

Quartz does not have a diagnostic spectral absorption feature in the SWIR 
wavelengths.  Opal, sanadine and chalcedony also lack an absorption feature.   They 
are included in the 14-band spectral library as field work by Ashley and Abrams (1980) 
confirmed their occurrence at Cuprite. 

3) You should have the 50-band SWIR data, the color geologic map and the grayscale 
map in your ENVI display.  Open the USGS color mineral legend (shown above) with a 
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picture viewer and place it next to the ENVI display so you can more easily correlate 
colors on the map displayed in ENVI with the legend.   

 
Example of the set-up for one computer screen that includes the ENVI display, Data 

Manager, Toolbox, and the USGS color legend as a floating picture.  The color map is 
interactively made transparent and opaque with the slider to help pick sites for a 

spectral profile.  

3) Let’s compare spectral profiles in our hyperspectral data to spectra in the USGS 
spectral library.   

a) Zoom-in so the hyperspectral image fills your View.  Click-on the grayscale map and 
click-off the color map.  Turn the grayscale map on & off so you can compare the map 
patterns to patterns on the hyperspectral image.  The  “Silicified” pattern can be seen on 
the image.  
  
b) Notice that the map does not fit the image very well – the image is not orthorectified 
so distortions due to topography are inherent and both maps were screen-captured from 
the pdf publication so they also have inherent distortions.  
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c) Click-off the grayscale map and click-on the color geologic map. Use the 
transparency slider to compare the patterns on the color map with the hyperspectral 
image.  Use the Data Manager to load any grayscale band.  The color map when 
partially transparent will be easier to compare with patterns on a grayscale band– it will 
be more apparent when the map is not aligned with the image.  

d) Set the transparency for the color map at 40%, 
 Highlight the 50-band hyperspectral data in the Layer Manager. 
 Click-on the Spectral Profile tool (or use Display > Profiles > Spectral). 

e) The Spectral Profile window pops-up. 
 Move your cursor to the bright red pattern (“K-alunite 1” mineral) that is mapped 
 on the western hill.  “K-alunite” and “alunite1” are the same in this lab exercise. 
 Move your cursor to different locations in the red, K-alunite outcrop pattern. 
 Notice how consistent the absorption feature is at ~2.17 µm.  Place your cursor 
 on the bottom of this absorption feature and see the wavelength value in red 
 numbers at the bottom of the window. 

 To better interpret absorption feature wavelengths and shapes, click-on the “Data 
 Value” drop-down menu below the spectral profile . 
 
 Choose “Continuum Removed”.  Now click around the red pattern and observe 
 the consistency and variation in the ~2.17 µm absorption feature. 

 Keep the Spectral Profile window open – we will compare the airborne AVIRIS 
 profile in this window to the USGS spectral library profile of alunite next. 

f) We open the 14-mineral spectral library that is in the Lab_11_Data folder.   
  File > Open   drive to the Lab_11_Data folder   
  Select “USGS_Min_Spec_Cuprite_50band_14minerals.sli”  > Open 
   The “Spectral Library Viewer” window pops-up. 
   The 14-band library is open on the left side of the window.   
   Select “alunite1…” 
 
   Move the library window with the spectral profile under the spectral  
   AVIRIS spectral profile for alunite so the two profiles are aligned. 
   See example to left. 

   Open the Properties menu (black triangle on the right side) of the  
   Spectral Library Viewer so you can see the mineral that is   
   displayed, and can delete profiles as needed. 
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 Compare the shape and wavelength of the K-alunite1 (red pattern) spectral 
 profile on the geologic map and in the USGS Spectral Library.  Click around the 
 alunite outcrop on the geologic map with your spectral profile tool. 
 
 Alternate profile display between “Continuum Removed” and “Data Value” 
 
Question 7:   A. Do you find the absorption feature of alunite is relatively consistent  
  between the pixels in the hyperspectral data set and the USGS Spectral  
  Library?   YES  NO 

 

NOTE:  Most pixels are mixtures of minerals – there are very few pixels in a scene 
characterized by only one mineral – pure pixels are named “end members”.  So you will 
see variation in the shape and perhaps in the wavelength of the absorption feature for 
most pixels in the scene.  

g)  Move and Click your cursor on the bright green pattern on the color map (lower left). 
Your outcrop has to be within the smaller area covered by the AVIRIS image!  A new 
spectral profile from the 50-band SWIR hyperspectral data is displayed.  Click around 
the green pattern – is the spectral profile consistent?  
 
 In the “Spectral Library Viewer”, find the one mineral in the USGS library that 
 matches the mineral represented by the bright green color on the map.   
  Select and delete the “alunite1…” and other profiles you try out in the  
  properties menu for clarity. 

Question 8:  A. What mineral is represented by the green color in the USGS color map?  

  B. What is the wavelength of the absorption feature in both the   
  hyperspectral data and in the spectral library? 

 
h) Kaolinite, Dickite, and Halloysite are clay minerals with similar chemical and physical 
properties.  They are common in hydrothermally altered terrain. 

 Display these three clay minerals in the Spectral Library Viewer. 

 Click inside the yellow pattern on the color map (well-ordered Kaolinite). 
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Question 9:   A. Do you find pixels with the deepest absorption feature at ~2.21 µm? 
  YES  NO 
 
  B. Do you find pixels with the “doublet” absorption feature?  (two   
  absorption features next to each other)  YES  NO 

  B. What is the wavelength for the deepest absorption feature for dickite  
  and halloysite in the spectral library?  

i) Add “muscovi1” (muscovite = white mica) to the Spectral Library Viewer. 
 
 Click-on many pixels in the blue pattern (White mica 2) on the color   
 geologic map and analyze the spectral profiles. 

 Click-on many pixels in the orange pattern (White mica 3) on the color   
 geologic map and analyze the spectral profiles.   

Question 10:  A. What is the wavelength of the absorption feature for “muscovi1” (white  
  mica) in the spectral library? 

  B. Describe the difference between the shape of the absorption feature of  
  kaolinite and  muscovi1 (white mica). 

j) Remove all the minerals from the Spectral Library Viewer except kaolinite (“kaolini1”).  
Reload “alunit2” into the viewer.    Think about what would happen to the absorption 
feature between ~ 2.15 and 2.23 µm if you mixed kaolinite and alunite.   
 Click around the “Alunite + kaolinite” pattern on the color map. 
 
Question 11:  A. What often happens to the depth of the first absorption feature in the  
  kaolinite doublet (~2.16 µm) when alunite is mixed in? 
 
NOTE: The spectral profiles of pure pixel end members are used to unmix the minerals 
in mixed pixels…and theoretically estimate what percentage of each mineral is in the 
mixed pixel.  Finding pure pixels (end members) and “Unmixing” are often major goals 
of hyperspectral processing. 

k) Close the Spectral Library Viewer and the Spectral Profile windows. 
 Uncheck all the layers in the Layer Manager except the 50-band hyperspectral 
 data set 
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A good way to learn about hyperspectral processing is to use ENVI’s “Spectral 
Hourglass Wizard” (created by J. Boardman and F. Kruse).  The wizard has extensive 
explanations for the many processes – and many warnings about not letting your 
processing blindly follow the automated steps and results.  Always look at the input and 
output data.   This lab can only touch upon some of the steps – if you are interested in 
hyperspectral processing work with the wizard on your own. 

 

 

 
1. Input/Output File Selection (input data are usually 
in reflectance) 
2. MNF Transformation to reduce spectral 
dimensions 
3. Review of MNF Results 
4. Data Dimensionality determination using Spatial 
Coherence measures 
5. Pixel Purity Index (PPI) to reduce spatial 
dimensions 
6. Review of PPI Results 
7. n-Dimensional Visualization, including auto-
clustering, to select and retrieve individual 
endmembers 
8. The option to manually add User Supplied 
Endmembers 
9. Spectral mapping using Spectral Angle Mapper 
(SAM) and/or Mixture-Tuned Matched Filtering 
(MTMF) 
10. Investigation of Mapping Results 

 
As you gain experience with hyperspectral data, try ENVI’s Toolbox’s many tools in the 
Spectral, SPEAR and THOR Folders. 

ENVI Toolbox > Spectral > Spectral Unmixing > Spectral Hourglass Wizard 
 INTRODUCTION page  -  READ the text for each step!   
 

j) After reading the first page, press > “Next”  
 SELECT INPUT/OUTPUT FILES page 
 select our 50-band SWIR hyperspectral dataset for input.   
 Select an output folder for the many files that are produced.     
 > Next 
 
 1)   FORWARD MNF TRANSFORM page 
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       Accept Defaults  input “50” MNF bands 
 
       Do not use “Shift Difference Spatial Subset…” 
 
        >  Next   
 
       MNF Eigenvalues” plot pops up (see plot to right). 

 
  

 Do you see a flattening of the MNF curve after “10” ?   
     (10 of the 50 MNF Eigenvalue bands have a value above 1.8538.                
     The remaining 40 MNF bands have very little data variance – mostly noise). 

 2) > Next   VIEW MNF RESULTS page 
   “Load MNF Result to ENVI Display….”   
  The wizard may automatically fills the ENVI Classic 3-window display and  
  the newer GIS-look display.  Look for the list of MNF bands in the Data  
  Manager. 
  
  Apply “Linear 1%” stretch if image is black. 

   “Load Animation of MNF Bands…”  If this window does not appear, look  
  in the  Windows Taskbar at the bottom of your computer screen to   
  display…. 
  Slow the animation down with Speed “1”  More effective to hit the “Pause”  
  symbol and manually work your way back and forth through the bands  
  with the black arrows. 

Question 12:  A. What do you visually see as a reasonable number of MNF bands to  
  use going forward?  (relatively clean data, not much noise). 

 3) > Next   DETERMINE DATA DIMENSIONALITY page 
  We see the MNF Eigenvalues plot again – with a black background. 

  Accept defaults (50)  > Calculate Dimensionality 

  The “Spatial Coherence Threshold” plot shows up.  Move the horizontal  
  red line up and down number (use your cursor in the plot or the arrows).   
  Each Threshold Level specifies the number of bands above the threshold. 
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Question 13: A. What “Threshold Level” did you decide to use and how many MNF  
  bands does the ENVI program recommend using going forward?   

  B.  Why the difference between what you saw with your eyes and what the 
  computer program specifies as good MNF bands to use going forward?  
 To achieve lab class consistency, let’s type in“20” as the number of MNF bands 
 to retain going forward.  Type “20” into the Data Dimensionality window. 

 4) > Next   DERIVE OR SELECT ENDMEMBERS page 

  Choose to Derive Endmembers from Image “Yes”  > Next 

 5) PIXEL PURITY INDEX page 
  Accept the PPI defaults (5,000 iterations, threshold value 2.5,  
  memory use 10.0 Mb.   > Next 

 

 6) EXAMINE PPI RESULTS page    Accept 10,000 default   > Next 

 7) N-DIMENSIONAL VISUALIZER page   Read the discussion on this page! 
  Enlarge the “n-D Visualizer” window  > Start 
  Reduce speed to 10.  Be amazed by the cloud with end members 
  These are “pure” pixels color-coded by the ENVI wizard. 

 

Examine the drop-down menus in the “n-D Controls” window. 
  Options > Show Axes 

  Options > Class Controls 

NOTE: 
I found  20,000 iterations on a fast workstation 
provided a curve that flattened more compared to 
the default 5000 iteration curve. 
If you are on a fast computer, try increasing your 
iterations and maximum memory. 
 
You want to flatten the curve in the upper right. 
 
A PPI image with a grid pops up on the ENVI View.  
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  The “n-D Class Controls” window pops-up with the 20 color-coded classes 
   Turn off the White pixels (I have 7048 white pixels).  The white  
   pixels are not end members (my understanding…).  I see a much  

   clearer picture of the 19 end members!  Do you? 
 

                     

 There are 20 MNF bands in the “n-D Controls” window (looks like a calendar)  
 They are color-coded in the “n-D Class Controls” window.  
  Try different 3-band combinations.  Turn off the active 3 bands, and then  
  select 3 new bands.  After a few combinations, try 18-19-20    > Start  

Question 14:  A.  What happens to the cloud when you load MNF bands 18-19-20 into  
  the n-D Visualizer? 

  B. What does the 3D shape of the 18-19-20 cloud tell you about coherent  
  spectral information and noise in these MNF bands? 

  
8) You can add your own end members by interpreting corners in the cloud  
 or by importing from a Spectral Library.  We will import our “alunite1”   
 spectral profile from our 14-band spectral library. 

 “n-D Controls” > Options > Import Library Spectra >   
 “n-D Visualizer Import Spectra” window pops-up >  
  Import   select   “from Spectral Library File>   
 “Spectral Library Input File” window pops up 
  If you don’t see our 14-band spectral library in the list, go to the “Open”  
  drop-down menu at the bottom of this window > choose “Spectral Library”  
  > drive to Lab_11_Data folder with our 14-band library > Select > Open  

  
 In the  “Spectral Library Input File” window  our 14 band library file displays at the 
 top of the list> 
  Select  “USGS_Min_Spec_Cuprite_50band_14minerals.sli”  > OK  
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 The “Input Spectral Library” window pops up. 
  Select “alunite…”  accept defaults     > OK 
 
 Two more windows pop-up(!).   
  The “alunite1…” spectra is highlighted and the profile displayed in the  
  Spectral Library Viewer.   

  “alunite1…” is also highlighted in the  “n-D Visualizer Import Spectra”  
  window  > Apply   and then the second small window (“Import Spectra  
  Parameters”)  pops-up  >  Accept default color > OK 

  The Alunite1 position in the cloud is displayed and labelled! 

  Try to determine what if any PPI endmembers correlate spatially with the  
  USGS “alunite1…” spectra.  The magenta endmember (553 pixels) and  
  the dark brown endmember (2149 pixels) are often near the USGS   
  spectra as different bands are selected with the n-D Visualizer tool. 
 

 6) Let’s delete our Alunite1 point. “n-D Controls”  > “Options” > “Delete Library  
  Spectra” window pops-up > select “alunite1…” > OK 
 
 7)  In the Wizard’s N-DIMENSIONAL VISUALIZER page  
  > click on “Retrieve  Endmembers” 
  The 19 endmembers populate the Endmember List. 

  The “Plot Endmembers” and “Start Spectral Analyst” buttons are activated. 

 

  Click-on “Plot Endmembers” 
   The “n-D Visualizer Endmember Spectra” window pops-up. 
              (see window below) 
    
   Change from “Data Value” to “Continuum Removed” 
   Click on the “Stack Plots” icon   
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  Read through the text on the right side of the “n-D Visualizer Endmember  
  Spectra” window  below.  Note how similar these endmember spectra to  
  some of the spectral profiles we found while clicking around the AVIRIS  
  SWIR data set.   Muscovite (white mica).  Calcite.   
    

 

 
“n-D Visualizer Endmember Spectra” window 
 
“Data Value” changed to    
                             “Continuum Removed” 
 
Clicked on “Stack Plots” 
 
What endmembers have unique spectral 
profiles in the SWIR wavelength range? 
 
Experienced analysts can identify the material 
(minerals in our example) that is associated 
with a spectral profile on the left.   
 
“n-D Class Mean #2 (green profile 2nd from the 
bottom) is very similar to “muscovite” or “white 
mica”. 
 
“n-D Class Mean #5 (cyan profile 5th from the 
bottom) is very similar to “calcite”. 
 
The end member spectra can be exported from 
this menu as a spectral library using the 
“Export” dropdown menu!  Then you could do 
an excellent job comparing your endmember 
spectra to large spectral libraries and more 
accurately rename the endmembers.  You could 
also delete those endmembers that had spectra 
that was not in your area (based on field work 
and knowledge about materials in the scene. 
 
Also you could use the “Start Spectral Analyst” 
tool that is shown on the “N-Dimensional 
Visualizer” menu to help identify your 
endmember spectra. 
 
These are very powerful tools! 

 
The spectral signatures and names of the 19 endmembers are shown on the plot above 

 The profiles and list are in reverse order.  “n-D-Class Mean #1” is at the bottom 
 of the profile stack…n-D Class Mean#19 is at the top of the profile stack. 

 8) You should realize that several of these spectral profiles look like spectra in 
 our 14-band Spectral Library.  Read the text in the box above. 
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 Click-on the “Start Spectral Analyst” button in the Wizard’s N-DIMENSIONAL  
 VISUALIZER page 
  The “Spectral Analyst Input Spectral Library” window pops-up. 
  Select our 14-mineral Spectral Library (if it isn’t in the list, go to the   
  drop-down menu at “Open” > Spectral Library > and drive to our library  
  location in the Lab_11_Data folder and select > OK 
   

 The “Edit Identify Methods Weighting” window pops up. 
 We will use all three methods to evaluate our 19 endmember spectral profiles 
 so enter 0.33 in the three “Weight” windows.   >  OK    (see below) 

      

 A blank “Spectral Analyst” window pops up (see below at left) 
 Click Apply and a list with our 19 endmembers pops-up (see below at right) 

                  

 Select endmember #5 (we think this looks like Calcite) > OK 
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The “Spectral Analyst” window pops back up with a list of potential spectra that  match 
our endmember #5 – ranked by score.   (see below) 

                     #1 fit is Calcite! 

 Click on Help at the bottom of the Spectral Analyst menu to understand the 
 limitations and processes involved.  Some Help comments below. 

NOTE:  Use the Spectral Analyst to help identify materials based on their spectral 
characteristics. The Spectral Analyst uses ENVI techniques such as Binary Encoding, Spectral 
Angle Mapper, and Spectral Feature Fitting to rank the match of an unknown spectrum to the 
materials in a spectral library. 
The output of the Spectral Analyst is a ranked or weighted score for each of the materials in the 
input spectral library. The highest score indicates the closest match and indicates higher 
confidence in the spectral similarity. Similar materials may have relatively high scores, but 
unrelated materials should have low scores. 
This function does not identify spectra; it only recommends likely candidates for identification. 

Question 15:  A. Using the “Spectral Analyst” tool, click on “Apply” and select “n-D Class 
  Mean #9”.  What three closely related clay minerals have the highest  
  score? 

  B. Look at the profile of n-D Class Mean #9.  What is the term used to  
  describe the  unique spectral absorption feature between 2.17 and 2.21  
  µm? 

  C. Using the “Spectral Analyst” tool, click on “Apply” and select “n-D Class 
  Mean #4”.   What mineral has the highest score? 

 9) “Edit Names” in the Endmember List shown in the Wizard’s the Wizard’s N-
 DIMENSIONAL VISUALIZER page. 
  Change “n-D Class Mean #5” to “Calcite” 
  Change “n-D Class Mean #9” to the mineral with the top score. 
  Change “n-D Class Mean #4” to your answer above. 
   Your changes will show up on our next map!!   > Next 
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 10)  USER SUPPLIED ENDMEMBERS page.  We won’t add “User Supplied  
 Endmembers”.  If you did field work and  collected spectra, you could add your 
 spectra her to improve and validate your map.     > Next 

 11) MAPPING METHODS page.  Carefully read this section – excellent review of 
 the different methods! 

 Let’s just do one method – SAM with the default SAM Maximum Angle of 0.10  
   (uncheck MTMF and Unmixing methods)   > Next 

 12) The SAM process is completed and the Wizard page INVESTIGATE SAM 
 RESULTS page pops-up.  Read this explanation of SAM. 

 In the Data Manager you will see the SAM 19-class classification map (shown 
 below) and the SAM 19 Rule Images (grayscale). 
 
 Turn on your SAM classification map and the USGS Hyperspectral classification  
 map.   Turn all other layers off in the Layer Manager.  

 Highlight the SAM map in the Layer Manager.  Manually use the transparency 
 slider to fade the SAM map from opaque to transparent.  Answer Question 16. 

 
             Color composite of SWIR bands        SAM map with 19 classes 

Question 16:  Questions are based on the SAM classification map. 
  (Hint:  Use the “Cursor Value” tool to query the class shown on your map)  
  A. Is Calcite located in the same place as on the USGS hyperspectral  
  color map?   YES    NO 
 
  B. What is the “nD-Class  Mean #3 class on the USGS hyperspectral color 
  map? 
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  C. Right-click on the “Classes” folder under the SAM map in the Layer  
  Manager >   Select “Statistics for all Classes”.  In the “Data Selection”  
  window ensure the “cuprite…_sam_class” file is selected. 

   What are the three largest classes? 
   What are the three smallest classes (don’t include “Unclassified”)? 

  D. Does your classification map show spatially coherent classes? 
      YES    NO 

 13) SAM Rule images are grayscale probability images.  Each endmember has a 
 SAM Rule image.  The better the fit of the pixel to the endmember’s spectral 
 profile, the smaller the “spectral angle” and the blacker the pixels in the Rule 
 image.  Use the Cursor Value tool to query light and dark pixels in the Rule 
 images. 

 In the Data Manager, expand the “cuprite…._sam_rule” file so that the 19 
 endmembers are displayed.   
  
 Select the “Rule (Calcite)” > Load Grayscale  > contrast stretch “Linear 1%” 
  Calcite is the renamed “n-D Class Mean #5” 
  Use the Cursor Value tool to query the brightest and darkest pixels. 
   (you could also use the “Quick Stats” tool to get exact values). 
  
Question 17:  A. What is the SAM Rule value for the brightest pixel you find?  
  
  B. What is the SAM Rule for the darkest pixel you find? 

  C.  According to the USGS color geologic map, what mineral is located  
  where the Calcite SAM Rule map has the brightest pixels?  (meaning  
  spectra in these pixels are very different compared with calcite spectra). 
 
  C. Where are the darkest pixels located? 

Turn-off all layers in the Layer Manager.  Turn-on the colorful SAM classification map.
 File > Chip View To > Geospatial pdf 
 Leave the metadata blank…bad practice but this lab is too long! 
 Output Filename:  “YourName_SAM_map”    check “Display Result” 
 Upload your geospatial pdf to the instructor.   

Congratulations for completing this lab!  You now have some understanding of the 
potential for hyperspectral remote sensing to provide unique, very informative, and very 
detailed maps of material on the Earth’s surface. 



26 
 

26 Introduction to Remote Sensing  Principles, Interpretation, and Applications 
F. F. Sabins and J.M. Ellis, 2020, Waveland Press.    Contact:  jellis@ellis-geospatial.com 

 

Lab 11   Hyperspectral  Section 1                   Name: 

Hyperspectral VNIR Datacube for Vegetation Analysis 

Upload the following files to the instructor: 
 
 “YourName_5_Spectral_Profiles”   as a .png 
 
 YourName_3D_Datacube” as a .tif 
 

Question 1: What is the name of the unique sharp increase in brightness (Data Value) 
between 680 and 745 nanometers? 
 
Question 2: Why is the reflected brightness highest in the 520 – 600 nm range 
compared to the 400 – 520 nm and the 600 - 680 nm ranges? 
 

Question 3:  What causes the unique absorption feature for healthy vegetation that is 
between ~600 and 680 nm?  (Hint: think about what is causing the higher reflectance 
values at shorter and longer wavelengths?) 
 
 

Question 4:  A. What is the calculated NDVI value for your brightest (most vigorous)  
  pixel? 

  B. What is the calculated NDVI value for the gray terrain (in the color IR  
  image gray may represent dormant, dry grasses and other ground   
  vegetation)? 

  C. How did the program calculate NDVI?   
 

Question 5:  Discuss what happens to VNIR spectral profiles when you move from 
vigorous vegetation to no vegetation (barren terrain). 
 

Question 6:   A. Do you think there is new information and patterns in the classification  
  map about vegetation, soils, barren ground, etc. that made our MNF and  
  isoDATA effort worthwhile?    YES    NO   

  B. Do you see shadows in the classification map?  If so, what class   
  number represents many shadows? 

  C.  What class number represents the most vigorous vegetation? 
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Lab 11   Hyperspectral Section 2                   Name: 

Hyperspectral SWIR Datacube for Geologic Mineral Mapping 

Upload the following file to the instructor: 
 
 “YourName_SAM_map”  as a pdf (at the end of the lab)  
 

Question 7:   A. Do you find the absorption feature of alunite is relatively consistent  
  between the pixels in the hyperspectral data set and the USGS Spectral  
  Library?   YES   NO 

Question 8:  A. What mineral is represented by the green color in the USGS color map?  

  B. What is the wavelength of the absorption feature in both the   
  hyperspectral data and in the spectral library? 

Question 9:   A. Do you find pixels with the deepest absorption feature at ~2.21 µm? 
  YES    NO 
 
  B. Do you find pixels with the “doublet” absorption feature?  (two   
  absorption features next to each other)   YES    NO 

  B. What is the wavelength for the deepest absorption feature for dickite  
  and halloysite in the spectral library?  

Question 10:  A. What is the wavelength of the absorption feature for “muscovi1” (white  
  mica) in the spectral library? 

  B. Describe the difference between the shape of the absorption feature of  
  kaolinite and  muscovi1 (white mica). 
 

Question 11:  A. What often happens to the depth of the first absorption feature in the  
  kaolinite doublet (~2.16 µm) when alunite is mixed in? 
 

Question 12:  A. What do you visually see as a reasonable number of MNF bands to  
  use going forward?  (relatively clean data, not much noise).    

 

Question 13: A. What “Threshold Level” did you decide to use and how many MNF  
  bands does the ENVI program recommend using going forward?   
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Question 14:  A.  What happens to the cloud when you load MNF bands 18-19-20 into  
  the n-D Visualizer? 

  B. What does the 3D shape of the 18-19-20 cloud tell you about coherent  
  spectral information and noise in these MNF bands? 

Question 15:  A. Using the “Spectral Analyst” tool, click on “Apply” and select “n-D Class 
  Mean #9”.  What three closely related clay minerals have the highest  
  score? 

  B. Look at the profile of n-D Class Mean #9.  What is the term used to  
  describe the  unique spectral absorption feature between 2.17 and 2.21  
  µm? 

  C. Using the “Spectral Analyst” tool, click on “Apply” and select “n-D Class 
  Mean #4”.   What mineral has the highest score? 

Question 16:  Questions are based on the SAM classification map. 
  (Hint:  Use the “Cursor Value” tool to query the class shown on your map)  
  A. Is Calcite located in the same place as on the USGS hyperspectral  
  color map?   YES    NO 
 
  B. What is the “nD-Class  Mean #3 class on the USGS hyperspectral color 
  map? 

  C. Right-click on the “Classes” folder under the SAM map in the Layer  
  Manager >   Select “Statistics for all Classes”. 

   What are the three largest classes? 
 
   What are the three smallest classes? 

  D. Does your classification map show spatially coherent classes? 
  YES    NO 

Question 17:  A. What is the SAM Rule value for the brightest pixel you find?  
  
  B. What is the SAM Rule for the darkest pixel you find? 
 
  C.  According to the USGS color geologic map, what mineral is located  
  where the Calcite SAM Rule map has the brightest pixels?  (meaning  
  spectra in these pixels are very different compared with calcite spectra). 

  D. Where are the darkest pixels located? 
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Lab 12  Change Detection and Radar Polarization 
Utilizes Textbook’s Remote Sensing Digital Database: Chapters 3 and 6 data. 

The objectives of this lab are to learn three methods for documenting change on images 
over 16 days in central California and to evaluate the information provided by radar 
bands acquired with different polarizations.(see Chapter 9 Digital Image Processing for 
discussion).  The change detection images and several files for the radar exercise are 
located in the Lab_12_Data folder.   The tasks we will complete with this lab are done 
with tools in the ENVI Toolbox. 

Three digital files are to be uploaded to the instructor and sixteen questions answered 
on the last pages of this handout. 

Change Detection 
We will analyze change at Mt. Diablo, California with Landsat images acquired before 
and after a fire.  Much of the Mt Diablo exercise is courtesy of M.B. Quinn, Geography 
Dept., Diablo Valley College, Pleasant Hill, California. 
 
NOTE:  The two images used for change detection and band ratios need to have 
exactly the same number of rows and columns, and the same pixel size.  When you 
cannot get the 2nd image to load in a change detection algorithm, check the Metadata 
and use the “Resize” tool to give the images the same dimension and same pixel size. 

Change at Mt. Diablo, California: 7 September 2013 to 23 September 2013 (16 days) 

 Open ENVI 
1) Load the two Landsat 8 TM subscenes into one View.   
 The datasets are in the Lab_12_Data folder.   
  mt_diablo_landsat8_7sep2013_30m_6band.tif 
  mt_diablo_landsat8_23sep2013_30m_6band.tif   
   
  Zoom to Full Extent 
  Change RGB Bands  to reflected SWIR2 – NearIR – Green (Bands 6-4-2)  
  as R-G-B so enhanced color  images display 
  Contrast stretch with “Linear 2%”  (SWIR2-NearIR-Green bands) 
  Perform Band Animation with the 6 bands on both Landsat images. 
 
     Load the DEM and  hillshade DEM in the Lab_12_Data folder. 
  mt_diablo_30m_dem _ 
  mt_diablo_30m_dem_shaded_ 
  Drag the DEMs below the Landsat images in the Layer Manager. 
   The shaded DEM should be above the DEM.   
   Contrast stretch the DEM files with “Linear 1%” 
   Right-click the DEM > Change Color Table > Rainbow 
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  Examine the hillshade and color-coded DEMs. 
  Select the hillshade DEM in the Layer Manager > “Transparency”  slider > 
   Fade the hillside DEM to 40%. 
   
  If needed, drag the 23 September image to the top of the Layer Manager. 
 
 Pan around the scene and Zoom in to the mountain.  Turn on and off the 7 Sept and 
 23 Sept images so you  see where features on the images are located on the color-
 coded hillshade DEM.  
       
Question 1:  A. What color is healthy vegetation in our enhanced color images  
  (SWIR–Near IR–Green as R-G-B)? 
 
  B.  September is a hot and dry month around Mt. Diablo, California,  
  and typically follows many dry summer months.  Based on our enhanced  
  color images, what features around Mt. Diablo have the healthiest (most  
  vigorous) vegetation?  
   
  C. What is the elevation at the top of Mt. Diablo?  (DEM in meters) 
 
 Use the Data Manager to load a grayscale Band 4 (reflected near IR light) from 
 the 7 September and 23 September Landsat data. 
   
 Zoom in to Mt. Diablo. 
   
 Contrast stretch both grayscale images “Linear 2%”.  Press on the “Stretch on 
 View Extent” icon (next to the contrast stretch drop-down menu) so only pixels  
 within the View are used for the histogram and contrast stretch. 
 
Question 2: A. Compare the 7 September band 4 to the 23 September band 4.  Where 
  geographically do you see  the largest difference in brightness?   
 
  B. Based on what you see and can interpret, what event has the 23  
  September image captured on Mt. Diablo? 
  
  C. Based on the Landsat imagery, when did this event occur? 
 
  D. What Landsat spectral evidence do you have to support your   
  interpretation about the event on Mt. Diablo between 7 and 23 September  
  2013? 
  
2) In its simplest form, the difference between two images can be determined by 
subtracting one from the other: Toolbox > Band Algebra > Band Math  
 
 Enter the expression: “float (B1)  –  float (B2)” then “Add to List”  > OK 
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 The “float” within the expression allows negative (floating point) DN values in the 
 output image. 
  
 Assign band 4 of the Sept 7 image as “B1”; Assign band 4 of the Sept 23 image 
 as “B2” 
  
 Output filename: “lastname_bandmath” 
 
 Apply various (canned) contrast stretches. Apply the stretch that best identifies 
 the difference between the two images. 
 
Question 3:   Explain how the band math subtraction of the 23 Sept image from the 7  
  Sept image results in the area of change having such a significant   
  difference in brightness (DN value) compared to the surrounding area. 
  (Hint: think what happened to the DN value of near IR pixels in the   
  changed area compared to the DN value of near IR pixels in the   
  surrounding area). 
 
 File > Chip View To > File  >  Format JPEG  >   “YourName_chg_bandmath”  
 Upload to the instructor. 
 
3) Now let’s try ENVI’s change detection software:  
 Toolbox > Change Detection > Change Detection Difference Map 
 
 For the “Initial State” image, select band 4 of the September 7 scene, > OK 
 
 Select the September 23 scene (band 4) as the “Final State” image, > OK 
 Number of classes: 5 
 
 Select “Simple Difference” and “Standardize to Unit Variance” 
 
 Name the output file: “ Lastname_CDDM” (for Change Detection Difference Map) 
 
The output image is a raster color slice showing various states of change relative to a 
mean DN value. The “plus” or “minus” indicate the positive or negative direction DN 
values have changed for each class.  If your “LastName_CDDM” image was not 
automatically placed at the top of the Layer Manager by ENVI, select this file in the Data 
Manager and >  Load Data.  
 
ENVI’s default (assigned) colors for classes are red (for positive values of change) and 
blue (for negative values of change). The user, however, can easily assign any color to 
each of the classes: 
 
 To change the color scheme: 
 Right-Click on the “Classes folder under the “lastname_CCDM” image > Select 
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 “Edit Class Names and Colors”  >  the window pops-up    
 >  Change Class Names and Class Colors as you desire. 
 
 For this exercise, let’s change the extreme change classes, 1 and 11. 
  Class 1: Change (+5) to Green 
  Class 11: Change (-5) to Yellow  
 
 Let’s save as a jpg graphic. 
 
 File > Chip View To > File  >  Format JPEG  >   “YourName_color CCDM”  > OK 
  
 Upload to the instructor. 
 
3a) Individual or all of the classes can be exported to a more useful GIS polygon vector 
file (.shp format) 
 Toolbox > Classification > Post Classification > Classification to Vector 
 
 Select Input Band: the “Change Detection Difference Map”  > OK 
  
 The “Raster to Vector Parameters” window pops-up 
 Select Classes to Vectorize  >  select   “Change (-5)”   this is Class 11 
 
 Accept defaults (Single Layer, output results to File) 
  
 Name the output file “Yourname_event_outline” in .evf format (ENVI vector  
 format). 
 
 If the vector .evf file does not show up automatically in your Data Manager or 
 Layer Manager, File > Open > drive to the folder where you saved your .evf file 
  and select  “Yourname_event_outline.evf”   (you must choose the file with .evf at 
 the end)  > Open 
 
 Turn off all the files in your Layer Manager except the hillshade DEM.  Your 
 vector file looks excellent on the hillshade DEM! 
  
 Convert the .evf to .shp:   Toolbox > Vector > Classic EVF to Shapefile 
 Name your shapefile “Yourname_CCDM_map_GIS.shp” 
 
Recall that there will be at least three files associated with each ESRI shapefile (.shp, 
.shx, .dbf, & possibly a .prj file); so to not allow confusion in determining the difference 
between ENVI and ESRI files, provide a new, distinct name for the output shapefile(s). 
 
 Click-off all the layers in the Layer Manager.  Load the shapefile into the View 
 using the Data Manager (the shapefile may already be loaded in your view). 
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 If the vector shapefile does not show up automatically in your Data Manager or 
 Layer Manager, File > Open > drive to the folder where you saved your shapefile 
  and select  “Yourname_CCDM_map_GIS.shp”   (you must choose the file with 
 .shp at the end)  > Open 
 
 The shapefile map matches exactly the ENVI .evf map. 
 
 Zoom in to Mt. Diablo.  Let’s send this vector map to the instructor. 
  
 File > Chip View To > File  >  Format JPEG  >   “YourName_CCDM_shp”  > OK 
  
 Upload to the instructor. 
 
Close all files using the Data Manager. 
 
NOTE:  You can run a majority filter on the 11-class, event CCDM classified raster 
image to reduce the number of small polygons.  There are 733 polygons in this one 
shapefile! 
 
In the GIS you can edit and eliminate small polygons – or all polygons outside of the 
main event feature – and create an excellent map with the feature of interest faded the 
hillshade DEM. 
 
If you have access to a GIS, load the shapefile, Landsat images and DEM to evaluate.  
Look at the attribute table and note the area and perimeter calculations are provided for 
every polygon.  So you can quickly provide area estimates to clean-up teams and 
environmentalists.   
 
There is an ENVI tool named “Image Change Workflow”.  This tool attempts to indicate 
“change” between two images by comparing differences using multiple bands rather 
than single bands (as were used in the examples we just completed).   If you have time 
and want to try this alternative method of change detection, here’s the tool’s location. 
 
 ENVI Toolbox > Change  Detection > Image Change Workflow 
 
Close all files using the Data Manager.  Start the radar exercise with a blank View. 
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Radar Polarization 
We will analyze HH and HV polarized radar images from the Chapter 6 folder in the 
Digital Remote Sensing Database.  We will also evaluate two ways to generate a third 
image from the HH and HV images so we can develop an informative color composite. 

NOTE:  Band ratios require the two grayscale images to have exactly the same 
dimension (rows and columns) and the same size pixels.  If the 2nd image will not load in 
the band math tool or allow you to “Enter Pair” in the ENVI’s Band Ratio tool, you have 
to resize one of the images so that the rows and columns have identical dimensions. 

Death Valley  
We will process PALSAR-2 radar data of Death Valley, California and compare the 
radar to a Landsat 8 enhanced color image. 
The textbook has PALSAR-2 characteristics in a Chapter 6 table along with a short 
description.  See the textbook’s Figure 6-11 that shows a close-up of the PALSAR-2 HH 
and HV images in Death Valley. 
 
1) Start-up ENVI >        Views > Two Vertical Views 
 Drive to the “Plate 18_PALSAR-2_Sentinel-1_DV” folder  
 and open the “PALSAR-2 L-band” subfolder.   

 The “…GeoTIFF” HH and HV bands are the original data and have their DNs 
 in unsigned integer format.  We’ll use these two images for band math. 
 
 The “…BW_Image_GIS” HH and HV bands were converted from the original 
 number format to 8-bit (byte) images that are easier to visualize in a GIS. 

 Highlight View #1  >       File > Open            
 Select the unsigned integer HH GeoTIFF image: 
  “DeathValley_Palsar2_HH_2016_Resized_UTM12N_GeoTIFF”> Open 

 Highlight View #2  >       File > Open            
 Select the unsigned integer HV GeoTIFF image: 
:  “DeathValley_Palsar2_HV_2016_clip_UTM12N_GeoTIFF” > Open 
 
2) Link the Views and Zoom in and pan around Death Valley to compare the HH and HV 
imagery.  Try different stretches.  I found the obscure “Square Root” contrast stretch 
worked very well.   See ENVI Help (definition below) 

Square Root performs a square root gray scale transformation, then applies a linear stretch. 

Question 5:  Which polarized band carries more information to the untrained eye: 
   HH or HV? 
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3)  We will use the band ratio to create a third grayscale radar image from the PALSAR-
2 HH and HV images.  
  
 We will divide the DN of the pixels on the HH image by the DN of the pixels on 
 the HV image to generate a ratio grayscale image.  The “Committee on Earth 
 Observation Satellites” (CEOS)  notes that the HH/HV backscatter ratio is 
 commonly used with PALSAR (L-band) data and displayed in the blue channel 
 as it results in a color composite image in which vegetated areas appear green. 

 We can use either band math or the “Band Ratios” tool.   
  With band math the formula becomes: 
      float (b1) / float (b2) 
 
  ENVI Toolbox > Band Algebra > Band Math 
   In the “Band Math” window: 
   Enter the expression above  > Add to List, and then > OK  
   click on the HH image for B1 and the HV image for B2  > OK 
   Name the output: “DeathValley_HH_HV_Ratio _radar” 

  The ratio image will appear in one of the two vertical views. 

 Let’s create a 4-View display.  Views > 2 x 2 Views > OK 

  Highlight the empty View #3      
  Drag the “DeathValley_HH_HV_Ratio _radar” to View #3  
   (remove from View 1 or 2) 
      or load the ratio image into View #3 from the Data Manager. 
 
  Views > Link Views > Link All > OK    Zoom to Full Extent 
  Zoom in and pan around to compare the 3 grayscale images: 
    HH, HV, and HH/HV 

Question 5:   Describe the ratio (HH/HV) image in 10 words or less. 

 Now we want to stack these HH, HV and ratio images into a 3-band color image. 
  Highlight the empty View #4 
  ENVI Toolbox > Raster Management > Layer Stacking 
  Import the 3 files by selecting all 3 files   > OK 
       Reorder if necessary:   
           The stack should be from top to bottom:  HH, HV, HH/HV Ratio.   
    (or HH – HV – HH/HV Ratio Image as R – G – B (1-2-3) 
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  Accept the defaults…. > Output Filename:   
   “DeathValley_HH_HV_ratio_radar”  > OK 
 
  Load the HH-HV-ratio color composite into View #4  
  Views > Link Views > Link All > OK 
   Try different stretches on the HH-HV-ratio color composite.  

4) You should have 
 HH in View 1,  
 HV in View 2,  
 HH / HV ratio grayscale in View 3, and  
 HH-HV-band ratio color composite in View 4 
  Views > Link Views > Link All > OK 

Question 6:  Do you think the color composite (View 4) tells you more information about 
  Death Valley compared with the grayscale HH and HV?   YES   NO 

5) Right-click on View #1 (HH Band) in the Layer Manager and > Remove View 
    Right-click on View #2 (HV Band) in the Layer Manager and > Remove View 

 In the View with the HH/HV ratio, load the Landsat color image. 
 Highlight this View    File > Open   
  Drive to the  
  “Plate 18_PALSAR-2_Sentinel-1_DV \ Landsat8” subfolder  
  and select  
      “DeathValley Landsat8_P40R35_22Feb2017_752 Enh-Color_30m_Image_GIS”  
 > Open 
 Zoom to Full Extent    The Vertical two Views should be linked. 
 Zoom-in and pan around to compare the enhanced Landsat that is generated 
 from reflected SWIR2, Near IR, and blue light with the radar color composite that 
 is generated from reflected radar energy. 

Question 7:  A. On the radar images there are dark features along the bottom of the  
  valley. What does the dark tone indicate about the roughness of the  
  surface? 

  B. On the HH-HV-Ratio color radar image of the valley bottom (ignore the  
  mountains on the left and right) there are bright landforms with colors that  
  grade from yellow to light purple to darker purple.  What does gradation in  
  brightness indicate what about the surface roughness of those landforms?  

Close all files with the Data Manager.   You should have two Views -  Select View #1 
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Trinity River, Texas 
We will close the lab with HH and HV polarized radar data collected by the European 
Space Agency’s excellent Sentinel-1 satellite.  The textbook lists characteristics of the 
Sentinel-1 system in a Chapter 6 table.  Plate 51 (Chapter 15) in the textbook shows an 
interferogram generated from Sentinel-1 system that measured ground deformation 
caused by the 2014 Napa Valley, California earthquake. 

1) Start-up ENVI >     Views > Two Vertical Views     Highlight View #1.   
 File > Open   Drive to the Remote Sensing Digital Database \    
        Ch_6_Radar_Images” folder.  

 Open the “ESA_Sentinel-1_hh-hv-ratio” subfolder and  
 Select the “Galvaston_2017Apr14_Sentinel-1_hh-hv-ratio_GIS” image > Open 
 The radar image should load into View #1. 

 Highlight View #2.     
 Return to the  “ESA_Sentinel-1_hh-hv-ratio”  folder  
 Select the “Landsat_OLI_432_6Apr2017_clip_GIS” image   > Open 
 The Landsat image should load into View #2. 
 
 Views > Link Views > Link All > OK 
 Zoom to Full Extent 
  You can see the overlap area of the radar and Landsat is mostly East of  
  the Trinity River and Houston.  
 
2) Both images were acquired within 8 days in 2017 (!)  We can have some confidence 
that features of interest on the radar and Landsat did not markedly change over the 8-
day period.  We will examine the advantages of using radar in urban and coastal areas.  
 Zoom-in and pan around   The Sentinel-1 image is not georeferenced very well, 
 so offsets will be noticed by you as you zoom-in and pan around. 

3) File > Open      Highlight View #1 with the Sentinel-1 radar color image.  

 Drive to the Lab_12_Data folder and select the Shapefile and ENVI “.anz” 

 (8 sites are located with points and labels in the Shapefile and the .anz file). 

 select “Sentinel-1_Radar_Sites.shp”  > Open 
       (There are at least 6 other files associated with this GIS shapefile). 

 Also select “Sentinel-1 Sites for Eval.anz” > Open 
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The shapefile is a point vector file with attributes.  The ENVI .anz file is just an 
annotation file that posts Site numbers 1 – 8 in the View.  They should be posted on the 
Sentinel-1 radar image in View 1 as shown below. 

 

The shapefile’s attribute table is also available as an Excel spreadsheet “Shapefile 
Coordinates Eval Sites.xls” in the Lab_12_Data folder. 
 
The Shapefile’s Attribute Table is shown below.  You can copy & paste the Lat/Long 
numbers in each row into ENVI’s Go To drop-down window as “29.641, -95.936” and 
ENVI will place the crosshairs at that location.   
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The Shapefile’s Attribute Table from the Excel Spreadsheet. 
Site Name Lat Long Y X 

1 Mouth of river 29.641 -94.936 3280587.0 312598.7 
2 bright dots on radar 29.690 -94.956 3286019.9 310785.3 
3 submerged pattern on radar? 29.618 -94.974 3278049.1 308854.1 
4 ponded water 29.562 -94.625 3271356.9 342531.7 
4 ponded water 29.569 -94.603 3272150.7 344754.2 
4 ponded water 29.566 -94.556 3271674.4 349278.6 
4 ponded water 29.553 -94.570 3270325.1 347849.9 
4 ponded water 29.531 -94.670 3267996.7 338166.1 
4 ponded water 29.598 -94.552 3275193.4 349675.5 
4 ponded water 29.542 -94.604 3269108.0 344595.5 
4 ponded water 29.535 -94.645 3268340.7 340573.8 
5 Ag Fields 30.185 -94.649 3340383.0 341270.7 
5 Ag Fields 30.176 -94.638 3339414.4 342284.4 
5 Ag Fields 30.175 -94.612 3339279.2 344796.0 
5 Ag Fields 30.160 -94.606 3337578.5 345359.2 
5  Ag Fields 30.198 -94.634 3341903.5 342667.3 
6 Tide 29.758 -94.696 3293135.1 335999.7 
7 Interstate 10 Bridge pilings? 29.820 -94.774 3300160.4 328553.2 
8 industrial site 29.885 -94.671 3307191.2 338601.4 

    
WGS-84 UTM 15N 

 
NOTE:  ENVI apparently cannot display attributes as labels (such as the Site number) 
in the ENVI View. And I cannot make the “Cursor Value” Tool reveal any attributes 
from a shapefile vector point displayed in the ENVI View.  Let me know if I’m wrong.  All 
the shapefiles have to go to a GIS to be useful and to be able to be queried? 

If the vector files don’t work for you, just copy Lat, Long coordinates (separated by a 
comma) from the table above, zoom-in to the crosshair, and answer the questions 
below concerning Sites 1 to 8. 

 
4) Let’s analyze what new information is available in the Sentinel-1 radar image. 

Zoom-in to Site 1 at the mouth of the Trinity River and Galveston Bay.  If the large ENVI 
annotation numbers block your view, just unclick the .anz file in the Layer Manager.   

You can increase the size of the shapefile’s points “+” by right-click on the shapefile in 
the Layer Manager > Properties > Point Size  >  increase the size from default “8” to 
“12” or “16” or more – and you can change the color of the “+”  >  Apply > OK 
 
Answer the following questions concerning Sites 1 to 8. 
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Question 8:  Site 1.  What different type of information is provided by the radar image 
versus the Landsat natural color image for the nearshore feature with many large 
polygonal structures? 

Question 9:  Site 2:  Do you see the green pattern to the northwest of “2” on the 
Landsat?  What could cause this feature – what could it be? 

Question 10:  Site 3:  These bright dots in a line on the radar are not seen on the 
Landsat.  What is a “corner reflector” in the science of radar? 

Question 11: Site 4:  A. Why is radar more reliable for visually detecting ponded water  
   compared to Landsat that captures reflected visible light?  

   B.  What are you seeing on the surfaces of the ponds in the   
   Landsat image? 

Question 12: Site 5: A. Why are there shadows on the west side and illuminated edges  

   on the east side of the agricultural fields with the “red +” ?     

   B. Are the fields higher or lower than the surrounding land cover? 

Question 13:  Site 6:  Which image shows the tide is out (low tide):  radar or Landsat? 

Question 14:  Site 7:  This is the east-west Interstate 10.  What do you think the bright  
   dots are on the radar image? 

Question 15:  Site 8:  Compare the radar and Landsat images of the industrial ponds  
   and surrounding area.    
   A. Purple-violet on the radar image indicates what type of land  
   cover?     

   B. Green – yellow green on the radar image indicates what type of  
   land cover?   

   C.  Why are many north-south roads clearly visible on the radar and 
   east-west roads are more difficult to see? 

This exercise hopefully shows that polarized radar imager can provide unique 
information in wetlands, coastal, industrial, and agricultural landscapes.  There are 
radar systems that collect 4 polarizations and multiple wavelengths – these extract more 
information about the Earth’s surface features.  The Sentinel-1 satellite radar imagery is 
available for download at no cost from ESA. 
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Lab 12 Change Detection and Radar Polarization   Name: 

Upload the following files to the instructor: 
  
 (2)  “Your Name_chg_bandmath” jpg 
  
 (3)  “YourName_colorCCDM”  jpg 
  
 (3a) “YourName_CCDM_shp”  jpg 
  

Question 1:  A. What color is healthy vegetation in our enhanced color images  
  (SWIR–Near IR–Green as R-G-B)? 
 
  B.  September is a hot and dry month around Mt. Diablo, California,  
  and typically follows many dry summer months.  Based on our enhanced  
  color images, what features around Mt. Diablo have the healthiest (most  
  vigorous) vegetation?  
  
  C. What is the elevation at the top of Mt. Diablo?  (DEM in meters) 
 
Question 2: A. Compare the 7 September band 4 to the 23 September band 4.  Where 
  geographically do you see  the largest difference in brightness?   
 
  B. Based on what you see and can interpret, what event has the 23  
  September image captured on Mt. Diablo? 
  
  C. Based on the Landsat imagery, when did this event occur? 
 
  D. What Landsat spectral evidence do you have to support your   
  interpretation about the event on Mt. Diablo between 7 and 23 September  
  2013? 
 
Question 3:  Explain how the band math subtraction of the 23 Sept image from the 7  
  Sept image results in the area of change having such a significant   
  difference in brightness (DN value) compared to the surrounding area. 
  (Hint: think what happened to the DN value of near IR pixels in the   
  changed area compared to the DN value of near IR pixels in the   
  surrounding area). 
 
Question 4:  Which polarized band carries more information to the untrained eye – HH  
  or HV? 

Question 5:   Describe the ratio (HH/HV) image in 10 words or less. 
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Question 6:  Do you think the color composite (View 4) tells you more information about 
  Death Valley compared with the grayscale HH and HV?   YES   NO 

Question 7:  A. On the radar images there are dark features along the bottom of the  
  valley. What does the dark tone indicate about the roughness of the  
  surface? 

  B. On the HH-HV-Ratio color radar image of the valley bottom (ignore the  
  mountains on the left and right) there are bright landforms with colors that  
  grade from yellow to light purple to darker purple.  What does gradation in  
  brightness indicate what about the surface roughness of those landforms?  
 

Question 8:  Site 1.  What different type of information is provided by the radar image 
versus the Landsat natural color image for the nearshore feature with many large 
polygonal structures? 

Question 9:  Site 2:  Do you see the green pattern to the northwest of “2” on the 
Landsat?  What could cause this feature – what could it be? 
 

Question 10:  Site 3:  The bright yellow dots on the radar that cross the river in a line in 
a WSW-ENE direction are not seen on the Landsat.  What is a “corner reflector” in the 
science of radar? 
 

Question 11: Site 4:  A. Why is radar more reliable for visually detecting ponded water  
   compared to images that capture reflected visible light?  

   B.  What are you seeing on the surfaces of the ponds in the   
   Landsat image? 
 

Question 12: Site 5: A. Why are there shadows on the west side and illuminated edges  

   on the east side of the agricultural fields with the “red +” ?     

   B. Are the fields higher or lower than the surrounding land cover? 
 

Question 13:  Site 6:  Which image shows the tide is out (low tide):  radar or Landsat? 
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Question 14:  Site 7:  This is the east-west Interstate 10.  What do you think the bright  
   dots are on the radar image? 
 

Question 15:  Site 8:  Compare the radar and Landsat images of the industrial ponds  
   and surrounding area.    
   A. Purple-violet on the radar image indicates what type of land  
   cover?     

   B. Green – yellow green on the radar image indicates what type of  
   land cover?   

   C.  Why are many north-south roads clearly visible on the radar and 
   east-west roads are more difficult to see? 

 

 

 


	Lab 1  Introduction to ENVI software
	Lab 2  Landsat Multispectral Processing
	Lab 3  Image Processing
	Lab 4  Image Processing 2
	Lab 5 Band Ratios and PCs
	Lab 6 Georeferencing_ENVI-Classic
	Lab 7 DEMs and Lidar
	Lab 8 IHS and Image Sharpening
	Lab 9 Unsupervised Classification
	Lab 10 Supervised Classification
	Lab 11 Hyperspectral_Two_Options
	Lab 12 Change Detection_Radar



