Lab 9 Unsupervised Classification
Utilizes Textbook’s Remote Sensing Digital Database: Chapter 3 data.

The objectives of this lab are to learn about unsupervised classification techniques,
including naming classes, combining classes, converting the raster thematic map to a
GIS shapefile, and the importance of apply a mask to improve your classification map.
The tasks are done with tools in the ENVI Toolbox.

Two digital files are to be uploaded to the instructor and five questions are to be
answered on the last page of this handout.

1) Unsupervised Classification

We will return to the Exumas Islands in the Bahamas where in Lab 4 we created a Mask
to eliminate the impact of water on our image processing of the islands. We want to use
the spectral characteristics of the six Landsat VNIR-SWIR bands to generate an
unsupervised classification map of the islands.

Unsupervised classification uses the computer program to cluster the pixels into natural
groupings based on the spectral characteristics of the pixels with no direction from the
analyst, except for setting basic parameters such as number of classes, number of
iterations performed by the program, and minimum number of pixels per class. The
analyst leverages his/her experience and knowledge about the features being classified
so a land use/land cover name can be attached to each class and classes can be
combined. Unsupervised classification is a very fast way to evaluate the spectral
richness and mapping potential of your multispectral or hyperspectral data.

The textbook Chapter 9 has an extensive discussion on unsupervised classification.

The multispectral data is located in the “Remote Sensing Digital Database \
Ch_3_Landsat” folder, inside the “Plate_9 Bathymetry” subfolder.

1a) Start-up a new ENVI display. File > Open drive to the
“Plate_9_ Bathymetry” folder and
Open the “Original_Landsat_Data” folder >
Select > “Exumas_Bathy 1984 Landsat_6-band_clip_GeoTIFF.tif” > Open
A natural color image should display (TM bands 3-2-1 as R-G-B)

Zoom to Full Extent > Contrast stretch “Linear 2%”

Open the “Data Manager” to see the six bands.

Use the Data Manager to display a total IR color composite (4-5-6 as R-G-B)
and color IR (4-3-2 as R-G-B) > Stretch both “Linear 2%”
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1b) We will first do an unsupervised classification on the entire 6-band scene.
ENVI Toolbox > Classification > Unsupervised Classification > IsoData Classification

ISODATA unsupervised classification calculates class means evenly distributed in the
data space then iteratively clusters the remaining pixels using minimum distance
techniques. Each iteration recalculates means and reclassifies pixels with respect to the
new means.

The Classification Input File window pops-up > Select the 6-band clip > OK
The ISODATA Parameters window pops-up (see below)
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We will accept all the defaults,
except change the “Maximum Iterations” from “1” to “10”.

Click-on Help to learn what each parameter means in the ISODATA menu.
(this is highly recommended for class discussion in the lab)

Name the output file “Exumas_unsup_land-water” > OK
The ISODATA Classifier window pops-up and you will see the iteration count
being posted. The classification stops at the 10™ iteration.

Examine the classification map. Use the “Swipe” tool to compare the
classification map with the color images.

Question 1: How many classes do you see on the islands?
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1c) The ocean water and seafloor captured most of the classes in our map. We have
generated a very poor (unacceptable) spectral classification map for the islands.

Remove our very poor classification map from the Data Manager.

Now we will apply the water mask that we built in Lab 4. The water mask for this scene
is inthe Lab_9 Data folder.

First we will load our water mask into the Layer Manager.

File > Open > drive to the “Lab_9 Data” folder >

Select “Water_Mask_0-1_Off” > Open

The Black and White Mask is displayed.

Use the “Cursor Value” tool to query the DNs for the black and white pixels.

Question 2: What are the DN values for Black and White pixels in the Mask?
ENVI Toolbox > Classification > Unsupervised Classification > IsoData Classification

The Classification Input File window pops-up > Select the 6-band clip
Click-on the “Select Mask Band”
Select “Mask Band” under the “Water_Mask _0-1_Off” file name > OK > OK

The ISODATA Parameters window pops-up (see picture above)
We will accept all the defaults,
except change the “Maximum Iterations” from “1” to “10”.

Name the output file “Exumas_unsup_water-masked” > OK
The ISODATA Classifier window pops-up and you will see the iteration count
being posted. The classification stops at the 10" iteration.

Examine the classification map. Use the “Swipe” tool to compare the
classification map with the color images. Y

You may see the new classification map swiping with the B-W water mask
image. Move the “Water_Mask_0-1_Off” to the bottom of the files listed in the
Layer Manager so that the color IR or other color image directly under the new
classification will be displayed in the Swipe tool.

Zoom-in on the larger islands.

1d) Let’s look at the statistics of this classification map.
Right-click on the “Classes” folder in the Layer Manager >
Select “Statistics for All Classes” > the “Data Selection” window pops-up >
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Select our new classification map “Exumas_unsup_water-masked” > OK
The “Classification Statistics View” window pops-up

Question 3: A. What percentage of our classification map is unclassified (this is the
area in the scene covered by our water mask)?

B. Which class on the islands has the highest percent coverage?
C. How many pixels are in the class with the highest percent coverage?

le) Let’s evaluate the patterns on the classification map with different color image band
combinations (and contrast stretches) to help us interpret the features on the map

Let’s start with the color IR image in View #2 and link the two views to help
interpret the classification map. Views > Two Vertical Views >

Drag the color IR image in View #2 in the Layer Manager

Views > Link Views > Link All > OK

Contrast stretch the Color IR image with different stretches.

Right-click on the “Classes” folder in the Layer Manager >
Select “Edit Class Names and Colors” >

the “Edit Class Names and Colors” window pops-up  (see below)
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Use the “Cursor Value” tool to query the Class number. In the “Cursor Value”
tool menu Click on the “Link” and the “Display Information for Views” icons
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NOTE

Click on different colors in your classification map with the “Cursor Value” tool to
decide what feature they represent.

Zoom-in and pan to different islands.

Use the Flicker tool to compare classified map pixels to color image pixels.

Change the band combinations in View #2 and try different stretches on the
images that bring out different patterns - these patterns may correlate with your
classification map

: This is a very good class exercise with the instructor writing the class answers

on a White Board so everyone patrticipates in the decision-making.

Build a small chart and write down what you think the class represents.
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a) Where do you see Class 5, 6, 7, 9, and 10 pixels most often?

b) There are only 378 pixels in Class 8 (dark green). Tough to find! Do you see
this class in areas with very bright white sand? Maybe this is dry sand — sand on
a topographic high?

c) In the color IR and total IR images is there a trend in vegetation vigor (redder
pixels may indicate more vigorous vegetation, denser vegetation cover, or
different plant communities) that you can correlate with the patterns of Class 2
(green), Class 3 (blue), and Class 4 (yellow) on the islands?

Question 4: What types of other imagery, maps, and other ancillary information would

help you interpret the classes with more confidence?
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1f) Let’'s name the classes and combine those that maybe represent the same feature.

We will use the “Edit Class Names and Colors” menu.
In the “Class Name” window in the center of this menu, select Unclassified >
Edit: enter the name “Water” and follow this with the next 3 entries

Unclassified = Water

Class 1 = Vigorous vegetation

Class 2 = Medium vegetation cover

Class 3 = Sparse vegetation > OK You will see the new names show
up in the classification map legend (see below)

=+ Classes

------ 7 O Water

------ 7| 1: Saturated beach sands
------ J| | 2: Vigorous vegetation

------ J| | 3 Medium vegetation cover
------ ][] 4: Sparse vegetation

------ V] h:Class b
------ J|m 6 Class &
------ 7| 7 Class 7
------ 7| 8 Class 8
------ 7| 9 Class 9
------ 7 10: Class 10

To open up the Edit menu again,
Right-click on the “Classes” folder in the Layer Manager >
Select “Edit Class Names and Colors” >
the “Edit Class Names and Colors” window pops-up

Change the name of Class 8 to “Dry sand on elevated beach” > OK

1g) Now let's combine classes 5, 6, 7, 9, 10 into one class.

ENVI Toolbox > Classification > Post Classification > Combine Classes
The “Combine Classes Parameters” window pops-up.

We want to sequentially Select Class 6, 7, 8, 10 in the “Select Input Class”
list and assign each one to the “Ouput Class” 5. After we fill in the Input and
Output windows we press “Add Combination” and the combined classes
show up in the bottom window. (see below)

Your Combine Classes Parameters menu should look like is shown below.
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> OK

The “Combine Classes Output” window pops-up.
Remove Empty Classes? Yes
Name the output file “combined beach sand” (see below)
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Automatically ENVI displays the classification map with the updated legend in the
Layer Manager (see above).

1h) Now we want to rename “Class 5” to “beach sand” and change colors on our map.
To open up the Edit menu again,
Right-click on the “Classes” folder in the Layer Manager >
Select “Edit Class Names and Colors” >
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the “Edit Class Names and Colors” window pops-up
Rename “Class 5” as “beach sand”

Let’s change colors in the lower window
Just select the class and touch the color box that appears
Check “Display Result” > OK

1i) The new legend pops-up in the Layer Manager. Let's rename this map
Right-click on “combined beach sand” > “Rename Item” >
Rename “Exumas Landsat Land Cover Map” > click on Green Checkmark
Your map name and legend should look like this in the Layer Manager

[¥] 5| combined beach sand
-2 Band 1
E-i - Classes
----- m {0 Water
----- 1: Saturated beach sands

----- 3: Medium vegetation cover
----- 4: Sparse vegetation

----- 5: Beach sands

----- 6: Dy sand on elevated beach

1j) Our map has a “salt and pepper” appearance with isolated pixels and narrow strings
of pixels. Land cover maps are typically generalized with a “Majority” filter (see textbook
Chapter 9 for explanation). The Majority filter provides a more visually appealing map.

ENVI Toolbox > Classification > Post Classification > Majority/Minority Analysis

j i i i re‘ ajori inority Parameters @1
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window pops-up.
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Center Picel Weight 1 =

Qutput Resuttto @) File ) Memony
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The majority-filtered classification map is displayed on top of the original “salt and
pepper’ map.
Use the “Flicker” tool and zoom in on larger islands to compare the two maps.
Question 5: Which map (original or majority-filtered) do you like the most? Why?
In the Layer Manager, select (highlight) the majority filtered classification map.
File > Chip to File > File The “Chip to File Parameters” window pops-up
Select output format “JPEG”

Name the output “Your Name_unsup map_maj”
uncheck the Display result > Save

Upload the jpg file to the instructor.

1k) Raster classification (thematic) maps are converted to vector polygon maps to make
them more useful in GIS applications. You can add more attributes to the vector
polygon map and it is a much smaller file compared to a raster thematic map.

First we convert the raster map to an ENVI .evf vector file, and then we convert that .evf
file into the universal shapefile format (.shp).

ENVI Toolbox > Classification > Post Classification > Classification to Vector
Select the Input file “Exumas_Landcover_Map_maj” > OK
Select All Items in the “Raster to Vector Parameters” menu that pops-up
Accept Defaults (Output as Single Layer)
Name the ENVI vector file “Exumas_Landcover_Map_maj_evf” > OK

The evf vector file may show up in the Data Manager. Load into the View.

ENVI Toolbox > Vector > Classic EVF to Shapefile
The “Select Input EVF files” menu pops- up.
Locate and select your “Exumas_Landcover_Map_maj_evf.evf File > Open

The “Output EVF Layer to Shapefile” window pops-up.
Name the shapefile “Exumas_Landcover_Map_maj_vec_GIS” >Open >OK

The .evf and .shp vector files should look like this in the folder where you are saving
images and these vector files.
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f20/2019 12:06 PM
f20/2019 12:06 PM
f20/201912:05 PM
f20/201912:05 PM
20,2019 12:00 PM
20,2019 12:00 PM

|Z| EBxurnas_Landcover_Map_GI5
|Z| EBxurnas_Landcover_Map_GI5
|| Exurmnas_Landcover_Map_Gls.shp
|| Bournas_Landcover_Map_GI5.shx
|Z| Exurnas_Landcover_Map_maj_evf

|| Bxurnas_Landcover_Map_maj_evf.evf

DEF File
PRI File
SHP File
SHX File
DEF File
EVF File

147 KB
1 KB
311 KB
T KB
147 KB
309 KB
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11) With ENVI, you can superimpose the GIS shapefile on your final classification raster

map.

File > Open drive to your folder that has the shapefile

> select the file that has “.shp” as the type > Open

Right-click on the shapefile in ENVI's Layer Manager > View/Edit Attributes

Use the slider to scroll across the fields in the attribute table.

Turn off (unclick) all the layers in the View with the shapefile

Zoom to Full Extent

In the Layer Manager, select (highlight) the majority filtered classification map.

File > Chip to File > File The “Chip to File Parameters” window pops-up

Select output format “JPEG”

Name the output  In the Layer Manager, select (highlight) the majority

filtered classification map.

File > Chip to File > File The “Chip to File Parameters” window pops-up

Select output format “JPEG”

Name the output “Your Name_unsup map_maj_shp”

uncheck the Display result > Save

Upload the jpg file to the instructor.

If you have access to a GIS, display your final, majority-filtered classification raster map
and the vector shapefile. Right-click on the shapefile and look at the attributes.

You can import your shapefile into Google Earth and compare you map to the imagery

Google Earth streams over the Exumas Island
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Lab 9 Unsupervised Classification Name:

Upload the following files to the instructor:
(13j) “Your Name_unsup map_maj” jpg

(1) “Your Name_unsup map_maj_shp” jpg
Question 1: How many classes do you see on the islands?
Question 2: What are the DN values for Black and White pixels in the Mask?
Question 3: A. What percentage of our classification map is unclassified (this is the
area in the scene covered by our water mask)?

B. Which class on the islands has the highest percent coverage?

C. How many pixels are in the class with the highest percent coverage?

Question 4: What types of other imagery, maps, and other ancillary information would
help you interpret the classes with more confidence?

Question 5: Which map (original or majority-filtered) do you like the most? Why?
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