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[bookmark: _GoBack]Lab 6  Georeferencing                 
The objective of this lab is to learn how to georeference a raster file with no coordinates (named a “warp image file” in ENVI) to a raster image (named a “base image file” in ENVI) that is in a coordinate system (see Chapter 9 Digital Image Processing for discussion).  Georeferencing does not account for distortions in the input file due to topography – that requires correction with the orthorectification process which is beyond this lab. The tools for georeferencing are in the ENVI Toolbox.
Three georeferenced files are to be uploaded to the instructor.  There are two questions at the end of the handout for you to answer.
The first exercise will use a 1959 scanned aerial photograph as the warp image file and a 2000 orthorectified aerial photograph as the base image.  Portions of these aerial photographs are discussed in the textbook’s Chapter 1 (Figures 1-5 and 1-9), Chapter 2 (Figure 2-20 and Plate 4), and Chapter 7 (Plate 25).  Both aerial photographs are in the Lab_6_Data folder.
ENVI uses the term “Registration” for georeferencing.  The new “GIS-look” ENVI provides a workflow wizard to simplify the process.
[image: L:\Textbook\RSDD_Labs\Lab_6_Georeferencing\Fig 1.jpg]
However, I was unable to make the ENVI Wizard work properly – it may be a software bug or a conflict with my Windows Operating system?    Try the Wizard  - it is found in the ENVI Toolbox 	
		> Geometric Correction > Registration > Image Registration Workflow

[image: L:\Textbook\RSDD_Labs\Lab_4_Image Processing 2\Masking_ENVI_Classic\icon.jpg]Therefore, the step-by-step guidance in this lab will use the
 “ENVI Classic” front-end which never fails and is used by power users.
The concepts and steps are very similar between the ENVI Classic
and the newer “GIS-look” ENVI.  The newer ENVI just displays the
steps so they are easier to view and more steps are automated.        
[image: L:\Textbook\RSDD_Labs\Lab_6_Georeferencing\Fig 1a.jpg]
The ENVI Classic toolbar has drop-down menus that replicate the tools in the “newer” ENVI front-end that we have been using for almost all the labs.
Exercise 1.  Georeferencing a scanned aerial photograph
		                        to an orthorectified aerial photograph.
1) Using your computer’s file management system,  Open the Lab_6_Data folder and its subfolder “1_Airphotos” to view the base image and the scanned image.  You will see the orthorectified base image – it is a .tif file with the coordinate information in the .tfw file.  Double-click on the .tfw file and open with simple software that can read .txt files.[image: L:\Textbook\RSDD_Labs\Lab_6_Georeferencing\Fig 2.jpg]	
	.tfw files are attached to a georeferenced raster .tif with the same name so that 	essential coordinate information is available when the raster file is loaded into a 	GIS or image processing system.  The .tfw file we will be using looks like this:
[image: L:\Textbook\RSDD_Labs\Lab_6_Georeferencing\Fig 3.jpg]
	The 1st line is the pixel size in the x-direction in meters.  The 4th line is the pixel 	size in the y-direction in meters.  The 2nd and 3rd lines document the rotation (if 	any).  The 5th line is the x-coordinate for the center of the upper left pixel and the 	6th line is the y-coordinate for the center of the upper left pixel. 
NOTE: The .tfw does not tell you the coordinate system which is required by a GIS. Geotiff raster files can have georeferencing information (coordinate system, map projection, ellipsoid, datum, etc.) embedded in their header but if they don’t you have to make educated guesses about the geotiff’s coordinate system based on the coordinates in lines 5 and 6 of the .tfw file.  The guess relies on your knowledge about common coordinate systems used for the geographic area that is being mapped.  If you guess correctly, the geotiff  will load into the correct location using your geospatial software.
2) We are going to georeference a scanned 1959 aerial photograph to an orthorectified 2000 aerial photograph (this base image has it’s map projection as UTM 10N, Datum NAD-83).  
	First we load these two images in separate ENVI Classic displays.
	File > Open Image File   Drive to the Lab_6_Data folder	

	Select “2000_Aerialphoto_2ft_ortho_base_GIS”  > Open
[image: L:\Textbook\RSDD_Labs\Lab_6_Georeferencing\Fig 4.jpg]		The “Available Bands List” window 
		pops-up with the base image.
		Accept default “Gray Scale”
		Click-on “Load Band” 
		The base image will automatically
		load into Display #1.	
			 

	File > Open Image File  Select  “Scanned_6aug1959_Wetlands_Airphoto_Nup_”
		The warp image is displayed in the “Available Band List” window. 
		Click-on “Display #1” drop-down menu > Click-on “New Display”
		Click-on “Load Band”. The warp file will load in Display #2.
	Your ENVI Classic set-up should look like the screen-capture below.
	Each Display has a Scroll window with the entire scene, an Image window 		with the raster files displayed as 1:1, and a Zoom window.  Place 			cross-hairs in the Zoom window by clicking on the small square with no 			lines at the bottom left corner of the Zoom window.   
	Move the red outlined square in the “Scroll” window with your cursor to pan 	across the scene and look at subareas in more detail in the “Image” window.  
	Move the red outlined square in the “Image” window to look at subareas in more 	detail in the “Zoom” window.
[image: L:\Textbook\RSDD_Labs\Lab_6_Georeferencing\Fig 5.jpg]
3) Before proceeding further it is important that you visually evaluate both images to understand common features between the two images, the extent of overlap, and potential GCP locations on both images.	    Much development and environmental change has occurred in this area along the Interstate 680 corridor between 1959 and 2000. 	Look at the four sites listed below for potential GCPs.

	a) Storage tanks associated with a refinery are in both the 1959 and 2000 	images.  Look for common infrastructure in the two photographs that can be 	used for an initial GCP (seed-tie-point).   
	b) You can see a wetlands in the upper right portion of the two photographs.  	Zoom-in to the wetlands in both Views.  You can see on the 1959 photograph a 	straight channel trending NW-SW has been dredged through the meandering 	stream.  In the 2000 photographs remnants of the channels and levees 	associated with the meandering stream and dredged channel can be seen 	protruding through the water.  The 1959 vegetated wetlands has evolved into a 	water body – a large pond- by 2000.  Look for common features in the two 	photographs that you can use for an initial GCP (seed-tie-point). 
	c) Look at the lower right portion of the photographs.  You can find common 	street 	patterns in the subdivisions that you can use for an initial GCP (see-tie-	point)
	d) Look at the lower left portion of the photographs.  You can interpret a reservoir 	with a dock in the 1959 and 2000 photographs that extends into the water body – 	this is an excellent initial GCP (see-tie-point). 
4) Look at the “Registration” options in the ENVI Classic Header Toolbox.  (see below) [image: L:\Textbook\RSDD_Labs\Lab_6_Georeferencing\Fig 1 cl.jpg]
	Select GCPs: Image to Image registration means pixels in the input warp image 	are being georeferenced to pixels in the base image by identifying ground control 	points 	(GCPs). 
	Select GCPs: Image to Map registration means pixels in the input warp image 	are being assigned coordinates based on visual correlation with the grid on a 	map.
	Warp from GCPs means that GCPs are already available and can be applied to a 	warp image – no need for the remote sensing analysts to pick new GCPs
5) We will select the “Select GCPs: Image to Image” tool from the Map > Registration drop-down menu.  The “Image to Image Registration” window pops up.
[image: L:\Textbook\RSDD_Labs\Lab_6_Georeferencing\Fig 6.jpg]
	Display #1 has the Base Image.  Display #2 has the Warp Image  > OK
The “Ground Control Points Selection” window pops-up.  Press on the “Show List” button in the lower left corner to open up the “Image to Image GCP List” (see below)

                 [image: L:\Textbook\RSDD_Labs\Lab_6_Georeferencing\Fig 7.jpg]
6) Now we will start collecting GCPs.  You have to collect 3 GCPs before any automated prediction tools can be enabled by the ENVI software.  Try to get these first three GCPs (also called “seed tie points) spread over the scene.  Pick the GCPs using the Zoom Display and cross-hairs.“Predict” tool used 
after 3 GCPs are 
collected.

GCP #1:  Zoom-in to the dock in the reservoir on both photographs (discussed in 3d above).  In Display #1 and #2 Zoom windows place the cross-hairs on what you interpret as the same location on the base image and on the 1959 warp image.  
		      [image: L:\Textbook\RSDD_Labs\Lab_6_Georeferencing\Fig 8.jpg]
	If you don’t see cross-hairs, click on the right “+” icon in the lower left corner of 	the “Zoom” window.
	In the “Ground Control Points Selection” window > press “Add Point”.  You will 	see your GCP #1 fills in the first row in your GCP list window.
GCP #2:  Pan over the right side of the aerial photographs and find a street pattern that is identical between 1959 and 2000 (3c above).  Example below.
[image: L:\Textbook\RSDD_Labs\Lab_6_Georeferencing\GIS-look\Fig 7.jpg]
GCP #3:  Find matching features in the wetlands (3b) or in the refinery (3a).  
If you make errors, just delete the GCP in the GCP list and redo the point.
NOTE:  Pick GPCs at the base of buildings and tanks.  This minimizes location errors.  The tops of buildings, oil storage tanks, and tall trees can have significant offset from their location on the ground due to inherent radial distortion from the camera lens.  
7) After you have entered the first 3 GCPs, you can take advantage of the “Predict” tool.  You select locate a GCP in the base image with your cursor and cross-hairs, click-on the “Predict” button on the “Ground Control Points Selection”.  ENVI will automatically use the georeferencing information in the first 3 GCPs to predict where the 4th GCP is located in the warp image.  To make the location of the predicted GCP more accurate, use your cursor to move the cross-hairs in the warp image to the most correct pixel based on visual comparison of the feature in the base and warp images.  After you correct the predicted GCP in the warp image > Add Point.  
8) The rest of the GCPs that you select should be spread evenly around the warp image to ensure a more accurate georeferencing of the warp image to the base image.  This is a good time to review the Georeferencing discussion in the textbook’s Chapter 9. 
Question 1:  Why should you have your GCPs distributed across the warp image and not confined to one corner or arranged along a line?
NOTE:  Anytime you get confused, click-on Help in the ENVI Classic toolbar, open the Index tab, and type “Registration” in the  “Search Index” window. 
9) After you pick your 5th GCP, the GCP list fills in the cells for C and Y Error and the RMS error (root mean square).  You try to minimize the RMS error by adding more and better points that are spread across the image and by deleting GCPs that have excessive error.
To see the RMS error listed in order, in the “Image to Image GCP List” click on the “Options” button and click on the “Order Points by Error”.  The GCPs will be listed in the table with the GCPs with the largest error at the top.
To see the overall RMS Error, look at the “Ground Control Points Selection” window.
[image: L:\Textbook\RSDD_Labs\Lab_6_Georeferencing\Fig 12.jpg]
10) Pick 10 GCPs distributed across the warp image.  It is very difficult to find any control in the northeast portion of the 1959 aerial photograph.  See example below of 10 GCPs posted on the 1959 warp image.
[image: L:\Textbook\RSDD_Labs\Lab_6_Georeferencing\Fig 11.jpg]
Your final table should look something like this (see next page).  To save your GCPs, 
		File > Save Table to ASCII…  
		Name the GCP file “1959_10pts”
	[image: L:\Textbook\RSDD_Labs\Lab_6_Georeferencing\Fig 10.jpg]
11)  As noted in the Chapter 9 “Georeferencing” section, it is often best to apply a first-order (linear) polynomial transformation to digitally georeference your warp image into the map projection of your base image.  First order cannot bend the warp image – it can only change the location, scale, and skew of x and y and rotate the image.  You only need 3 GCPs to do a first-order transformation, but typically one would use at least 8 GCPs.
2nd order (parabola) transformations can bend the warp image.  This can cause pixels on the margins of your warp image to be digitally “rubber sheeted” far away from their true location.  A 2nd order transformation can minimize the radial distortion caused by the camera lens if the GCPs are well distributed and there is minimal topographic relief.  You need 6 (9 with some software) GCPs to do a second-order transformation, but 12 or more is preferred.
On the upper right corner of the “Ground Control Points Selection” window is a “Degree” window.  “1” means 1st order (linear) warp – and the total RMS Error is posted at the bottom of this menu.  Change the “Degree” window to “2” and you will see the RMS Error changes.  A reduced RMS Error for 2nd degree compared to 1st degree does not mean the warped image will look better – there may be significant errors away from the GCPs along the margins of the warp image.
For this exercise we will use a 1st degree (linear) transformation.
12) In the “Ground Control Points Selection window”, click-on Options > Warp File
   The “Input Warp Image” window pops-up.  Select the 1959 warp air photo > OK
   The “Registration parameters” window pops-up.  Choose “Resampling” as Bilinear
	See textbook Chapter 9 for discussion of resampling
	    	Nearest neighbor: retains spectral information in pixels, but is blocky.

	   	Bilinear: uses DNs from 4 pixels in base image to assign DN to the 					corresponding warped image pixel. Smoother appearance than 
			with nearest neighbor resampling.
[image: L:\Textbook\RSDD_Labs\Lab_6_Georeferencing\Fig 13.jpg]		Cubic convolution:  uses DNs from 16 pixels in base image to assign DN 				to the 	corresponding warped image pixel.  Smoothest appearance 				for the warped image.
   Accept defaults – Polynomial and 1st degree.

   Change Resampling to Bilinear

   Name the warped file 
         “1959_Aerial_Photo_UTM10_ENVI”

   > OK

	
	
13) The warped image is resampled to the pixel size in the Base image – 0.6 m or 2 feet.  The original 1959 scanned air photo was 1716 x 1716 in size.  The georeferenced 1959 air photo is ~3808 x 3808 in size.  
	To see metadata on files, use the ENVI Classic Toolbar
			 > File > Edit ENVI Header and select the file of interest.
			Double-click on the file and more information is revealed.
14) The 1959 warped air photo is listed and highlighted at the top of the “Available Band List”.  Select “New Display” and press “Load Band”.  The georeferenced 1959 air photo will be in Display #3.
15) So the warped air photo is useful for GIS, CAD, and other geospatial programs we will save it as a geoTIFF.
	Display #3 > File > Save Image As > Image File > 
	The Output Display to Image File window pops-up
	
		Ensure Resolution is “8 bit (gray scale)
		Change Output File Type to “TIFF/GeoTIFF”
		Name the file “YourName_1959_Aerial_Photo_GIS”
		
		Upload the georeferenced 1959 air photo to the instructor

	A geoTIFF file will not automatically display in the “Available Band List” menu.
16) To visually evaluate how good your georeferencing was, let’s link Display #1 (Base Image) and Display #3 (georeferenced image).
    	Display #1 > Tools > Link > Link Displays 
	The “Link Displays” window pops-up.
  	 Change Display #2 to “No” (see below)  > OK
[image: L:\Textbook\RSDD_Labs\Lab_6_Georeferencing\Fig 14.jpg]
	Roam around using the square box in the Scroll Window of either Display #1 or 	Display #2.  Appreciate the incredible development and environmental change in 	this area during the late 20th century!  
17) With the “newer” GIS-look ENVI front end, you can load the two georeferenced images into one view and use Swipe or Flicker to compare and note changes.
If you access to a GIS, load the two georeferenced images and open streaming vector and raster base maps to compare your georeferenced air photos with what is available online.
18)  Now that you have completed one cycle of the ENVI Classic georeferencing workflow, let’s try another georeferencing exercise using a 15 m ASTER satellite image and non-georeferenced jpgs of scanned 1980 wetland and 1880 interpreted wetland maps of the Suisun subregion, California created by the San Francisco Estuary Institute as documented below:[image: L:\Textbook\RSDD_Labs\Lab_6_Data\Wetlands_ASTER_SFEI_Maps\credits\sfei_wetlands map credits.jpg]
19) Using your computer’s file management system,  Open the Lab_6_Data folder and its subfolder named “2_ASTER_Maps”  The contents are shown below:
[image: L:\Textbook\RSDD_Labs\Lab_6_Georeferencing\sfei\fIG 1.jpg]
The ASTER will be the Base Image.  The 1980 and 1880 SFEIs maps are the Warp Images.  We’ll start our ENVI Classic georeferencing effort with the ASTER and the 1980 map of the wetlands.
20) First we close the airphoto displays.  “Available Band List” > File > Close All Files
 	Next we load these two images in separate ENVI Classic displays.
	File > Open Image File   Drive to the Lab_6_Data folder	
	Select “Base-ASTER_CIR_2003_15m_GIS.tif”  > Open
	Load the color image into Display #1.
		ENVI automatically loads the three bands of the color IR satellite image.
		
NOTE: The band sequence (R-G-B) is interpreted correctly by ENVI if the 	vegetation is red in the color image in Display #1.  If vegetation is bluish, the sequence of bands in the ASTER geoTIFF is different from what ENVI expected, and you have to manually correct the loading of the ASTER bands to make the vegetation red. 
	Next Select “1980_SFEI_map.jpg” > Open
	Change “Display #1” in the lower right corner to “New Display”
	The SFEI map is in Display #2.
21) Roam around the image and map and look for potential GCP points.  Railroad and road track intersections and other man-made infrastructure are good candidates for GCPs.  Look at the legends in the 1980 and 1880 folders to understand the symbology on the SFEI maps.
22) Start the georeferencing process.  
	ENVI Classic Toolbar > Map > Registration > Select GCPs: Image to Image

ENVI georeferences the warp 1980 map as an ENVI file.  Let’s save your georeferenced 1980 wetlands map as a .tif
	Display #3 > File > Save Image As > Image File > 
	The Output Display to Image File window pops-up
	
		Ensure Resolution is “24-bit Color (BSQ)
		Change Output File Type to “TIFF/GeoTIFF”
		Name the file “YourName_1959_Aerial_Photo_GIS”

	Name “Your name_1980_SFEI_GIS.tif”
23)  Open the georeferenced 1980 map (base image) and the 1880 interpretation map (warp image) in separate Displays.  
Question 2:  Why did we georeference the 1980 map to the 2003 ASTER image first – and then georeference the 1880 map to the georeferenced 1980 map.  (Hint: think about dates of the three files and look at the features (roads and railroads) common to the two SFEI maps).  
Load the georeferenced 1980 in Display #1 and the scanned 1880 jpg map in Display #2.  Repeat the georeferencing workflow.
When done, save your georeferenced 1880 interpreted wetlands map as a .tif
	Name “Your name_1880_SFEI_GIS.tif”
24) If you have access to a GIS, load the ASTER, 2000 orthorectified air photo, georeferenced 1959 air photo, georeferenced 1880 wetlands map, and georeferenced 1980 wetlands map into the GIS.  
You have created something new.  These georeferenced images and maps can be uploaded into Google Earth, ESRI ArcGIS Globe, or any geospatial software system. 


		



Lab 6  Georeferencing                          Name:
Upload the following files to your instructor:
	(15) “YourName_1959_Aerial_Photo_GIS”   .tif

	(22) “Your name_1980_SFEI_GIS”    .tif

	(23) “Your name_1880_SFEI_GIS”    .tif

Question 1:  Why should you have your GCPs distributed across the warp image and not confined to one corner or arranged along a line?


Question 2:  Why did we georeference the 1980 map to the 2003 ASTER image first – and then georeference the 1880 map to the georeferenced 1980 map.  (Hint: think about dates of the three files and look at the features (roads and railroads) common to the two SFEI maps).  

	1
	Introduction to Remote Sensing  Principles, Interpretation, and Applications
F. F. Sabins and J.M. Ellis, 2020, Waveland Press.    Contact:  jellis@ellis-geospatial.com
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