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Lab 10  Supervised Classification 
Utilizes Textbook’s Remote Sensing Digital Database: Chapter 9 data. 

The objectives of this lab are to learn how to build training sites, understand the 
parameters that impact the accuracy of supervised classifications, and convert your 
raster classification map into a GIS vector polygon file (see Chapter 9 Digital Image 
Processing for discussion).  The classification exercise will be done on a subscene of 
the Landsat 8 image used in the textbook (see Figures 9-28, 9-29, and 9-33 and Plates 
(29 and 30). This subscene is in the Lab_10_Data folder.  The tasks we will complete 
with this lab are done with tools in the ENVI Toolbox. 
 
Two digital files are to be uploaded to the instructor and six questions are to be 
answered on the last page of this handout. 

The Landsat 8 image was acquired on September 23, 2014 of Martinez, California.  The 
non-irrigated vegetation is dry.  To successfully complete accurate supervised 
classification maps the analyst must have a knowledge of the types of features that are 
being spectrally classified.  

1) Start-up ENVI.  File > Open  drive to the Lab_10_Data folder  >  Select 
   “Martinez_Landsat8_6bnd_2PC_CLIP2_ENVI_” 

 A natural color image (OLI bands 4-3-2 as R-G-B) is displayed in View 1 
 Apply a contrast stretch to brighten the color image 

 Open “Data Manager”  You see 6 VNIR-SWIR bands and two PC images (PC3  
     and PC4) 
 Let’s look at all the bands.   
 Right-click on the 8-image Landsat file in the Layer Manager > Band Animation 
  Slow the flicker down…1 second delay maybe. 

Question 1:  Which of the 8 grayscale images are most different? 

2) Let’s look at the complete statistics between the 8 grayscale images 
 ENVI Toolbox > Statistics > Compute Statistics  
  Click-on  “Histograms” and “Covariance”   Output to the Screen  > OK 

 Review the Correlation Matrix while looking at the “Band Animation” 
 
Question 2:  What features on the ground lead to the negative correlation between PC 4 
image (“Band 8”  in the correlation table) and Bands 1, 2, 3, and 4  (Hint: opposite 
graytones in the images  - one has bright pixels and the other has dark pixels for the 
same feature). 
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In the upper left corner is the “Select Plot” drop-down menu.  Select “Histogram  1” 
first, the “Histogram 2” and then “Histogram 3”. 
 
Question 3:  Are these three visible band images normal or slightly skewed to the left? 

 In the upper left corner is the “Select Plot” drop-down menu.  Select “Histogram 
 4” first, the “Histogram 5” and then “Histogram 6” – the 3 reflected IR bands. 

Question 4:  What is unique about the histograms for the reflected IR bands compared  
  to the visible light bands? 

3) Let’s analyze the Landsat scene and define 8 land cover classes.  We will then select 
training sites for each class using heads-up digitizing of polygons with ENVI’s ROI 
(regions of interest) tool.  8 is an arbitrary number for this lab.  (17 training sites were 
developed for the textbook example that used a larger Landsat scene of this area). 

 What land cover classes do you find on the image?   
 Classes should be spectrally unique. 
(This is a good exercise class exercise with the instructor copying the land cover 
classes on a White Board and everyone voting for the top 8).  

 Split the ENVI display into 4 Views and fill each with a different color composite 
 using the Data Manager and highlighting (selecting with your cursor) each View 
 to be filled. 
 Views > 2X2 Views 
 View #2 load a color IR image 
 View #3 load a enhanced color (Bands 7-5-3 as R-G-B) 
 View #4 load PC4-PC3-Band 6 as R-G-B 
 Link the Views     Views > Link Views > Link All >  OK 
 Zoom to Full Extent   >  Zoom–in  and pan around 

 Placeholder Classes for processing in this exercise**  
  1) River water 
  2) Ponded water 
  3) Irrigated grass 
  4) Dry grass 
  5) Wetlands 
  6) Suburbs 
  7) Industry 
  8) Trees (on western slopes with dry grass and deep shadows in valleys) 

 ** OK if class develops more or less classes and different classes for their 
 processing 
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4) Now we will generate training sites (ROIs) for the 8 land cover classes. 

To give yourself more room to draw training sites (ROI polygons), let’s Remove Views 
2, 3, and 4.  Right-click on Views 2, 3, and 4 in the layer Manager > Remove View 
 
NOTE:  ROIs should be neatly drawn so that the pixels inside the ROI are “pure” for the 
class being defined.  Zoom-in and draw the polygon over only those pixels that correlate 
with the class being mapped.  You should have more than one polygon for each training 
site.  Try to draw ~5 polygons over pixels that represent a class. 

Open the ROI tool (icon located at the top center of the ENVI display window) 

 

 Click on the “New ROI” icon, change name from ROI #1 to “River water”. 
  We will accept default polygon drawing tool.  
 The “River Water” ROI is displayed in the Layer Manager and in the Data 
 Manager. 

 
 Zoom-in to the feature of interest, and draw the around the pixels of interest. 
 When done drawing the polygon, double-click your mouse, the polygon line will  
 join both ends to create a closed polygon that is filled with a solid color. 

 The ROI tool keeps track of the number of polygons in your class  
 (“Record Count”).  If you want to delete one of the polygons just use the counter 
 with arrows at the bottom of the ROI tool to bring up the polygon and then you 
 can that specific polygon using the  “Delete Record” tool. 
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 When done with one ROI, just click on “New ROI” and repeat the process. 

 When the “ROI Name:” turns blank while you are mapping the ROI, just click on 
 the small down-arrow on the right to have your active ROI show up again in the 
 tool.  The name field turns blank sometimes when you use the Zoom and pan 
 tools.  
 
 Make the polygons large in the suburbs, industry, dry grass, and river water so 
 the program has the range of spectral values in the ROI. 

As an example of training site polygons for the 8 ROIs, see below:

  

 Let’s send our training sites to the instructor. 

 File > Chip View To > File   Choose Output Format  “JPEG” 
 Name the file “YourName_TrainingSites” 
 
 Upload the jpg to the instructor 

 Now we want to save the ROI file. 
 Regions of Interest (ROI) Tool > Save As > Select All Items 
 Name the ROI file “Landsat8_Martinez_8_ROIs” 

5) Now that we have our training sites, we can start the supervised classification 
program. 
ENVI Toolbox > Classification > Supervised Classification >  
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       Maximum Likelihood Classification 
` The “Classification Input File” window pops-up. 
 Select our “…6bnd_2PC” dataset > OK 
 
 The “Maximum Likelihood Parameters” window pops-up  > Click on Help for  
 excellent information on the Maximum Likelihood algorithm. 

 Select All Items > Accept Defaults except “Output Rule Images? Change to “No” 
 Name the output file “Landsat_Martinez_8class_Sup” 

 The computer crunches the numbers and displays your supervised classification 
 map 

NOTE:  Maximum likelihood classification assumes that the statistics for each class in 
each band are normally distributed and calculates the probability that a given pixel 
belongs to a specific class. Unless you select a probability threshold, all pixels are 
classified. Each pixel is assigned to the class that has the highest probability (that is, the 
maximum likelihood). 
The many other classification algorithms have advantages and disadvantages, just as 
the Maximum Likelihood does.  Open Help and search for “Classification workflow”  
Read about the different methods and review the “Classification Tutorial” 
 
6) Your classification map could look like this: 

 
This is a raster thematic map.  It has 9 classes (one is “unclassified”). 
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Let’s look at the map’s statistics.   
Right-click on the “Classes” folder > Statistics for All Classes…. 
The “Data Selection” window pops-up       Select our 8 class map > OK   
Scroll down to the “Class Summary” table (see below) 
 

 

 
Every pixel was classified. 
   
The largest class is “Industry” 
 
The smallest class is “Irrigated 
grass” 
 

 
7) As with the unsupervised classification, let’s minimize the “salt and pepper” 
appearance of this map by running a 3 X 3 majority filter across the scene. 
 
ENVI Toolbox > Classification > Post Classification > Majority/Minority Analysis 
 Choose the 8-class supervised map > Select All items > Accept Defaults  
 Name the output file: “Landsat_Martinez_8class_Sup_maj”   > OK 
 
The generalized classification map displays on top of the raw map.  Swipe to compare. 
 Let’s look at the generalized map’s statistics.   
 Right-click on the “Classes” folder > Statistics for All Classes…. 
 The “Data Selection” window pops-up    Select our 8 class Majority map > OK   
 Scroll down to the “Class Summary” table (see below) 
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Question 5:  What class lost the highest percent of pixels and what class gained the  
  highest percent of pixels when the majority filter is applied to the original  
  classification image? 

8) Move the color Landsat image beneath the majority-filtered classification map in the 
Layer Manager so you can compare with swipe and fade tools 
 Swipe the generalized map over the color Landsat image 
  (you 
 Fade the generalized map over the color Landsat image (Blend View tool) 
  These tools seen uncontrollable?!  Too fast for analysis? 
 
 Stop the Blend Tool.  Use the manual slider for transparency in the upper right 
 corner of the ENVI display.  Fade the map on and off to see what classes fit well, 
 and what classes have errors (misclassified pixels) 

 To provide colors on the 8 classes that are easy to understand (i.e. dark green 
 for trees, bright green for irrigated grass, blue for river water, etc.) Right-click on 
 the majority classes folder in the layer manager > Edit Class Names and Colors 

 Display the Landsat as a grayscale image (OLI band 5 (SWIR1) is good) to 
 provide an easy-to-understand backdrop to the faded/partially transparent color 
 classification map. 

Question 6:  A. What class(es) do you interpret as least accurate? 
 
  B. What class(es) do you interpret as most accurate? 
 
  C. Why do think some classes are more accurately classified compared to 
  others? 

9) As with the unsupervised classification, this ENVI raster thematic image is not easily 
viewed by others.  So we are going to convert it to an ENVI polygon vector file (.evf) and 
then convert the .evf to the universal .shp file.   

      ENVI Toolbox > Classification > Post Classification > Classification to Vector 
 Select the Input file “Landsat_Martinez_8class_Sup_maj”     > OK 
 Select All Items in the “Raster to Vector Parameters” menu that pops-up 
  Accept Defaults (Output as Single Layer) 
 Name the ENVI vector file “Landsat_Martinez_8class_Sup_maj_vec”   > OK 

If the .evf file does not automatically load into the Layer Manager, File > Open >  “…evf” 
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The .evf vector file should be displayed in the View.  Turn off all the raster layers. 

     ENVI Toolbox > Vector > Classic EVF to Shapefile 
 The “Select Input EVF files” menu pops- up.   
 Locate and select your “Landsat_Martinez_8class_Sup_maj_vec.evf”   
   File  > Open 
 The “Output EVF Layer to Shapefile” window pops-up. 
 Name the shapefile “Landsat_Martinez_8class_Sup_maj_GIS”    > Open    > OK 
 
If the .shp file does not automatically load into the Layer Manager, File > Open >      
  “Landsat_Martinez_8class_Sup_maj_GIS.shp” 

10)  Let’s display the hillshade DEM of this Martinez area under our land cover shapefile 
in ENVI.   
 From the ENVI display window File > Open     
 Drive to the Chapter 9 folder in the Remote Sensing Digital Database and open 
 the DEM folder 

      Ch_9_Image_Processing \ Plates 29-30_Spectral_Classification \ DEM 
 
Select “DEM_Martinez_GIS_hs045_30elev.tif”  > Open 
 The hillshade DEM displays in the ENVI View. 
 Drag the hillshade DEM below the landcover shapefile so the vectors show up on 
 top of the DEM. 

Let’s send this display of vector land cover map over the hillshade DEM to the instructor 
 File  > Chip View To  >  Image     Select “JPEG”   uncheck “Display result” 
  
 Name the vector map + hillshade DEM graphic  
 “YourName_landcover_hs-DEM” jpg 

11) If you have access to Google Earth,  import the land cover shapefile (see below) 
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 Select and right-click on the imported shapefile in the Google Earth Places list > 
 Save Place As  >  Accept default name.  > Save    
  

 Your shapefile is now in the .kmz format (a universal format) 
 Upload the kmz to your instructor. 
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Lab 10 Supervised Classification                     Name: 

Upload the following files to the instructor: 
  
 (4) “YourName_TrainingSites”  jpg 
  
 (10) “YourName_landcover_hs-DEM”   jpg 
  

Question 1:  Which of the 8 grayscale images are most different? 

Question 2:  What features on the ground lead to the negative correlation between PC 4 
 image (“Band 8”  in the correlation table) and Bands 1, 2, 3, and 4  (Hint: 
 opposite graytones in the images  - one has bright pixels and the other 
 has dark pixels for the same feature). 

Question 3:  Are these three visible band images normal or slightly skewed to the left? 

Question 4:  What is unique about the histograms for the reflected IR bands compared  
  to the visible light bands? 

Question 5:  What class lost the highest percent of pixels and what class gained the  
  highest percent of pixels when the majority filter is applied to the original  
  classification image? 

Question 6:  A. What class(es) do you interpret as least accurate? 
 
  B. What class(es) do you interpret as most accurate? 
 
  C. Why do think some classes are more accurately classified compared to 
  others? 

  

 


